X96 Max plus issues,... in new versions?

Hi guys, I would like to share with you some issues that I am experiencing with a recently two X96 Max plus boxes that I bought 2 weeks ago, I will try to describe as deep as possible my issues installing and booting up coreelec.

I will need your highly appreciated help, to resolve my issues if it would be possible.

Like introduction, I bought a year ago a 2 Khadas Vim3 pro, and this boards have exactly the same hardware… but is not the same when you buy 2 X96 Max plus… lol (hahahaha newby in android tv box hardware).

I found some hardware information using Android HW info app installed in both devices and I got the information bellow:

Generic hardware information for both devices:

  • CPU: s905x3 GPU: Mali G31
  • RAM: 4 GB
  • eMMC: 32 GB

Device 1:
Device name: Droidlogic X96Max_Plus2_M
Wifi device: mtk_sdio

Device 2:
Device name: Amlogic X96Max_Plus2_2101
Wifi device: rtl88x2cs

About boot up issues and sd-card / sd-card reader:

First issue: Following the instructions to boot up from sd-card, I have problems with moderns cards, ej:

  • Boot correctly with: Standard Kingstom 3 years old 32GB card in both devices.
  • Doesn’t boot using recently bought Samsung Evo Plus 32 GB new card in both devices.

Tips added for this behavior like:

  • Both Cards can boot up using a external USB SD Card reader plugged to USB device from two devices correctly.
  • Both Cards can be readed correctly after internal Android 9.0 is loaded from android app file explorer, copy/move/read operations without issues from both devices.

About Wifi issues:
On device 1 (mtk_sdio adapter), after coreelec boot up, I haven’t Wifi or Bluetooth detected on device but yes ethernet and all other devices without issues.

On device 2 (rtl88x2cs adapter), after coreelec boot up, I have working all wifi devices including bluetooth without any issues.

Additional tests information:

All these tests has been done with the same results in CoreElec 19.4 and 19.5rc1
DTB used in all the tests: sm1_s905x3_4g_1gbit.dtb

Additional configuration for VFD or remote works correctly in both devices.

Thanks so much in advance to everybody (in special for CoreElec team in this great work) and kind regards.

Don’t expect too much support here from Devs for X96, as there are meanwhile just too much HW permutations out there…

Thanks so much by your reply.

¿Could be possible to request that the CoreElec Team add the driver (if there is present and possible) in the next release of CoreElec?