X96 Max Plus Q2 - WiFi doesn't work


I bought a new X96 Max Plus S905X3 device and got Q2 version. Apparently it’s similar to the previous version but with a different WiFi chip.
I installed CoreELEC on it but WiFI doesn’t work, probably missing drivers for this chip.
Is it possible to add support for it?
Thank you

CoreELEC:~ # udevadm info /sys/bus/sdio/devices/*
P: /devices/platform/ffe03000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
L: 0
E: DEVPATH=/devices/platform/ffe03000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
E: SDIO_ID=0271:050A
E: MODALIAS=sdio:c00v0271d050A

dmesg: http://ix.io/2Osu
lsmod: http://ix.io/2OsI

1 Like

Same here, was about to post the same issue, hope will get support hehe

I have the identical issue with my new X96 box. Also, SOC is “unknown” - maybe there’s more than only the WiFi chip.

cat /proc/cpuinfo:
Serial : 2b0b0100011612000011363742595650
model name : Amlogic unkown_soc rev b
Hardware : Amlogic
Revision : 0400

I also have an X96 max plus Q2 box. This is their latest delivery configuration. It is the same as the problem mentioned above. I hope to get support from CE team.

Same problem.

Same. Anyone managed to fix it?

I assume the answer is “no”, so look what I’ve found:

That eric4gith guy says that the Q2 variant of X96 Max Plus is likely based on QCA6174A-3, which is supported by the ath10k driver, which in turn should be in the kernel by default:


It was first included in Linux 3.11-rc1 released on 2013-07-14.

Now I guess we only have to find/make some working dts… right?

It’s solved since 19.1-Matrix_rc4

Implemented Wifi driver QCA6174
1 Like

I am having the same issue. X96 Max Plus 4/64 running 19.2 rc2. No wireless or bluetooth. It has an FN-Link 6222B-SRB wireless ac and bluetooth module. The product page says it’s an RTL8822BS chipset. I tried running the command in Putty to get the info. But it returns “Unknown device “sys/bus/drip/devices/*”: No such device. Perhaps someone can help. This is a fresh, new install.

Can confirm, Wifi and BT work on 19.2 rc2 x96max plus q2 1000 mb, 4/32

Is there a chance, to getting work on CE 9.2.7?

I don’t think so, use CE-19.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice