X96 MAX PLUS suddenly no SPDIF/Optical output

X96 MAX PLUS 4+64 with 905x3 and COREELEC 9.2.5, also updated to 9.2.6,same issue. Installed alone on EMMC, no Android coexists although I don’t think EMMC installation is a problem.
Recently discovered no SPDIF/Optical output on my X96 MP, tested speaker with another SPDIF input, speaker works fine. Checked the cable, when connecting to X96 red light is visible, so how can I confirm if it’s a software setting issue or sth. wrong with the hardware? Used to works, no setting modified. Changed channel to 2.0 (always 2.0 in fact), no use.
Log here:http://ix.io/2Tuj, if needed I can do another one, just let me know.

result of aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: AMLAUGESOUND [AML-AUGESOUND], device 0: SPDIF-B-dummy dummy-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: AMLAUGESOUND [AML-AUGESOUND], device 1: TDM-B-T9015-audio-hifi T9015-audio-hifi-1 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: AMLAUGESOUND [AML-AUGESOUND], device 2: SPDIF-dummy dummy-2 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: AMLAUGESOUND [AML-AUGESOUND], device 3: TDM-C-dummy dummy-3 []
Subdevices: 1/1
Subdevice #0: subdevice #0

result of aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=AMLAUGESOUND
AML-AUGESOUND,
Default Audio Device
sysdefault:CARD=AMLAUGESOUND
AML-AUGESOUND,
Default Audio Device
surround71:CARD=AMLAUGESOUND,DEV=0
AML-AUGESOUND,
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=AMLAUGESOUND,DEV=0
AML-AUGESOUND,
IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=AMLAUGESOUND,DEV=0
AML-AUGESOUND,
HDMI Audio Output

Extra info:
X96MP—HDMI–>TV—coax cable—>speaker=works
X96MP—optical cable—>speaker=no sound
I can confirm the optical was working some time ago, did not touch anything except update CE from 9.2.3 to 9.2.5, don’t know why.
why must optical? 'cause I’m listening music on X96MP and it’s stupid& overkill to turn on TV just to listen music…

I have a similar problem with my X96 air (also 905X3). Since 9.2.5 or 9.2.6 I have to unplug / plug the optical cable to my receiver, otherwise there’s no audio.
I don’t think my receiver is to blame as it started with a CoreELEC update >1 month ago…

Have you tried if the unplug / plug routine works for you too?

Tried plug/unplug on both speaker side and X96 bot side, no use. Still no sound. I can see SPDIF in audio output, but select it has no use. Used to work, weird…
Screenshot:
op.png

Please try first in Android if it still works!
Maybe the hardware is faulty.

Thx, I have deleted Android already and love CE on the box, so no way to test it on Android. looks like I have to live with this issue.

Does it work if you go back to 9.2.3?

Try a clean install on a sd card to rule out software side.

Matt

2 days ago, the same problem here, X96 Air S905X3. Optical cable in and out sometimes work, as well as rebooting the optical device (Home Cinema set)

In Android no problem, with older version Coreelec on sdcard (9.2.4) also no problem. With Coreelec 19-rc1 the spdif problem exist.

Is this the solution ?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice