X96 max+ revision AI - ICPlus_IP1001 (lan is not working)


Please give us all a favor and DO NOT BUY ANY X… device!

I would expect support from trying to fix the problem. That can’t be that hard.
could this not be used?

Then please feel free to fix the driver and make a PR, thank you very much for your support.

1 Like

The driver was not updated to include IP1001M support.
The only thing you can do is ask box vendor for the source code.

Vendor is not responding. :frowning:

Not a big surprise…

1 Like

The vendor here told me he would get the IP1001M driver in a few days and bring it to me

1 Like

They gave me the file and I uploaded it in MEGA. I cannot say it would work but I’ve tried my best.

link: 83.6 KB file on MEGA

1 Like

Is this dtb usable as dtb.img in the root of CE sd/flash?

I’m not quite sure. But no worries 'cause I’ve made a contact with the manufacturer (Taiwan IC plus) and they would send the linux driver to me


Here it comes~ I called IC plus tech support and got this!

Filename is “IP1001M_Linux_v1.0_20130207.tar”


Can you please add provided driver to kernel for master branch? Thank you.

I am not sure, as the driver already exist:

When we just overwrite it maybe some other users do break…

please try this or at least some devel version for us


Please try this or at least some devel version for us. Old version of driver is from 2007, new version is from 2013. I suppose this new version covers every IC+ 1001 chips modifications.

1 Like

It could happen to be honest. If necessary I would like to test the new firmware and report anything wrong I encounter.

1 Like

I tried to overwrite the original driver with the one included, but unfortunately there were errors. it seems that more things depend on the original. It would require more adjustments. I hope someone looks at it.

1 Like

I suppose only Portisch can do this job.

Hi. I’m not good at english.pls understand my english using a translator.

I want to ask about x96 max plus.
I bought x96 max plus not too long ago, and this stuff bothers me. I didn’t know this item was being distributed in multiple versions by changing modules. The version I bought is the ‘x96 max plus2_AI’, but coreelec sd card booting does not work on this version of firmware(x96 max plus2_AI-20210928).
The Ethernet module is ‘IP1001m’, wireless and the bt module is ‘am7256’. Can you help me install coreelec through sd card?
I’ll upload the firmware that I have.

*this link is list of version.

I see that it’s becoming trendy around here.