X96 max+ revision AI - ICPlus_IP1001 (lan is not working)

Hi. I’m not good at english.pls understand my english using a translator.

I want to ask about x96 max plus.
I bought x96 max plus not too long ago, and this stuff bothers me. I didn’t know this item was being distributed in multiple versions by changing modules. The version I bought is the ‘x96 max plus2_AI’, but coreelec sd card booting does not work on this version of firmware(x96 max plus2_AI-20210928).
The Ethernet module is ‘IP1001m’, wireless and the bt module is ‘am7256’. Can you help me install coreelec through sd card?
I’ll upload the firmware that I have.

https://4pda.to/forum/index.php?showtopic=1013103&st=40#entry102780026
*this link is list of version.

I see that it’s becoming trendy around here.

Its easy, boot CE from flash disk (usb 2.0) and move CE to nand using ceemmc -x command in ssh (How to use the Team CoreELEC ceemmc tool). CE will be booting from nand, remove your flash disk and enjoy. But LAN will be not working, because no lan driver is in CE yet for IC+IP1001M chip.

Are you sure it’s a good idea to perform a n internal installation on such a device with no support for networking yet? SD card installed CE its a safe and easy way to go. Network by ethernet could be easily solved by using an USB to ethernet adapter or an wifi dongle.

Wifi is working on this box.

Thank you for reply. I’ll try as you told me.

Dear all please try this test image. Maybe it start working with 1GBit, not sure:

It’s 19.3-Matrix nightly status. So please be sure to updated already to CE-19 before update to this image.

update by SSH:

cd .update
megadl https://.....
sync
reboot
1 Like

Thans for your work and time, but no success here, lan is still not working… :frowning:

Please dump Android DTB. Search the forum how to dump it please.

Log:
http://ix.io/3CuJ

Dump later, I must study how to…

Here is the original image from the vendor:

Here is the DTB file.aml_dtb.PARTITION (83.5 KB)

please try this first:

maybe cut DC power once after update

No success. :frowning:

Than it’s not the driver as the init is now the same as your source

Ok. I have 2 boxes with IC+. Result is the same in both. Where could be the problem?

-1 in motivation. The vendor did encrypt the firmware. Nothing to read. Maybe you can try to dump it on running Android, not sure…

1 Like

Last idea:

1 Like

dtb failed to pull in better form is encrypted. Even this last image did not work. It probably doesn’t have an easy solution. And it’s time to give it up. but thank you for your effort

1 Like

Thanks a lot for your support.Maybe sometimes later the solution will be found.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice