X96 max+ revision AI - ICPlus_IP1001 (lan is not working)

Hi, I assume that still no luck in implementing the IC drivers into CE… In the meantime, May I make it work at 100M easy way? Wireless works with any issues?

THX

Try to put this command to autostart.sh, ethtool -s eth0 speed 100 duplex full
Wifi is ok in this revision.

This revision = 19.3 I assume…

May I access to the autostart.sh file using a card reader in windows?

It will be far more easy to edit this file in a windows editor than using coreelec… I think…

Thanks

Nope.
Filesystem is ext4

You have the option to create the file using windows and copy it via SMB ore SFTP.
Be sure to use linux format and check attributes via SSH after copy.

Best choice ist using SSH to create and modify autostart.sh
It´s no rocket science

Hello, good evening, is the first message I wrote. yesterday I got the X96 max + AI review and it is not working at all, it is very slow with the cpu with very high values and a lot of lag. I start it from a USB 3.0 and sometimes the coreelec screen stays the flashing letters and after several hours it does not get started (in android I have slimboxtv 12.2).
I will be attentive to the thread and if you want me to try something tell me.

Check the usb disk or try another one. Or try ceemmc tool to start CoreElec from nand.

Try with another 16gb usb3.0 pen the version “CoreELEC-Amlogic-ng.arm-19.4-Matrix_nightly_20211029-Generic.img.gz” with the device_trees “sm1_s905x3_4g_1gbit.dtb” and the “sm1_s905x3_4g” a 5ghz connected to the internet. and it keeps going bad, slow and unstable.

I have already installed it in the internal memory (mmc) and it seems to go a little faster, but the bluetooth does not work, it recognizes the headphones but it does not connect and the wired network does not work either.
any solution to the bluetooth?

Gigabit Gigabit Ethernet: ICPlus_IP1001 and no driver in CE (lan not working). Can you implement the driver for this lan adapter? bluetooth detects it but does not allow pairing, THANKS. I have the X96 max+ AI review.

Hint: never, never buy any X… device!

By the dtb dump of @Borec1 it was possible to add a option in CoreELEC settings to enable IP1001 support. This option should be become available for sm1_s905x3 devices. Default setting is ‘n/a’ (not assembled). When set to ‘assembled’ gigabit LAN should start to work.

The option is supported since CoreELEC Nightly, 15.12.2021.

3 Likes

Unfortunately I have a similar problem. CoreElec Works OK but the speed of the wired connection is only:
ethtool eth0 | grep -i speed
Speed: 100Mb / s
Is my purchased (X96max+ 4/64) only 100Mb / s?
I used the sm1_s905x3_4g_1gbit.dtb file and the CE starts up correctly but only 100Mb / s …

  1. DO NOT BUY ANY X… DEVICE
  2. try tomorrow with new nightly and with IP1001 enabled. Maybe it works
  3. If still not working send it back

If you got 100mbit right away and there was no problem with DHCP then you have a good revision. And either you bought a 100mbit device or you have the wrong cable or switch.

1 Like

Yes I know X96max + it was a bad choice :frowning:
but I will not return it anymore because it’s a waste of time.
On today’s CE: 19.4-Matrix_nightly_20211214
I don’t have the option: IP1001 Ethernet?

Ps. @Borec1 you are right !!! :heart_eyes:
I was sure about this cable and here is such a surprise.
Fortunately, I had another one and everything is fine now.
Sorry for the confusion
@Portisch thank you for your help
CereElec is great !

I confirm that X96m+ rev. AI with IC+1001M lan is working now as gigabit. Thanks a lot @pocitacnachate, @Borec and @Portisch.

Its Xmas present for a lot of holders of this box.

Great job!

1 Like

Wow, it’s a great news, now waiting the same fix for nexus nightly :grin::+1:

Nobody told me nightlies aren’t build anymore since 20211208

1 Like