X96 max+ revision AI - ICPlus_IP1001 (lan is not working)

Yes, it happens periodically…

Is it possible to backport this solution to CoreELEC 9.2.8? I’m still using this as my daily driver because of compatibility issues of some add-ons (and python 2.7).


Well, it’s not 31 december 2021 yet …

A small backported patch to support this hardware on 9.2.x could still be on the table

Then hurry up and get the PR ready to be merged!

In mean time I will go with my kids buying a Christmas tree.

Thanks for the tip Portisch and enjoy your well deserved quality time with your kids!

I don’t have the skills to merge a PR unfortunately to create a new patched version of CE 9.2.x. Who could help me out please??


which CE version are you talking about?

I have the same tv box and I really appreciate your help to make it work.


Already a big thanks for the offer. It would really save my precious setup!

I’m running my X96 Max Plus box on CoreELEC 9.2.8 (Kodi 18).

i had similar issues with x96 max+ (i dont think it is the Revision AI), but the LAN stopped working a couple of weeks ago and wifi worked. intially troubleshooting was just reboot router, but it didnt connect on LAN.

finally had time to troubleshoot, and reading this thread and the fix was to copy the DTB from device tree folder into root and it worked again. I am not sure why the dtb in root changed.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.