X96 mini boot

i have just bought an x96 mini ,i have downloaded the amlogic image for the x96 mini 2 gig,it wont boot ,i have tried usb and card still nothing.tried toothpick, terminal em just a blank screen or the boot options to update from external then nothing .i have tried the 1 gig image as well same result.i bought from a reputable vendor (droidbox) never had an issue from any of their devicescorelec

With the toothpick don’t wait until the menu, press it only for 10 seconds until the X95 logo apears.

i have tried numerous times when i hold in the toothpick with the sd card/usb inserted the screen stays blank no corelec logo its only when i tried without card in that the menu appears ,tried update from external.i have checked with cpz its amlogic p281 2 gig so img is correct so maybe its just the box thats the problem

I don’t think that you are so lucky with both bad usb and sd cards for this box, but try different sd and usb card one more time.
And what android version installed on this box?

android 7.1

Don’t know that is an issue…
But you can try different sd and usb card for test as I said earlier.
Also you can try to install 9.2.0 or 9.0.3 versions and if they started then update to latest

thanks, matey I will try an older version :wink:


tried 9.2 ,9.03 on different usb still nothing doing must be the box ,going to see if droidbox have locked it or just faulty ? no issues with android on it

Have you tried whith another android firmware?
With an internet update on my two X96 Max boxes the ethernet adaptor stoped working on both.

Have a quick read of this Coreelec does not boot in X96 mini there were some supposedly x96 minis with a rockchip that wont work. I set one up for my brother that needed a different dtb.img file I will see i can find the post try the one for the x96 that might be the one. I have set up around 10 of x96/x96 minis and find then reasonably good for the money. Some have them have been running for two years the main problem I find is the SD cards get corrupt so now I normal install to internal.


I am having the same issue (and posted about it in an other thread already - but thread awareness differs, so I will reply here too).

I checked with multiple (micro)SD-cards, all recognized properly but booting stucks in the initial boot screen - so CE already tries to boot but fails somewhere. Using that very cards on other boxes here (with other dtb’s of course) boots properly. Tried all 281 and 212 dtbs offered by 9.2.1 stable and nightly of today.

The device oddly is fixed to 720p on my TVs (and also in the preinstalled KODI). I copied the /dev/dtb.img (256k sized) but this does not help booting up CE. AIDA64 shows it is a “real” amlogic not an rockchip.

Coreelec should really somehow write a debug.log so one could narrow stuff down more easily.