X96 mini Power Off not working

Installed the update, it has no effect on switch off. The led stays blue, the hdmi output is still active. Also tried “poweroff -p” from a ssh terminal, same behaviour.

What means hdmi is active? Is Kodi on screen or is it black? I have no such hardware and can’t check it in more detail. The p281 device I have does support suspend after inject bl301 with all features. Before inject it just resume as the “old” bootloader have no suspend support.

Only a UART log will lead to a solution I guess

I have a monitor with multiple inputs, if one input becomes inactive the monitor switches to the next input - which is in this case my pc. If i start the x96 mini in android mode and push the “power off” then the led goes to red and my monitor switches to my pc as the next active input. If i run it with CoreElec and push the “power off” then CoreElec stops, my ssh connection is saying: “connection lost” and the monitor only gets black with the backlight still switched on it and stays on this input. If i then pull the power plug of the X96 mini the monitor switches to my pc. The same behavior on my TV.
Would that help if a make pictures from the board itself?

You should update the bootloader, install android 9 and try again…

The box was delivered with Android 9 installed on it, if i run it with the installed Android the “power off” works correctly.

I understand now what you ment, installed android 9 and the original bootloader from scratch (X96mini_RP_20200831-1031-SV6030P.img).
Now i can power off (LED goes to red) and on (LED goes to blue) with the original android 9 again… but after installing CoreELEC-Amlogic-ng.arm-9.2-nightly_20210116-Generic with gxl_p281_2g.dtb as dtb.img it is the same again, so if i am switching it off it goes to a zombie state, LED stays blue, the attached usb harddrive stays on. To switch it on again i have to pull the power plug. Same with suspend. Instralled CPU-Z, it states Model: X96mini_RP (ampere), Board: ampere. I saw an older X96Mini, there was: Model: X96mini (p281) , Board: p281.
Is there any known Box with this “ampere” board? Should i try some other device maps or other images (like Odroid or Potato or whatever)
I have the latest original image now, can this help somehow?

I installed the original sw+ bootloader, then “CoreELEC-Amlogic-ng.arm-9.2-nightly_20210120-Generic”. I started inject_bl301 from a remote shell. Status after pressing:
“Power off system” : LED stays blue, attached USD-HDD stays on, HDMI-output switched off
“Suspend” : LED stays blue, attached USD-HDD stays on, HDMI-output stays on,
“Reboot” does the same as “Power off”
The box allways wakes up.
After i started inject_bl301 and boot in android mode, it is not anymore possible to start the box with the remote - before it worked ok.

You have wrong IR code setup

Thnaks, corrected “config.ini” according to the howto, unfortunately at the end: “sync && reboot” the box does not reboot, it stays in this funny zombie state. After replugging power comes up but on-off behaviour remains the same.

Thanks and sorry - i will slowly get to it…


system logs:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.