X96 mini remote went retrograde after 19.1

I have an X96 mini S905W 1GB RAM. It works well with build 19.1.0 compiled 2021-5-12 using the gxl_p281_1g.dtb. With later builds, including the latest release candidate, the remote control does not work. The only issue I have with build 19.1.0 is that if I turn the box on before the TV, I get a green screen and have to cycle power on the box. I realize this may be an issue with the TV rather than the TV box.
So, I’m wondering if anyone has had luck with current builds and the remote control for this device, and if so, is there another device tree that they are using?

Look about *.toml extension.


Thanks. I do have an X96 remote profile at


With build 19.1.0, it works without the .toml extension (or maybe it is just ignored, and the remote works). With later builds, the remote is not recognized. I tried it with the keymap both with and without the .toml extension. I can just stick with build 19.1.0. I suppose this is more of a development issue than an installation issue.

My remote works fine with build 19.1.0, but doesn’t work with any later builds I have tried.

It’s for sure a configuration problem as on other users it works without issues:

Maybe try another config from this collection:

Thanks a lot. I got it working. I think the problem was just that I forgot that when I set it up before that I manually added the config to the driver. So I followed the meson-ir guide and got it working. It seems to work both with and without the toml file structure

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.