X96 mini (S905W) MPCM with amlogic-ng 9.2.5 - no sound

I have a x96 mini with 1/8GB. This is a S905W based device and it was running the amlogic build with the 3.14 kernel. The device is connected to an older Yamaha AVR that supports only decoding of AC3 and DTS. So with this setup I had the audio output device set to “ALSA: AML-MESONAUDIO, HDMI” and had Passthrough for AC3 and DTS enabled.
This worked for all of my video files from Stereo up to DTS-HD and Dolby TrueHd. Everything that was not enabled for Passthrough was send as multichannel PCM to my AVR and was working as expected.

I wanted to test drive the amlogic-ng build and installed current v9.2.5 onto this box.
And today I wanted to watch a movie and had no sound. Settings are the same as with the none ng build. While searching for a solution I tried several combinations of audio settings, enabling, disbaling, and switching different options one by one and then testing the movie with the new settings again. I was not able to find a working combination of audio settings.

I have looked into several threads but I am still not able to solve my problem. I believe I have the exact same issue as @Joe_90 describes in the “Coreelec amlogic-ng 4.9 kernel for s905x s905d s905w thread”

For evaluation I searched for video files that have E-AC3 and TrueHD audio tracks. Playing them in the amlogic-ng build results in no sound. Even after wiping SD and doing a clean install, no sound. I then wiped and re-installed the none ng (old kernel) build and played the same files. They were working just fine with my settings posted above.

I don’t know how to proceed from here. Is it likely that there will be an update that fixes this?
If there is any way I can help in fixing this, please let me know.

Thanks for reading
kp

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.