CoreELEC Amlogic-ng(4.9 kernel) for S905X/S905D/S905W - FunHouse builds

Installed the update ok, but still no 5.1 audio from my multichannel FLAC files. Plays 2.0 FLAC at all resolutions up to 192KHz, but mute on 5.1 audio. It’s a Venz V10 Pro (S905X with 2GB/16GB). Posted back in March 22nd and earlier about this.

For LPCM to work, you need to select the PCM audio device, not HDMI.
And also set the channels to 7.1

Unfortunately no. Everything looks as it should and why it does not boot CE after initial installation, I don’t understand…
Is your Android rooted, or can you root it? With rooted Android you can use a simple app from the Play Store that directly reboots Android to CE on uSD card:
Reboot to LibreElec”. It runs the “reboot update” command as root. Can you try it to see if there is any difference ?

I think you have same problem as my. Try to boot it in textmode (set it in config.ini)

If that video is showing the true colours you see on screen then there might appear to be a graphic problem.
Maybe booting in text mode will work, (as advised above).

Thanks for responding, but it doesn’t work for me. When I selected PCM audio and set the channels to 7.1, the default passthrough device (greyed out) was still the HDMI audio device. I tried with passthrough set (I know this is not relevant for LPCM, but my AV amp is capable of all Dolby/DTS variants) and with passthrough switched off. Either way 2.0 audio is perfect at all resolutions but multichannel (5.0 or 5.1) audio is silent. Debug log etc. is at if anyone cares to take a look.
I’m running from micro-SD card but I do have an older LibreELEC installed on my internal flash (it’s kzaqs build).

Yes, we probably have the same problem! :anguished:
I have read your old posts and I am in the same situation, and I have a TV box similar to yours (s905x / 1Gb ram / 8Gb rom / Android 6).
In text mode it works, but if I try to start Kodi it freezes and the terminal no longer works.

LPCM != passthrough. Passthrough is for bitstreaming formats, such as Dolby Digital and DTS.
You can’t passthrough formats like FLAC, so the system is using multichannel pcm.
I’ve tested LPCM, and it works fine for me, not sure why it doesn’t for you.

In the video the colors are not exposed correctly, but on the screen they are displayed correctly.

Thanks @TheCoolest - I know that passthrough is for DD and DTS etc., which is why I said it wasn’t relevant for LPCM, but I just wanted to show that the passthrough device option retained the HDMI setting (greyed out) and that I tried with and without passthrough set. The standard builds from CoreELEC (non-4.9 kernel) work fine with LPCM and HDMI device set. It may be that my internal install of LibreELEC is causing some issue perhaps? I’m reluctant to blow that away because it works so well with all my audio and with my DVD iso’s. Since Kodi 18, I have had issues with DVD menu handling, but this seems to be a core Kodi issue, not anything to do with the builds. With my particular piece of Chinese crap I may just have to stay on kzaq’s build!

I have old build of coreelec-on-gxl branch which use hardkernel-4.9 sources and it work well on my box. But when CoreELEC team switched to amlogic-4.9 kernel it work only in textmode. I think hardkernel sources has commit which can fix our problem, and it related to graphic part. Maybe @cdu13a can help, I can give any needed logs.

1 Like

I will take another look at this some time later this week. I have to knock a few more things off my todo list before I can get to it.


I’ve decided that I’m wasting my time with my particular S905X considering I need to have LPCM working with my high res audio, plus the DVD navigation issues since Kodi 18 caused (I think) by the detection changes with still images in menus. So, I’ve placed an order for the Odroid N2+ CE edition, which should be coming into stock next week in the HK UK distributor. Hopefully, shifting to a standard supported platform will eliminate most of the niggles.

GXL is not less supported than the Odroid N2.

1 Like

I think the answer to that is - it depends! I’ve had no success with my multichannel FLAC audio on the new kernel. Works fine on an old LibreELEC build, but I’m then stuck on a two year old build. I think a new TV supporting 4K might be required to take full advantage of the N2, though. Need to persuade the boss… :wink:

Are you sure it is working on N2?

I believe so, Ray. Board is due mid-week, so I’ll know for sure soon :grinning:

Box arrived a short while ago. CoreELEC 9.2.3 already installed on MMC. Did a quick power up and some basic config - all good. Tested some of my multichannel FLACs - perfect!
I’m using an RF remote with USB dongle for navigating menus. All good except the power button won’t turn off (or on) the N2+. I need to do a bit of searching on the forum.

1 Like

@Joe_90 Use a kodi remote app via your phone!
Use the same network.

1 Like

Got exactly the same problem as @B1oHazard and @notFound - bootloop.
All I can see is CE logo and version in top left then bootloop.

MXQ Pro 4k
S905X / 1gb ram
Android 6