Youtube addon broken

Cees this instruction finally worked for me.

Thanks.

Shoog

1 Like

some says you have to create a new user (don’t use the default one),
to put the API key, to me, the easiest way is this one:

For me creating the own API key, user id and secret as described above worked so far, however all videos under “My Channel” don’t play. I can see them all but when I choose one of them, after a few seconds of rolling the app just resumes at the list of my videos.
All other videos, e.g. those under my subscriptions or in the search results do play.

Anyone here seen this?

I created API key, user id and secret key, I entered in youtube, I registered the device, it works immediately. I could watch the trailers for movies or serials. but after 3 days it didn’t work anymore.
Do you have any idea.

I created my own API keys about three years ago and have never experienced any issues with the YouTube addon since. It’s my most used addon, daily, and all working flawlessly here with my channel subscriptions, playlists, likes, dislikes, etc.

Yes, it’s a bit of PITA to set it up, but well worth it!

Also, the API keys are quite long and you can easily make a typo when entering them into the YouTube addon settings. Not to mention time consuming! I learned this the hard way after I couldn’t log into my YouTube account with the keys I “thought I was being very careful with.” So, in order to avoid typos and to have the ability of entering all those API keys (3 of them) within SECONDS, I use a tool to do it for me.

Considering you will be creating your API keys from a computer, then the easiest way is to:

  1. Copy the API keys from your computer
  2. Paste them into a Chrome extension called Kassi-Kodi/XMBC Remote Control
  3. Send this text direct to CoreELEC’s YouTube addon, so you don’t have to manually type them

All you have to do is enter your CoreELEC’s IP address and TCP Port 9090 into the Kassi settings … it’s that easy. I use this method for sending over all sorts of API keys, YouTube, TMDB, TVDB, etc. etc.

Cees, fantastic, exactly what I needed as help. Just wanted to say this so maybe the most simple solution can be used by most. Great!!!

The API key is located at \ ‘ip of coreelec’ \Userdata\addon_data\plugin.video.youtube\api_keys.json
Just use a notepad++ app to input the API key, Client ID and Client secret and save the file.

1 Like

You can even copy this file to another device, works fine.

the link is broken “russian bride” insteed -_-

This one does the same job:- https://shorturl.at/kpC68

I dont think it is API issue, more like symlink and dependency when compiling inpustream:

2020-04-13 12:31:58.182 T:3451904896   ERROR: ADDON: Could not locate inputstream.adaptive.so.2.4.2
2020-04-13 12:31:58.182 T:3451904896   ERROR: IAddonInstanceHandler::CreateInstance: inputstream.adaptive returned bad status "Permanent failure" during instance creation

After CE update to version with newer kodi binary addons, youtube works again fine (using own keys for long time)

I run the YouTube add on (with API keys) for trailers but can’t get the sound to work. I get sound every 5-7 seconds, then it’s silent, some sound, silent. And so on for a full trailer. Otherwise sound works on the system (Odroid N2) with no problems, it’s just anything I run in the you tube add on. It’s also sound stutter using the other functions directly in the add on. I run 9.2.2 now when tested. Also done a update of the add on but that didn’t help.

It’s possible that you use AVR via HDMI and audio track is AAC.
In that case you need to choose HDMI Multi Ch PCM in audio settings

@Cees, I did an API installation yesterday anyhow since I have problem with the sound staggering in the add on, but that didn’t help for the sound either… :frowning:

In CoreElec you mean? Not in sound bar or TV? Just that all other sound I run I have no problem and I’m sure some has AAC. But of course I will try that, sounds promising, but in CoreElec settings?

In Kodi setting part: System->Audio settings


danlun

boot2k3

2m

In CoreElec you mean? Not in sound bar or TV? Just that all other sound I run I have no problem and I’m sure some has AAC. But of course I will try that, sounds promising, but in CoreElec settings?

Great, thx, I will try!

Hi boot2k3 again. The test is done and I had Multi PCM already. I switch to some others, tested, no sound and switched back to multi PCM and I get some few seconds of sound and then silence for a long time and a occasional stutter of sound again… This add on was working on 9.2.1 for a long time but approx 14 days ago it started like this, I think it started when I got the problem with the API keys. Then when I got it working again this problem occurs. I was hoping 9.2.2 would solve it but not. And also if I did the full API thing also which I did on 9.2.1 a couple off days ago, but that wasn’t the solution either.

Seems that YouTube have set things such that only a valid API key works now. None of the quick fix solutions work any longer.

Update: Finally got my API’s configured. Quite simple really. Had issues before because Google Console was logging me in on my wives gmail account and then I was trying to use my tablet with my email account to verify the API. Need to make sure that the computer you use has the same gmail as the device you you use to verify.

Shoog