Youtube addon broken

Hi all,
The general keys for Youtube seem to be blocked from a few days ago, this breaks the youtube addon. Does anyone know a solution.

Shoog

1 Like

Seems some API issue. Read this: https://forum.kodi.tv/showthread.php?tid=348464&pid=2925479#pid2925479

So where are the instructions on how to generate the necessary API keys ?

Seems it is here, looks complex:

Shoog

it really is a pita. but i can confirm its working.

First attempt failed.

I can confirm that creating a personalised key gets this working again. I’m guessing whoever created the app had their project expire or deleted it.

1 Like

Hi all,

Tried to follow the steps and got to this step:

Now when I click on Credentials I do not get this screen:

Imgur

but this screen instead:

Can anyone help me out with what to do next?

TIA

Greg

Have just followed this guide here: http://shorturl.at/dELT9 very easy to achieve the 3 logins needed.

2 Likes

Thanks, that helped.

1 Like

Thanks a lot, it really help. But after the 2nd code to google.com/device, my N2 completly freeze with the screen with the 2nd code, it was validate on the google side. After unplugged/plugged reboot I can play trailer from kodi, but research on the youtube app show nothing, with no error message :s

ok everything work fine now: in a blank research on the app I heard that there is elements hidden when I move down with the remote, I just push select on the remote and the all list appeared. When I quite and make a new research, no blank screen. I retrieve also the hidden icon to install a plugin [edit] came from the “dumb” Laura skin option kiosk (now I know what it is doing), maybe there is a link with the hidden research element, try to active kiosk again, change nothing on the youtube app [/edit]

I did everything according to guide, but I have problem at the very end, where you have to login twice. I go to “google.com/device” (on my PC) and use code from TV screen youtube app. When I come back to TV, there is nothing I can do, only press cancel. Then when I want to login to youtube addon, it says wrong api. I triple checked all 3 passwords. Any help ?
Thank you

Start again from step 1. I think I have to repeat my authorization three times until I succeed :slight_smile:

OMG it took me one hour to input all the api keys using remote control :flushed:

1 Like

Far easier ssh ing into device to copy an paste into the userdata/ addon_data/ youtube/ setting.xml from pc.

I am getting the same.

Loginexception:[401]invalid_client
Client is is incorrect

No matter how many times I try, I get the same every time.

UPDATE: I ensured that only ‘Enable personal API keys’ is selected and not ‘Allow developer keys’ or ‘Enable API configuration page’ and it works.

For those wanting to copy and paste to settings.xml via SSH, the lines to look for are:

setting id=“youtube.api.id”
setting id=“youtube.api.key”
setting id=“youtube.api.secret”

Does anyone know of a different working movie trailer addon?

Tried HD-trailer and, imdb trailers and both are DOA on my N2.

I suspect that you might be better off starting a new thread for this as this one is quite specific and you may miss out on a prospective larger audience to give their thoughts.

So I did all the steps again from guide above and it worked this time :slight_smile: Actually I didn’t even have to login to Kodi Youtube addon - just entered 3 API keys and it worked right away.

Go to the YouTube addon, settings/api, switch off “use personal api”
Choose “use api key” set 5.
Click Ok,

Now trailers wil work again.

1 Like