3D Frame Packed (MVC) output with CoreELEC?

I would like the most current test build to test on my A95x F3 Air.

There is only one test build. The developer of this build (@Ray) will not do any more builds until the work on OSMC is not finished, and maybe not not eve then…

@Ray, I have just read about new test version with following fixes
Does this still interest you?

How do I manually update with a devel image?

Read 10 posts back, #53

You should have installed CE 9.2.4, as I wrote in post #53, and then update to devel…

I have read that post but it just says manually update with devel image. How do I actually do that? Is it something I need to do the SD card or something I do from within Coreelec?

To manually update boot CE and when Kodi is up, copy the devel.tar to /storage/update folder. (easy to do with Kodi File manager). After the file is copied just reboot the box, the update will start on next boot…

Ok thx! Sounds really easy. Will try after work today!

But first install 9.2.3 stable version from that time. Then in Kodi File manager -> Add Source -> Browse -> Add “Home Folder” to see all contents of /storage partition where /storage/update folder is.

I can’t find the update folder in storage shall I add such a folder?

No, not necessary, just add “Home Folder” which will be named “storage”. When you then open it you’ll see many folders, and “update” among them.

Ups, just checked and it’s not storage/update but storage/.update with a dot proceeding the name. The dot means that the folder is hidden, same as all folders with proceeding dot in the name. Sorry for my ignorance :slight_smile:

To see hidden files and folders/directories you have to open Settings -> Media and in General enable “Show hidden files and directories”. You can also enable all options there…

Now I managed to install the update. It’s far from stable though. Just wait and hope for another patch.

How is it “far from stable” ?
On my N2 OS is stable but plays various 3D MVC files with various results. On some picture is OK on some video jerks about every 8-10 seconds - so unwatchable. All files/samples I tried were recognized as 3D MVC, except one. That one was created with new FFmpeg. This has now been corrected, but did not find the way into this devel version.

Since @Ray - the author of this devel version, is not interested in further work on this, I thing that this story ends here. I will finally have to get a Vero 4K+ OSMC box (for which 3D MVC implementation will soon be finished) for my 3D MVC movie collection.

I get really mixed results. I’ve tried the test files from Kodi. Some times it works decently but most of the times my box A95x F3 Air stops putting out any video at all and I need to pull out the cord and restart.

Ok development stops here then that’s to bad but not much to do since I at least don’t have the knowledge to keep deveopling.

Thx for the help anyway!

Hi, I know that Bluray 3D MVC and Kodi is a difficult topic - however in my understanding it depends at the hardware support for MVC, and that’s why it is working for Raspi. I’m owning a ODROID N2 with a S922X cpu and I just read that this cpu should also support MVC (https://republicaradio.com/s922x-datasheet/). Any idea if somebody is working already at this topic? What would have to be done for this?

We have enough posts about 3D MVC support, all you need to do is use the search button to get your answer.