9.0.1 Discussion

So updated, tried to update repositories but still TVheadEnd client “not compatible, disabled”. This really should not happen at all. My parents use CE and after almost every update they can be literally f***ed. Even I’ve tried to update (context menu and update repository) that without success. This shouldn’t be more difficult and should actually not happen at all. Shouldn’t be updated immediately even the basic repositories and then plugins automatically without a touch to evade these problems?

So what should I do more to make it working please?
Thx for understanding


For me and some other ce user the easiest way to solve this was:
Download newest stable and newest nightly tar files
Then stable - nightly - stable or nightly - stable nightly CE
After first change deleting CE repo in addons

This procedure brought everything in place again and updating PVR client

Maybe this will help in your case too
Don’t forget a backup as a first step

1 Like

I think I don’t understand you, I have a mess with your “stable”, “nightly”, “stable or nightly”. Actually I don’t know what to do despite I can adjust CE almost as I need, sorry :smiley:

Or you mean to install:

  1. the stable+delete CE repo
  2. then a nightly
  3. then again the stable?


Yes do it this way

the CE Version on my devices could not connect to the CE repo anymore. So kodi takes the last known for good addon normaly stored in addons/packages. But there was an api change also. As a follow up the pvr client is marked as incompatible and will be disactivated.

Relkai has made a change in the nightly Version recently. So use a fresh tar file.

CE can connect to its repo again if you do the procedure as described and will update addons again without problems

1 Like

ok, thank you

I think 9.0.2 is NEEEDEEEED a lot to fix these problems once and for all :slight_smile:

There is absolutely nothing wrong with the 9.0.1 release.

We had to change the PVR API to bring it back in-line with upstream Kodi and that is what has caused the addon issue but that is exactly what it is, it’s an addon issue and not an issue with the release!

There is a lot of conflicting advice on how to solve this issue, most of which is confusing and wrong.

You need to do the following steps…

SSH to your device and make sure your package cache is clear.
rm -rf /storage/.kodi/addons/packages

also for good measure make sure any CoreELEC repository that you have installed is removed because we always bundle the latest version with each release and so it is not necessary to keep a user installed copy.
rm -rf /storage/.kodi/addons/repository.coreelec


Restart Kodi at this point and then update your addons.

If you still have an issue at this point then manually update your PVR addon.

If you follow the steps outlined above then you will have absolutely no issues with 9.0.1 and hopefully with no future update either.

We have made a team decision to not modify any API in future releases to prevent any issue like this from occuring again.



I disagree with maders opinion.

A few days ago the only problem for users switching sometimes between stable and nightly was that the update procedure as described did not work. System still claimed no connection to repo and as a follow up the not updated pvr version stayed disabled.

Then I had contact to relkai here in the forum. He changed something and told me to download the nightly tar file again. Did that and installed the tar file. Then CE repo and CE nightly repo can both be reached again and all addons will be updated.
Some other Users had the same problem and could solve this with downloading newest tar files and doing a stable nightly stable or a nightly stable nightly change.

CE 9.0.1 stable/nightly both running like a charm used with my several devices.

tried to uninstall and install but again “installation failed” even after your advice :frowning: (says repository version 9.0.2) Is 9.0.2 coming today? :slight_smile:

I understand there is no issue with CE, but CE update should include even the updated core repository so an update of the core addons provided by CE would not do any problem. Maybe I don’t understand something but for me it’s logical that any system update should include even updated its core components.

You need to follow all of the instructions!

Ignore the 9.0.2 as that is just the repository version and it has been at this for over 6 months now and is irrelevant.

I followed… only uninstalled yesterday and today with your instructions “install failed” twice

A final confirmation.
I tested several times and this is all it takes.

@anon88919003 out of interest: will not updating pvr api bring possible regressions in this area?

maybe an updating problem with the server… when I had a problem like this (2x) every time was confirmed a problem on the CE site

when almost every your plugin trying to update I get “installation failed” now

even tried to re update

My crystal ball is broken today, please provide a log so I can see what your doing.

Many users have confirmed no problem after following these simple and concise instructions.

confirmed, very probably a problem of the connection to your servers


  1. your SSH commands
    rm -rf /storage/.kodi/addons/packages
    rm -rf /storage/.kodi/addons/repository.coreelec
  2. update nightly
  3. update stable
  4. able to install/update PVR client

@bylderup provided very probably the only complex solution to the problem, thank you!

I’m having problems with my plugins.

I sorted the PVR-problems with deleting two repository-folders, but I’m still having issues with video plugins YLE Areena and CMore. I can browse list of videos, but playback fails.

Here’s the log: http://ix.io/1CDV

I tryed this now serval times, but i get still the same error.
I see the requested URL in the Kodi.log. So i try to use wget on the odroid-c2 with the url in the log, which failed.
wget works. And it has downloaded the zip file.
This confuses me :confused:

2019-03-05 18:51:08.580 T:3987919728   ERROR: Requested path https://addons.coreelec.org/9.0/Amlogic/arm/pvr.zattoo/pvr.zattoo- not found in known repository directories
2019-03-05 18:51:08.580 T:3987919728   ERROR: CAddonInstallJob[pvr.zattoo]: failed to resolve addon install source path
2019-03-05 18:51:54.832 T:3530552176   ERROR: Requested path https://addons.coreelec.org/9.0/Amlogic/arm/inputstream.adaptive/inputstream.adaptive- not found in known repository directories
2019-03-05 18:51:54.832 T:3530552176   ERROR: CAddonInstallJob[inputstream.adaptive]: failed to resolve addon install source path
2019-03-05 18:52:14.924 T:3530552176   ERROR: GetDirectory - Error getting

DBraun, post kodi debug log. I think I saw same messages not long back.


what do you mean with “i tried this…” ?
The procedure from AdamG or the solution I have posted ?
The log file part you have posted is pointing exactly to the problem which should be solved if you try my workaroud as posted above. It is confirmed as working in postings at kodinerds also.

We bumped PVR API versions to make PVR addons work correctly after adding IPTV Archive support. A user suggested a better way to implement archive support, so we have now reverted back to following Kodi PVR API. This has caused these issues that some people now have. We thought it’s better to deal with this problem right now and get everything sorted out before Kodi bumps their PVR API, which would have caused even more problems down the line.

I have the same problem with a Samsung TV. No issues with previous auto-updated versión (I don’t know wich number was, I think it was on the 8.9x.y branch) Solved with this workaround, after reboot too. Is there any open discussion for this problem? I can provide my debug logs…