9.0.1 Discussion


#111

I updated yesterday, watched half of a movie, and dont see any problems with adjusting refresh rate ON (using this on one of my setups)


#113

Repo version is 9.0.2 here as well.
All is default, no custom fiddling.

Now that i think of it, that actually could be a versioning issue (?) On the other hand it could be nothing to worry about. Just reporting :wink:


#114

Nothing to worry about that is just the version of the repository package and not necessarily the version we use in the URL for add-ons.

Previous advice still stands to delete any folders as we already include the latest repository in all of our images and have since our very first release.


#115

I generally avoid “Auto Update” functionality and prefer to be notified when an update is available, then decide to apply it after backup, review, etc.

On the update from 9.00 to 9.01, I received a notification that an update was available but there was nothing listed under "Available Versions. Additionally, there is nothing listed under “Update Channel”, just a bar highlighting a blank line in the selection dialog, which you can select (closes the dialog and returns to the previous screen, same as Cancel), or select Cancel. Under “Available Versions”, the Cancel button is the only thing you can select, there is not even a highlighted blank line in the dialog.

I was able to perform the update by changing “Automatic Updates” to “auto”, then the update quickly installed and rebooting performed the installation.

This was a clean 9.0.0 installation. Is the updater not currently working properly making this expected behavior, or is my installation somehow gorked?

Thanks and best regards,

- Phil


#116

I have mine set to manual updates. On boot up there is a pop up telling me an update is available, I then set auto update, & couldn’t see anything in the channel.

So, I set to auto update, it then downloaded the update & I rebooted.

No drama


#117

We have not setup the update channel yet for manually selecting versions.


#118

I think it would be helpful to have a “semi-auto” update option, which anounces when an auto-update is available, but lets the user decide when to perform download & install.
This would allow to do backup in front, or just postpone if the time is not the right one…


#119

You already have this option by selecting manual, you still get the notification with this setting selected.


#120

Hi,

I had 8.99.X version, sadly my box crashed, thus it got an update to 9.0.0 than 9.0.1
After reboot my tv (LG C8) got “no signal”
I was able to access the box via ssh and saw that kodi is running
I logged to webgui and changed the resolution to 19201080p60hz from 38402160p60hz than got signal

However if I started a 4k or 4k hdr video I got “no signal” again
Than switching to 4096x2160p24hz I was able to play 4k(hdr) content, but the main menu is very laggy.

I already cheked this guide: Recommended Kodi Settings
But I have the opposite of this:
“If you have a black screen when playing 4K/HDR content then whitelist 3840x2160 and below, leaving 4096x2160 unselected as sometimes Kodi will choose this resolution for 4K content which can cause problems with some setups.”
So I have to whitelist 4096x2160 if I whitelist 3840x2160 than I got “no signal”
now gui set to 1080p as recommended above

The problem is that I have some 4k60fps content which is downgraded to 1080p60

Once again I had no problem previously and of course my tv support all resolution
Is there any solution to use my tv and coreelec just as before (3840*2160p60hz) ?
I would like to stick with latest release, but if there is no workaround how can I go back to 8.99.X release ?


#121

@suhanbongo some LG displays are problematic, enable the following option

Settings>System>CoreELEC>Use 4:2:2 colour subsampling

Revert the whitelist changes you made and you should be okay then, GUI should also be at 1080p for HDR autoswitching to work correctly.


No signal when putting interface in 4k
#122

Thanks, that’s solved my problem (after reboot)


#123

So if you have a LG TV, GUI set at 1080p is a must for HDR to work correctly are that also the case on the upcoming Odroid N2 paired with LG TV?


#124

Yes

N2 discussion is here


split this topic #125

A post was split to a new topic: Semi-auto update


#126

So updated, tried to update repositories but still TVheadEnd client “not compatible, disabled”. This really should not happen at all. My parents use CE and after almost every update they can be literally f***ed. Even I’ve tried to update (context menu and update repository) that without success. This shouldn’t be more difficult and should actually not happen at all. Shouldn’t be updated immediately even the basic repositories and then plugins automatically without a touch to evade these problems?

So what should I do more to make it working please?
Thx for understanding


#127

@mader

For me and some other ce user the easiest way to solve this was:
Download newest stable and newest nightly tar files
Then stable - nightly - stable or nightly - stable nightly CE
After first change deleting CE repo in addons

This procedure brought everything in place again and updating PVR client

Maybe this will help in your case too
Don’t forget a backup as a first step


#128

@bylderup
I think I don’t understand you, I have a mess with your “stable”, “nightly”, “stable or nightly”. Actually I don’t know what to do despite I can adjust CE almost as I need, sorry :smiley:

Or you mean to install:

  1. the stable+delete CE repo
  2. then a nightly
  3. then again the stable?

thx


#129

Yes do it this way

the CE Version on my devices could not connect to the CE repo anymore. So kodi takes the last known for good addon normaly stored in addons/packages. But there was an api change also. As a follow up the pvr client is marked as incompatible and will be disactivated.

Relkai has made a change in the nightly Version recently. So use a fresh tar file.

CE can connect to its repo again if you do the procedure as described and will update addons again without problems


#130

ok, thank you

I think 9.0.2 is NEEEDEEEED a lot to fix these problems once and for all :slight_smile:


#131

There is absolutely nothing wrong with the 9.0.1 release.

We had to change the PVR API to bring it back in-line with upstream Kodi and that is what has caused the addon issue but that is exactly what it is, it’s an addon issue and not an issue with the release!

There is a lot of conflicting advice on how to solve this issue, most of which is confusing and wrong.

You need to do the following steps…

SSH to your device and make sure your package cache is clear.
rm -rf /storage/.kodi/addons/packages

also for good measure make sure any CoreELEC repository that you have installed is removed because we always bundle the latest version with each release and so it is not necessary to keep a user installed copy.
rm -rf /storage/.kodi/addons/repository.coreelec

ssh

Restart Kodi at this point and then update your addons.

If you still have an issue at this point then manually update your PVR addon.

If you follow the steps outlined above then you will have absolutely no issues with 9.0.1 and hopefully with no future update either.

We have made a team decision to not modify any API in future releases to prevent any issue like this from occuring again.


PVR Addons fail to install
Upgrade to 9.0.1 breaks PVR