9.0.1 Discussion


#65

Successfully updated.
Made sure repository.coreelec wasn’t present.
Rebooted to update.
Updated TVheadend PVR client.
All good.


#66

I had the same repo issue here on a x96 (s905x) box. This box has never been downgraded.

Removing the repo package and re-installing the update manually fixed it.


#67

what means :improved subtitle rendering
no need for algorithmdirtyregions 0
on my 912 anymore?


#68

No, it still required.
Some optimization in rendering.


#69

Update did not work for me with tvheadend. I unistalled and installed again hts tvheadend addon and now it’s all good


#70

Btw not mentioned in changelog, Kodi splash screen is back?

[edit] No it’s not😁 actually, why did you remove Kodi splash screen in CE? LE keeps it still


#71

@giaur500 excuse my bluntness but why is anything LE does relevant here exactly?

Bootup is slightly faster without it and seeing as people already complain about a slow boot compared with say OSMC for example, we thought it appropriate to remove it, if it really bothers you then you can add it back in advancedsettings.


#72

Many thanks to the developers for the update.

I also had the same problem with TVH HTSP client, removing /storage/.kodi/addons/repository.coreelec and reinstalling the update worked. I never downgraded CE or installed any custom repository.corerelec.


#73

Nothing. My own reflection only. It also does not bother me so much, only asked from curiosity


#74

@giaur500 CoreELEC follows it’s own development path separate from LE, the 2 are not the same, the only commonality is that both distributions use the same JeOS buildroot originally developed by OpenELEC.

It’s like comparing Ubuntu with Xubuntu, both share the same buildroot but the end result is 2 similar but different products.


#75

Does auto-update works for you guys? Got this error in logs:

-snipped


#76

KI Pro was perfect for automatic updating!
I just needed to reboot.


#77

@DigiTo you only get that error if your network interface is late at starting.

You can try restart Kodi option from the power menu (not reboot) and you should get the notification.


#78

Hmm weird… I did that and still the same error in logs.


#79

This is normal as we do not provide a releases.json at this time, you should still receive the update notification almost immediately.


#80

Well… I do not receive any notifications about the update. I will do manual update then.


#81

Have you checked you don’t have updates set to manual? the only other explanation like I said would be a network error as we can see on the stats page that the update is rolling out.


#82

I did and it is set to “auto”. I had no problems with previous releases just on 9.0.0 :stuck_out_tongue:


#83

I’ve just checked the server and I can indeed see there is a problem, I will get it fixed this evening, thanks for reporting.

-edit fixed now


#84

Firstly, thank you very much for the frequent updates (and fixes :smile: )

I have been running the Mythtv PVR on CE for some time

The upgrade from 9.0 to 9.01 resulted in an error in the add-on

ERROR: CAddonInstallJob[pvr.mythtv]: The dependency on kodi.binary.instance.pvr version 5.10.4 could not be satisfied.

I’ve removed the add-on, removed the repository.coreelec directory as discussed above, then downgraded CE to 9.0 and upgraded to 9.0.1 again … without success.

Any advice ?
Thanks