9.0.1 Discussion


#175

That is interesting, @mader. Does not seem to be the problem here though. 41 degrees, and in general it is quite hard to get the MINIX very hot.


#176

What do you PROs say? Should a clean install be next step, or do you want to investigate this error further?


#177

A clean install should’ve been your first step as indicated in the guides. :roll_eyes:


#178

The dtb in ce 9.0.0 works with ir-keytable. The 9.0.1 dtb file is corrupt.


#179

Sorry mate, thought you guys might have been interested in knowing more about this issue!


#180

The clean installation is needed to understand if it’s a Coreelec problem, or a corrupted installation, or a user provoked problem…


#181

Hi @Vascobraga.
Yes, I do understand that. But nevertheless I just wanted to let you guys know about this issue, that at least I consider not a “user provoked issue” since it all started after the box been automatically updated. Everything worked as expected on 9.0.0, but didn’t on 9.0.1.

I am useless when it comes to coding, but I wanted to do what I can and at least lift the issue to your attention, and contribute in that way. Otherwise I could have downgraded or make a clean install.


#182

@Exile82 there is over 6000 active installs of 9.0.1 and whilst there was a few teething issues with the addons, we have not experienced any boot loops from other users.

This is probably a configuration issue as your logs have not shown anything, maybe a dmesg log would be more informative, the only thing I could see this being is a bind mounted Kodi issue as one of our developers had this and forget about it. You never stated if your whole device was restarting or just Kodi?


#183

Sorry @adamg. It was never my intention to “make this a big thing”. I have full respect for Devs knowledge and the complexity in devloping these products for a vast variety of HW.

But actually, I think I wrote that only Kodi was restarted, not the actual box/HW. But I was probably not clear enough in my description.

Well, I did a fresh install this evening. First time I get in to Kodi right away, making the standard settings etc etc. But first thing that happens when I restart the MINIX (U9-H) is that I end up in Safe mode. I create a log file (https://paste.kodi.tv/igicakuqux), and then try another to restart it again. Same thing, I end up in safe mode. I didn’t see any crucial things in the log but I don’t have a trained eye for this. I have doublechecked device tree file, it is correct.

It is soon bed time, and my kids will not take any prisoners tomorrow so I need to head to bed. But tomorrow I will continue to investigate. Let me know if there are any information you need from my side. I will try with a fresh install of 9.0.0, that is the latest known working release for my box. If that works I will update to 9.0.1 ( fresh install) again.

Thanks for terrific support and rapid response!


#184

Not sure what you mean by settings but read what happened to me .
Sorry I’m lazy to repeat all the my steps. Read link below.


#185

Sorry @kostaman. With standard settings I mean like the common settings, like language, audio, download and setup the most important addons etc etc etc.

Thanks for the link, I will read that


#186

Could you upload full log? After kodi restart 1st time go to you smb share and upload latest log from Logfiles directory
Also crashlog can be in this directory too


#187

@Exile82 the problem seems to be with one of the settings or addons that you are installing, I’ve tried a clean build on my U9H and it’s fine, try to provide the logs as detailed by boot2k3 above or tell us exactly what your doing otherwise we will be unable to help any further.


#188

i need to installtointernal.
TX3mini-L version
which dtb file can i use?
try many file in device_tree it working on boot on sd card.


#189

Coreelec, does not support all internal memory. This is the fault of the manufacturers, for not releasing the source code of their devices.


#190

More interested in folks eliminating the obvious (user error) and not wasting the Dev’s time :wink:


#191

Hi guys (@adamg and @boot2k3). As I was reviewing the crash log I found this on bottom row:
2019-03-09 06:45:30.790 T:4090208272 ERROR: unable to load resource://resource.language.sv_se/langinfo.xml: Failed to open file at line 0
2019-03-09 06:45:30.790 T:4090208272 FATAL: SetLanguage: CLangInfo: failed to load resource.language.sv_se language information

And yes, upon first setup (welcome screen wizard) I actually changed the language. Do not usually do this, I do not know if this has been possbile back in the days. I thought, that’s neat, then I do not need to do that later (I do know that the instructions in the wizard is still in english though).

Made another clean install, and without changing the language in the wizard, everything seems to work.

It does not explain why I had the frustrating issue after the automatic update from 9.0.0 to 9.0.1 though. But I will not bother with that, a clean install without changing the language did the trick!
I will add my advancedsettings and my mysql details. Let’s see if everything is as smooth going forward.

Thanks for patience, and support!!


#192

It was not my intention to waste someones time, espacially not the Devs. It was maybe a bad call from my side, but I want to contribute if I find weird stuff. And I do think that it would have been useful if the auto update functionality for MINIX didn’t work as expected.

But I am sorry if you feel that I wasted time here…


#193

And does swedish works for you when you install it later (not during wizard)?

Btw., I have strange experience with changing language/skin during initial wizard also. Sometimes, it just doesnt do anything when I tried download additional language or skin through wizard buttons, but the internet connection was fine. I dont investigate it much further, as in reality I dont need wizard for setup rest of things.

I just get used to do initial setup in english, doesnt touch anything much, just finnish wizard without any download, next next next. Later on, when normal Kodi runs, I do installs of Czech + Confluence skin, and do rest of environment setup there without problems…


#194

Hi JimmyS!
Yes, I have not had any issues at all prior to this issue, not at all (lang included).
But I have not tested that much now, but I could not reproduce the Safe Start scenario at least!