9.2.2 Discussion

New release !!! :partying_face:

I had a nice upgrade on my C2, everything works fine :ok_hand:
Boots crazy fast, can’t even see the Kodi boot screen :open_mouth:
Most of the announced changes are there and are felt (as in good) :grinning:
A few missing new options in the CE-settings (CEC…) I guess those depend on the hardware
I “only” have 3 settings under the new “Hardware” tab:

  • “Power/Wake-on-lan => ON/OFF”
  • “Display/VESA modes => ON/OFF”
  • “Performance/CPU Governor => OnDemande/Perormance”
    => No “CEC”, “Fan”, “remote wake up”, “USB power”, “install/remove BL301 bootloader” setting

I was expecting a lot from the CEC settings as it is still broken for me (I mainly use the Kodi volume to control the soundbar volume, saving 1 remote…) :cry:

News Typo: :nerd_face:
[…]

  • Added new hardware tab in CE-setting - // - Missing an “s” at the end I think
  • Added support to configure CEC in CE-settings

[…]

:pray: Thanks :pray:

Maybe because Kodi boot screen is disabled :grinning:

1 Like

I barely see the CoreElec boot screen, so maybe I’d see the Kodi one if it was enabled but would be just a blink I guess :wink:

@Sholander we have re-uploaded 9.2.2 to fix the issue with the slow boot from SD on the N2.

This is the only change so no other users need to re-download it.

@elgatito yes it does.

1 Like

@JeffJoker some of those settings only work with newer devices, I have updated the Changelog to make that more clear.

CEC settings/ remote wakeup/ bl301 is for ng only.
Fan only shows if you have one connected.
USB power is only for N2/C4.

Thanks for the heads up on the typo.

1 Like

Sorry but… what means “ng” ?
My english is quite good but the poor little french I am have some understanding troubles with some abbreviations…
Thanks

@Joretapo ng > next gen

It’s our images for newer SoC’s

1 Like

@anon88919003 please let me ask (again), nightly auto updated to 9.2.2 stable, will it stay on stable or it will be updated to next nightly?

I still cant pass Logo Screen on my N2 using SD Card…

image file hash: cb52863b495a7a07ceb999dc6dfb158ce747f98221375fa761e5e9c95f21683a

@altrey I don’t know what your doing then because I tested it twice here.

17s to boot from eMMC
22s to boot from SD

File hash matches also.

will try again … but I just to let you know 2 sec ago I tried latest nightly and the same issue happen.
CoreELEC-Amlogic-ng.arm-9.2-nightly_20200412-Odroid_N2.img.gz

Its fine with nightly CoreELEC-Amlogic-ng.arm-9.2-nightly_20200402-Odroid_N2.img.gz

Weird…

@altrey that would be because the nightly has not been updated yet, the stable release is currently newer than the nightly.

So i just tried again 9.2.2 after successful CoreELEC-Amlogic-ng.arm-9.2-nightly_20200402-Odroid_N2.img.gz

the same SD card using Etcher and no luck, stuck on first Red screen with Logo. Maybe its just me.
Will wait for me N2 users.

Thx!

@altrey you should not have any red screen as the bootloader logo was changed with the HK logo and the background on the splash was changed to blue, do you have an eMMC attached?

awesome, thanks for the update fellas.
From 9.2.1 -> 9.2.2 on a n2 was one button action (Yes) :slight_smile:

Thx for the ugrade,

on my Odroid-N2 4G the upgrade went without errors.
My main apps
EMBY Client and TVHeadend Client run without problems.

4k with HDR are also running smoothly and satisfactorily on my Panasonic TV.

Thanks a lot and stay healthy.

Greetings Jerry

Tnx, will try it later tonight, as now N2 is used for daily needs :slight_smile:
Btw, should I make a new install, or just update via .tar file to get the fix ie, are both images updated ?

@Sholander yes both tar and img was updated, update via tar is enough.

We did test fresh installs and updates for installs on SD on other devices but the N2 is different and we only tested eMMC initially, so apologies again but thanks for letting us know quickly.

@anon88919003 yes I do have eMMC with 9.2.1 running smoothly.
I use SD for testing new updates first to make sure its all cool.