I was about to report the same thing regarding the CEC issue. I did a fresh install and all was working ok with CEC enabled. As soon as I disabled “Switch source to this device on startup” and rebooted, the problem occured.

Debug logs: http://ix.io/2tXU
Dmesg: http://ix.io/2tXV

Yea, it usually does that :wink:

I am on 9.2.3 and want to update to, update is set to manual. In the update-channel (in CE settings) I only see 9.2.4. (which is supposedly disabled).

Is there a problem with the channel not showing more than 3 version digits or is not available in the channel?

Yes i think i saw that earlier on one of my test boxes
You will see all digits when you start the download.

We have been testing and a fix has been found.
Tested on my Vim3L and a fix will be available
after some more testing as there is another error in my log that needs attention.

What you will find is if you use your TV remote CEC
to navigate a few clicks your other remotes come good and GUI is normal

Using CoreELEC-Amlogic-ng.arm- on my Vontar X3 (S905X3) and I don’t seem to be able to select libCEC version 4.0.7. System defaults to version 4.0.4 and I can change that to version 4.0.5 by issuing the rm -rf /storage/.config/libcec-4.*.conf and touch /storage/.config/libcec-4.0.5.conf commands via SSH and restarting Kodi. When using the rm -rf /storage/.config/libcec-4.*.conf and touch /storage/.config/libcec-4.0.7.conf commands and restarting Kodi though I still get libCEC version 4.0.4 when I check the version under Settings > System > Input > Peripherals.

I’ve confirmed that libcec-4.0.7.conf is the only libcec-4*.conf file in /storage/.config. I’ve also confirmed that the following files are present in /usr/lib


Any thoughts?

Just select the 9.2.4 update, it has been updated to but isn’t reflected in the menu option.

Thank you. :+1:

X96 Mini 2/16 S905W.

I Installed CoreELEC ng with ceemmc -x command to internal storage and works. (With dual boot)
I can boot CoreELEC ng and with the option “Reboot from eMMC/NAND” boot to Android 7.1.2
*DO NOT install with ceemmc if previusly installed CoreELEC on internal, it doesn’t boot. Install the original android image before do it.

I tried to inject BL301 and works too.
For now works very well the ng on my device,
No deinterlacing option available on CoreELEC Settings because it’s not necesary on this kernel.
All run very smoothly for now.

I have auto update turned on however, I installed CoreELEC on an SD card. Will the update automatically be made to the SD card or will it fail to update because it will search for a hardware installation?

Also, to avoid the numerous problems cited above, would a manual fresh install to a new SD card be advisable? I’m thinking that if anything goes awry I can simply roll back by switching SD cards.

Carlos:~ # udevadm info /sys/bus/sdio/devices/sdio*
P: /devices/d0070000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
L: 0
E: DEVPATH=/devices/d0070000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
E: SDIO_ID=3030:3030
E: MODALIAS=sdio:c07v3030d3030

this is whiat I got. 3.14 Kernel

I tried NG NG Generic on my x96 mini fake S950L 1GB using gxl_p2121g dtb and the wifi works. Slow boot. Not really understanding if old kernel will not be maintained anymore for old mobos. Not sure if using NG version is a good choice and wihich are the drawbacks. No success in installing to internal (unable to read the emmc size).

On a different box (A95X F1 - S905W -2+16GB) I succeed in installing it to internal using non NG version. Does it make any sense to install the NG version? I haven’t found any instructions on how to move from non NG to NG version on internal: do I have to make a backup, use a SD to install the NG and then use ceemmc to install to emmc and then restore the backup?

I just received an Odroid N2+.
Before flashing version, is it recommended to update “petitboot version 20200806” or do not touch anything ? Thanks for your help.

If using eMMC for CoreELEC single boot OS no need to do anything with Petitboot.

If you will use Dual Boot SD Card CE and Android eMMC

You must update Petitboot.

Hello.How i am supposed to update from 9.2.4. to nothing i do works…

Try something else which only YOU know what else you haven’t tried.

1 Like

Thank you for this quick response. I am using single use coreelec on eMMC so I will not be updating Petitboot! Thank you very much for the information.

Just for yourself and others
It’s very easy to update.

Boot into petitboot
Navigate in menu to enter “Exit to shell”
Type: pb-update
Petitboot will be downloaded from Odroid Servers and on completion it will reboot
with the updated Petitboot installed.

thank you for this procedure. But for me no need is that right ?
I just flashed version without the Petiboot update as you told me and it works perfectly, coreelec works fine ! thank you.

You’re all good.
You are a single OS boot user .
You will not use petitboot.

1 Like

I think that you can find the answer here