Khadas VIM3L After any CEC modification, the device will slow down completely. It responds to a button press after 10 seconds.

You are absolutely right! I tried the same.First installed the latest nightly-ng build, and then update to with .tar file. I didn’t test too deep, but I think that runs well for experimental build.
Thanks to all CoreELEC team and their great efforts.
You are just great guys.

I want to use ssd1309 amlogic ng. But 4.9 not support i2c(pin group is faulty)
[ 4.618768@3] periphs-banks:474 is using the pin GPIODV_24 as gpio
[ 4.624778@3] meson-gxl-pinctrl pinctrl@4b0: request() failed for pin 73
[ 4.631413@3] meson-gxl-pinctrl pinctrl@4b0: pin-73 (d0042000.snd_dmic) status -22
[ 4.639264@3] meson-gxl-pinctrl pinctrl@4b0: could not request pin 73 (GPIODV_24) from group dmic_in_dv24 on device pinctrl-meson

Bummer man, but if you’re throwing it away, you might as well throw it my way… :wink:

Not one of you has supplied logs

I’ve got the same slow GUI problem on my N2, the log should be in the link below, thanks.


Can’t help you with the banned addons and services running on your hardware.
Fresh install with legal addons or i can mark your post as solved due to incompatible addons.

1 Like

Jut did a hard reset and its fixed the problem.

I’ve made a fresh install on Odroid N2 and the CEC issues have been resolved using stock libCEC 4.0.4

The deceleration happens when I uncheck the box after “switch source to this device on startup”.

Are you using the Khadas Factory Remote when this slowdown occurs ?

Forget that.
I just disabled switch source to this device on start up on my Vim3L and massive issues with GUI.
Will get back to you after some testing.

There is no reset button on this device.Actually I found out that the device boot up ,because I can browse the storage via SMB but the screen is black. I tried to copy the correct vfd.conf file in config folder then reboot, but the same…still black screen.
Can someone help me to resolve this issue with the black screen please.
My device is: GTMedia GTC with Amlogic S905D 2GBRAM +16GBROM
Thanks in advance.

I was about to report the same thing regarding the CEC issue. I did a fresh install and all was working ok with CEC enabled. As soon as I disabled “Switch source to this device on startup” and rebooted, the problem occured.

Debug logs: http://ix.io/2tXU
Dmesg: http://ix.io/2tXV

Yea, it usually does that :wink:

I am on 9.2.3 and want to update to, update is set to manual. In the update-channel (in CE settings) I only see 9.2.4. (which is supposedly disabled).

Is there a problem with the channel not showing more than 3 version digits or is not available in the channel?

Yes i think i saw that earlier on one of my test boxes
You will see all digits when you start the download.

We have been testing and a fix has been found.
Tested on my Vim3L and a fix will be available
after some more testing as there is another error in my log that needs attention.

What you will find is if you use your TV remote CEC
to navigate a few clicks your other remotes come good and GUI is normal

Using CoreELEC-Amlogic-ng.arm- on my Vontar X3 (S905X3) and I don’t seem to be able to select libCEC version 4.0.7. System defaults to version 4.0.4 and I can change that to version 4.0.5 by issuing the rm -rf /storage/.config/libcec-4.*.conf and touch /storage/.config/libcec-4.0.5.conf commands via SSH and restarting Kodi. When using the rm -rf /storage/.config/libcec-4.*.conf and touch /storage/.config/libcec-4.0.7.conf commands and restarting Kodi though I still get libCEC version 4.0.4 when I check the version under Settings > System > Input > Peripherals.

I’ve confirmed that libcec-4.0.7.conf is the only libcec-4*.conf file in /storage/.config. I’ve also confirmed that the following files are present in /usr/lib


Any thoughts?

Just select the 9.2.4 update, it has been updated to but isn’t reflected in the menu option.

Thank you. :+1: