9.2.4.2 Discussion

Are there any known issues with deinterlacing on 9.2.4.2? Had to roll back to 9.2.3 on my C4 to watch live sport (1080i).

Edit - not getting the same issues with my La Frite and 9.2.4.2.

What are you using to watch live sport?

What is your issue?
Also please upload a recorded sample on that this issue could be repeated

Hi guys, I am an owner of Odroid N2 and I have now installed the new CoreELEC 9.2.4.2, having connected an AVR Hdmi to my system I noticed that in the audio setting there are no more DTS-HD and TrueHd audio, I tried to play movies with these audio codecs and in fact they no longer appear on the display of my AVR, on DTS-HD it appears DTS and True-HD does not reproduce any sound, too bad because the previous version were present and worked well. Why this change? Thank you.

Check in audio settings(in 2 places there) that correct devices selected HDMI and HDMI Multi Ch PCM

Thanks, it was my mistake, I found the two codecs and selected them, I hadn’t seen them, I apologize.

Tvheadend. Looks like whatever the problem is its unique to the C4 and CE. No issues with CE on my La Frite or Kodi on Windows.

Will record a sample and upload it.

Hi all,

Is this the right discussion topic to post this issue? If not, can a moderator point me to the correct one?

Thanks in advance,

We don’t include cryptsetup iirc.

Using Odroid N2
I’ve jut noticed that subsampling setting is missing from Coreelec settings. Is this intentional or bug?

Just wanted to mention this build is working nicely on my MeCool BB2 (non-pro) S912 box. Best Build so far, no errors I can find, runs smoothly, almost as good as my Odroid N2.

1 Like

I have problems with hdmi-cec. when I turn off the tv and turn it back on, the odroid N2 always turns on. I have tried all the configurations in the “hardware” section and kodi. Any suggestion? Thank you

Looks like I installed it from entware. It was working 100% for several versions before this upgrade, maybe some kernel or library change broke it.
Any chance cryptsetup can be included in Coreelec?

Which “subsampling” setting is missing?

nunog, you should find when this thing broke with using old nighly builds from http://coreelec.relkai.org/. Then you can look what broke it (maybe some kernel config).

Thanks for the tip!

Just downgraded to 9.2.3 but still wasn’t working.
Then I checked the entware package date… it was recently updated also, but since I didn’t reboot for a long time, just now I needed to remount the disk. So I reverted to a older cryptsetup (2.1.0) and it’s working now with coreelec 9.2.4.2.

Thanks for the support.
Anyway, having cryptsetup (LUKS) in coreelec would be a great feature to add :wink:

1 Like

I agree. I need cryptsetup myself.

If i remember correctly in previous builds there was “Use 4:2:2 Color subsampling“ setting somewhere in Settings/CoreElec/…
I needed this setting for my Odroid/AVR/TV+Projector setup to work reliably as one of my HDMi cables is quite long (-10m), not top notch quality and not able to support 4:4:4 without brief screen blackouts.

It’s still there, if you select Expert you should have it in Settings/CoreElec/Display…

It works perfect on S905X (Magicsee Iron)
But ‘Disable deinterlacing’ option goes away anywhere. I tried echo 1 bypass hd blabla command but it doesn’t work. How can I do it? Because my IPTV streams. Thank you!