A95X-R1 install CoreELEC

I have an a95x r1 (s905w) android box but I don’t know how to install c.e or even Ubuntu on it. I tried but it does not boot on c.e or Ubuntu.
Plzz help me

Be very sure which SOC you have.
Double check that you have an S905W
If it is, gxl_p281_1g DTB
Read what i posted wayback THEN

I have tested this dtb but it does not work or even bootloop. I have checked and it have amlogic s905w and a95xa1_v5.2 board.

What does it do exactly ?
Does it boot to Android or what ?

It boots back to Android

Why are we reviving 2 YEAR OLD threads? Can’t be the same issue, start a new one! :roll_eyes:
The sillier part is that you’re getting responses :rofl:

1 Like

plzz help me

You can just explain me how to install c.e or ubuntu. I am a noob and don’t know how to install it. Even watching videos and follow installation process but in vain

Instead of bumping ancient threads and making multiple consecutive posts, you could just read this topic:

Thanks for your collaboration i hope this will help me in installing coreELEC

Which dtb is needed to be download for a95x r1 s905w

Please read the given answer.

i tried the reset button method but it does not boot into coreelec

so, you have downloaded the correct image for your device

you then burnt to a usb or microsd card, using etcher or rufus

you then copied the correct dtb file based on Ram size & LAN size, from the device trees folder located on the card, into the root of the card, renaming the dtb to dtb.img

you then inserted the card, while plugging in the power you are holding the rest button in, then after a few seconds releasing the reset button.

Some S905W boxes need that the reset button be held down before plugging in the power, and need to hold the button pressed for 15-20 seconds, or until CoreElec logo is displayed.

Even doing this it is not booting. I have to search for a dtb for a95x r1 2gb ram

There’s a A95X-R2 DTB in the device_trees folder, use that.

i have tried the dtb mentioned And it works but i am getting an error of could not mount /flash/system

Try a different SD card. Try burning it with Rufus.

Can you help me to install multiboot on it.