AAC 5.1 HDMI passthrough audio using S905X2 devices

​I’m still using a generic i686 LibreELEC on my HTPC, which is connected to a Denon AVR 1912 Receiver via HDMI. Pass-through works fine with this system, like AC3 and AAC 5.1 channel audio tracks. In other word: The files don’t seem broken and the AV receiver is able to decode and play multichannel AAC.

Since I want to switch to a TV box style of “HTPC”, I was trying to play the same files on a Beelink GT1 mini and a X96 Max, both using a Amlogic S905X2 (and also booth having 4 GB/ 64 GB) and the latest CoreELEC image (CoreELEC-Amlogic-ng.arm-9.2.1-Generic.img with g12a_s905x2_4g_1gbit.dtb as dtb.img).

Video (H.264) and network works fine. Also AC3 tracks work out of the box. PCM and Stereo AAC (passthrough) seems to work fine, too. But the latter seems to be at least a little more unreliable. What doesn’t work at all is multichannel AAC (5.1) with at total bitrate of 768 kBit/s. While the video plays nice and smooth, the sound is mostly inactive or heavily distorted (deep voices or static noice). I’ve played around with the different audio output devices and couldn’t find any combination that gives me a clean AAC 5.1 sound. The behaviour was identical on booth devices (which isn’t a big surprise, since it’s the same image and basically the same hardware). Like already mentioned above, the identical video files play fine on the old HTPC.

Using SPDIF is not really an option, since it doesn’t have enough bandwith to transport 5.1 AAC audio.

I just wanted to ask if this is maybe an issue already known or if someone has a similar setup and could solve the issue? Or any other ideas what I could try next?

Both boxes are using a fresh installed CoreELEC image.

1 Like

For AAC passthrough you need to select HDMI Multi Ch PCM.

Thank you, for your reply.

Yes, this option was selected as default and I also tried it multiple times. But I still get only very noisy and distorted sound.

What could I do to find out more? Maybe it’s an issue that can’t be solved by CoreELEC, but it would be nice to know for sure.

One thing I noticed is, that the PC system shows the name of the receiver when selecting the audio output device (something like “HDMI1… Denon…”).

More info: http://ix.io/2482

Can you please provide us with some samples so we can test them as well? :slight_smile:

Good idea. Will do that very soon!


This is just an example using AAC, but the outcome is still the same.

I’ve downloaded the the AAC files and the WAV file (first three downloadable files on that page) and played it on my PC (Windows 10), my LibreELEC HTPC (Generic x64) and the S905X2 Box (Beelink GT1 Mini).

I’ve confirmed, that my PC and HTPC play these file with correctly mapped 5.1 multichannel output - which they do. While the PC has its own sound system, the HTPC is connected to the same AVR receiver (Denon AVR1912) the Beelink GT1 Mini Box is. No problems there. AVR receiver shows “Multi Channel In” while playing.

Now if I copy the same files to the Amlogic box, selecting Multichannel PCM in System --> Audio and “5.1” Channels, I’m either getting no output at all or a very distorted with additional static noise (AVR receiver shows “Stereo” all the time). If I select HDMI/PCM output and “2.0” channels the files play fine, but – obviously – only using the front speakers.

Happy to test other files if this helps in any way…

(Tested with “CoreELEC (official): nightly_20191215 (Amlogic-ng.arm)”)

I’ve tried your samples earlier and I don’t have any issues. Try for instance to disable “Maintain original volume”. Follow Kodi’s Audio quickstart guide instructions with the last column “AVR HDMI (HD Audio)”.

Interesting! Do you have the same box (Beelink GT1 Mini) or similar S905X2 device? I’ve tried different options for hours, but I will check the link, maybe there is something I’ve missed!

Unfortunately I have no other AVR available that supports multichannel PCM to test if it’s maybe a receiver issue.

I will report back!

Still no success. :frowning:

This is a combined screenshot of my audio settings:

coreelecAudioSettings.webp (66.3 KB)

No, I’ve S922X and A311D, yet it’s the same kernel and build. It might be a HW issue, but let’s wait and see if anyone else with a S905X2 device can confirm if LPCM works or not. At least for me, it works fine on both latest stable and nightly.

No issue here, in my 922X GT-King CE latest stable and nightly. Multichannel and stereo pcm or AAC working good.

It’s (now) a known and confirmed issue with S905X2.
Once I get a box with this SoC, I’ll get this fixed ASAP.

It seems to be fixed now! :slight_smile: Thank you! :smiley: