After upgrading to Coreelec 19.2-Matrix_RC2 p281 1G RAM is not booting

Hello everybody, after upgrading to coreelec 19.2-matrix_rc2 the screen is like that

Now, when I try to use previous versions, they no longer start, when they worked before. Sorry for my bad English

I have this “VUVA 4K Hub” use as a device “X96 Mini 1GB” and it worked, after attempting to update no longer works.

When I try to use any version of Coreelec I get this.


I have tried with SD and USB with the same results

What dtb you use?
In 19.2-Matrix_rc2 the dtbs for 1g devices got modified.

Please make a new clean fresh install from 19.1-Matrix.

If it does not work please try to open SSH connection and/or a UART connection and collect a dmesg log by: dmesg | paste

And the device X96 Mini 1GB is confirmed working with 19.2-Matrix_rc2.
Please ensure you have a minimum Android version 7.1 installed on the device!

Thanks for replying, I was able to install 19.1-Matrix with this " gxl_p281_1g_a95xr2 “, I update to RC2 and stays frozen
the device I have is this " VUVA HUB 4K”, the version of android is 9

You are sure this is the correct dtb?
Please dump your Android dtb when booted with 19.1-Matrix:
dd if=/dev/dtb | gzip > /storage/backup/dtb.img.gz and share the dtb.img.gz.

For tests you do not need to upgrade to 19.2-Matric_rc2. Just extract the dtb from the tar image and replace it on the boot media. Maybe you try also another one. If none is working please try if you can open SSH connection to make a dmesg log of the not booting dtb. We can not find the real issue without a log.

Before this problem I installed Matrix 19.1 and 19.2-Matrix_rc1 with this db " gxl_p281_2g " after updating that db it didn’t work anymore.
and now I was able to install Matrix 19.1 with this db " gxl_p281_1g_a95xr2 "

" Please dump your Android dtb when booted with 19.1-Matrix:
dd if=/dev/dtb | gzip > /storage/backup/dtb.img.gz and share the dtb.img.gz. "

I don’t know how to do that

I could do this?
https://discourse.coreelec.org/t/extracting-dtb-file-from-a-running-android-os/1218/6

gxl_p281_2g was the wrong anyway when you have a 1g RAM device.
Why not gxl_p281_1g? Does it not work?

Boot with 19.1-Matrix and open a SSH connection and run this command:

dd if=/dev/dtb | gzip > /storage/backup/dtb.img.gz

You can then download dtb.img.gz from the Downloads folder.

Sorry the db I was using is " gxl_p281_1g "

I’m on w10, to connect via SSH I use putty
putty coreelec

but I don’t know where the file is

Sorry I’m really newby at this

In the shared folder named Backup
Just open a Windows file explorer and enter the IP \\192.168.0.110 of your CE device and the folder should show up.

Or also COREELEC should be visible in Windows explorer as well.

ok, I’ve done it

dtb.img.gz (35.5 KB)

Then please update the dtb with this one attached and try to boot.
Even when it does not work try to open a SSH connection and run:
dmesg | paste

I tried to install 19.2-Matrix_rc2 with this db and it didn’t work.
I can’t connect via SSH

Please try this dtb:

V1:

V2:

No luck, they didn’t work
v1 same error
v2 did not start, black screen.

Then I do not know what do do next.

The only way would be to open your device and search for the UART header and make a UART log as you can not connect by SSH.
The easier method will be the SDIO debug board but I think as the device already “old” you invest your money into a newer device with a newer SoC (S905X2 or the more preferred one S905X3).

Look here:

Thanks, anyway
Any way to leave Matrix 19.1 and not update automatically?

Does rc2 work if you copy dtb from 19.1?

Already tried, error

You only can make a clean install from 19.2-Matrix_rc2 and use the dtb from 19.1-Matrix image.

But our statistic shows clear it works on 19.1-Matrix and maybe I think I will revert the changes.
So you can install 19.1-Matrix and update tomorrow with the new 20210608 nightly image:
https://relkai.coreelec.org/

@DarkHarthur.
Tone map SDR to HDR = of
Tone map HDR to SDR = otomatic

Change it to and reboot.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice