Amlogic Hardware Decoder is not always working

Hello, occasionally the Amlogic hardware decoder does not work. When I turn on a video or TV, the image stays black and the timeline starts running.
Then, if I turn off the Amlogic decoder, the videos will work. (maybe the software decoder is on)
I reactivate the decoder and restart the Odroid N2 and the hardware decoder will work properly again.

What can this be about?

I tried it with different videos. That cannot be the cause.

1 Like

Could you please provide more information about your setup and specific steps regarding how to reproduce the issue you are facing? Follow guides as How to report an issue you're having with CoreELEC :+1:

Can confirm this issue on both my N2 and X96Air.
Issue seems to be when the box encounters an error in decoding it fails to clear the decoder hardware and release the frame buffer. Reboot is the only solution.
Have pointed this out to the team before.



Great that you also found out and I am not alone.
Can you log the error?

Its not something which is easily tracked but there are people looking at related bugs. It seems to be related to Kodi changes rather than kernel changes.

And how can we track the error?
It’s a pity if I have to restart the Odroid again and again.
Especially with TV it is very depressing.
For example, when zapping between 2 channels.
And why should we do without the hardware decoder?
That’s exactly the strength of the Odroid N2 - strong hardware.

I just want us to get to the wrong side.

Perhaps the bug is known and will be fixed shortly?

I use x96 mini and got the same error on 9.2.1, so I had to downgrade to 9.2.0. Videos wouldn’t play, Kodi would freeze and I would have to reboot via SSH. Since downgrade no issues.

1 Like

If I secure my settings…
Can I downgrade and re-enter the backup?

You should be able to put the tar update file in .update folder and reboot, your settings will stay. Backup still a good idea

Yes, I made a backup for security.
I went under update to 9.2.0 and completed the downgrade.
The settings remained the same.
Now I’ll test.
Under Audio Output Device you can not take all.
Some have a shrill tone on Netflix etc.
I selected the AML SDIF. It works for music, video and TV without this shrill sound. The dogs bark :sweat_smile:

1 Like


Please test some audio output devices on Netflix and co.

This issue will be addressed when there are some logs provided and more specific information regarding how to reproduce etc. Let us know if you guys need any input on how to provide logs :+1:

As I said its been worked on and solutions been tested. However it would be useful for everyone who is effected by this to submit logs to confirm that they are all been effected by the same bugs. Its not a simple matter to resolve and the more data available the more likely it is that a solution will be found.


At the moment I’m back on CE 9.2.0 and it doesn’t seem like the problem here.
I will look for the log because I had activated the log from the beginning.
It must not have been overwritten after the downgrade.

after restart old log is renamed as .old. So best is occur the problem and copy logs straight away or after first restart at last

Newbie question: How are you guys turning on/off the decoder?
Is this the hardware acceleration in CE settings? (I don’t ever touch these settings btw)

I’ve only had my N2 for a few weeks, but I’ve yet to encounter something it can’t play. Perhaps it’s cause I reboot my N2 daily, right before I begin using it. It’s just a habit I’ve gotten myself into for years now.

Yes, the hardware acceleration can be found under Audio.
Amlogic decoder with 3 settings, for example “MP4 Acceleration”.
This decoder crashes more often at CE 9.2.1.
Then only a restart or disabling of the hardware decoder helps, but this also means that the software decoding does not run smoothly and goes to the resources.

I watch via the PVR/VU+ addon TV. It’s just not fun when the hardware decoder crashes. I can no longer switch between channels because the image remains black.

So I looked at the old logs. I hope there is something suitable and you can help me with the troubleshooting.

kodi_crashlog_20200123215731.log (2,5 MB) kodi_crashlog_20200123215731.log (2,5 MB) kodi_crashlog_20200122083647.log (91,1 KB)

Two questions:
-do you have erratic internet with drop outs and occasional slow speeds ?
-do you use a VPN ?


No I have a 100Mbit Internet and my Home Network is 1Gbit connected.