Amlogic-ne, New Era

Welcome to CoreELEC

Any luck?

Testing on Hk1x4 S905X4
With success!!

Latest nightly 5.4.125
On internal.

Soon will remove
And test Omega 21

Happy Testing

I am sorry.Problem solved.

1 Like

Hello , firstly i want say a biiiiiiig thanks to all Coreelec devloppers ,i have build a audio video Juke-box with touchscreen, Beelink GT king 2, coreelec 20.1…use a car amp in this Juke-box… i have a problem : to much bass , searching in coreelec to ajust high/middel/bass but not found how to do :thinking:, After searching in Google i found equalizer Addon …does this work with Coreelec ? Or Can anybody say me how to ajust high,middel, bass in coreelec ?

Thanks for your help and thanks to make it possible for me to create this Juke-box with thé perfect software : Coreelec, touchscreen work perfect,:slightly_smiling_face: ,sorry for my bad english
Link from the Addon :

Picture from the audio video Juke-box :


with the 20230716 update, the mx3 air mouse does not recognize the ok and exit keys of my controller
also the keymap editor is ok and does not recognize exit keys

‘on internal’ you say. You mean that it run on emmc onboard memory. Not from USB-stick or SD-card. Is that correct?

That is correct
On internal

With S905X4 there is only single boot on internal

Or external boot from media.
To retain Android on internal

Tnx. Can I ask how did you do that? With CoreElec emmc Tool? Because I understood that S905X4 was not supported but maybe that is old news.

Yes correct. ceemmc -x

With S905X4 there is only single boot.
You will lose Vendor Android on internal.

If you use Android and CoreELEC then
Need to use external Media MicroSD/USB

Still figting with S905W2 usage on my device.
In the meantime i killed my box and found a way to recover S4 devices using new ADNL protocol

Maybe someone will be happy. It can recover even if you damage the bootloader (like i did):

Portish - what is a purpose of .ta files and video_ucode.bin? Got a s905Y4 board and i cannot load firmware. Verify failed.

I’ve sees you try to mount Android partition and use it’s tee suplicant and tee_preload_fw to load .ta files

But this approach doesnt work. Can you provide more information?

It’s all there to read how it’s done:

More help is only possible with more information:

Ok. I figured this out. Now i understand how it works.

Made a video Player with hardware video decoding of AV1 and VP9 up to 4K60 fps on S4 and SC2 Amlogic CPUs. Based on fork of c2play.

As usual, incredible work. Running really well on an S905W2 unit I have here with 1GB RAM.

There was no DTB available for 1GB RAM S905W2 (s4_s905w2_1g) models, so I modified the 2GB DTB. It worked fine after I changed the RAM hex value and the model name. There’s a delay booting as it identifies the DTB as out of date, but I’m not sure how to resolve that.

I can’t upload the modified DTB as my account is too new, but it’s trivial to change yourself and recompile with dtc.

Hi guys, I just got a Vontar X4 (S905X4) 4/32 and installed CoreELEC 21.0-Omega_beta1 Amlogic-ne with DTB sc2_s905x4_4g_1gbit on an SD card.

Everything works fine, just one thing I couldn’t figure out: the box won’t boot without a monitor connected and turned on. I use it mostly for music and I control it from my phone with the Kodi remote app Kore, no monitor needed.

What happens with a monitor connected: Vontar logo > artifacts showing on the whole screen for 1 second > CE boot text for another second > CE splashscreen > Kodi. With no monitor connected (turning on the monitor later): Vontar logo > artifacts only on the top 5 cm. of the monitor but they won’t go away > that’s it.

Tried to set vout='1080p60hz' on config.ini, no change. Tried to inject the BL30 blob but I got “System is not suported by BL30 injection”, I guess it’s not supported on S905X4’s. Flashed the latest ne nightly 20231126, no change. Without any hope I also tried to dump disp_cap but of course it didn’t make any difference.

Obviously I can’t come up with any logs as the device isn’t booting.

Any pointers?

The kernel needs edid to boot. Amazon has edid emulators that can solve the issue.

1 Like

Thank you, I had no clue about those. I’ve just ordered one on Aliexpress.

Edit: so I’ve got it and it works like a charm! Thanks again @rome1931 for the very helpful reply, much appreciated!

1 Like

I installed the New Era image on my SD card today. When I want to play some 4K DV films, I get HDMI disabled warning on the TV screen. Some 4K DV, HDR and HLG films are fine
.New Order all works on the system without any problems
GT King II
dmesg | paste