Amlogic-no Discussion

Please use this thread for general Amlogic-no discussion

Before posting an error please follow these troubleshooting steps.


Device GT King Pro S922X-H
So far, 4K video and live tv channels also have problems.
TBS tuner drivers ok
CEC ok
Device GT King II A311D2
4K ve 8K video ok
TBS tuner drivers ok
Live Tv 4K channels ok
CEC no

S922X-H Screen


GT King Pro dmseg | paste
GT King II dmseg | paste
Edit:4K videos work after removing Hyperion.NG plugin.
Corrupts after reinstalling

Well chaps, you kept this one quiet. I thought that my N2s would slowly become obsolete so I’m delighted by this development. I’ll be giving this a spin in the next few days and will report back on anything I find that’s not working.

Thank you for this.

I’ve just tried to install to SD on my N2 and I can’t get past a Hardkernel bootloop. Image burned with etcher and then the N2 dtb copied from the directory on the card and to replace the dtb.img file (I mean deleted the dtb image that was there and substituted it with the renamed (to dtb.img) one from the device trees folder).

In such case include dmesg | paste from last NG/NE nightly. Much easier would be to have a log by UART from booting 5.15.

1 Like

I created the NO version onto a microSD card and using it with my TOX3 (Amlogic S905X4), so far no issues.

However, trying to install to the internal nand, I get an error.
I am running the CoreELEC:~ # ceemmc -h using Putty, but Putty says command not found.

It has been running from the internal nand using NG. I think I used the same command from Putty.

What am I missing?? thanks

@Portisch , sorry to be thick but you are so far ahead of me that I don’t even know if your post was intended for me.

To continue with the Hardkernel bootlooping, the same SD card loads properly on my main N2+ but will still not load on my N2 that I use upstairs. I am running the latest petitboot but the N2 is the 2GB version. Could this be the cause?

Yes, because there were only 4g available. Make a dmesg log from NG on this device.

Here’s the log

Hope ive done it correctly. It’s using Beta 2.

It’s 2gb ram, yes. I thought these were never sold.
I will need to check how we can add this case.

Thanks for looking into this for me (and a few others maybe). At the time I bought it 2GB was (and still is I think) considered sufficient to run Coreelec.

Had a bit of time this morning so have tried NO on my N2+. There is no audio when it is set to Alsa, PCM when playing video. I did get sound if I played music from Radio Paradise tho. On NG Beta2 this setting would send audio through the 3.5mm jack and HDMI for music and video.

I haven’t sent a log because this should be easy to reproduce.

Please try again with image from 20231215, I just uploaded the new build what does now include the N2 2G RAM version.

I will but it will be tomorrow before I can report back.

Beelink GT-King S922X, wifi not working:

Please also add a dmesg | paste with last nightly from preferred Amlogic-ne if possible.

CEC is not working on A311D2 GT King ii.
GT King Pro also works CEC

Disable CEC in Kodi, reboot. Enable CEC on Kodi and reboot again. Maybe it’s than working, it’s a bug I guess.

I have an Odroid N2 with 4GB ram and it won’t boot. It fails at the petitboot screen.