Amlogic-no Discussion

vtunerc.ko (1.4 MB)

I had to change VTUNER_MAX_DELSYS from 8 to 32 because this is the value set in linux kernel.

# SPDX-License-Identifier: GPL-2.0
# Copyright (C) 2024-present Team CoreELEC (https://coreelec.org)

PKG_NAME="vtuner"
PKG_VERSION="35a614a11813161e4637b0c5c85957e800bb60e4"
#PKG_SHA256=""
PKG_ARCH="arm aarch64"
PKG_LICENSE="GPL"
PKG_URL="https://github.com/joed74/vtuner-ng/archive/${PKG_VERSION}.tar.gz"
PKG_SITE="https://github.com/joed74/vtuner-ng"
PKG_DEPENDS_TARGET="toolchain linux"
PKG_NEED_UNPACK="${LINUX_DEPENDS}"
PKG_LONGDESC="vtuner-ng"
PKG_IS_KERNEL_PKG="yes"
PKG_TOOLCHAIN="manual"

post_unpack() {
  sed -i "s|(KDIR)/build|(KDIR)|" ${PKG_BUILD}/kernel/Makefile
  sed -i "s|\(#define VTUNER_MAX_DELSYS\) 8|\1 32|" ${PKG_BUILD}/kernel/vtuner.h
}

make_target() {
  kernel_make -C ${PKG_BUILD}/kernel \
       M=${PKG_BUILD}/kernel \
       PWD=${PKG_BUILD}/kernel \
       KDIR=$(kernel_path) \
       default
}

makeinstall_target() {
  mkdir -p ${INSTALL}/$(get_full_module_dir)/${PKG_NAME}
  cp ${PKG_BUILD}/*/*.ko ${INSTALL}/$(get_full_module_dir)/${PKG_NAME}
}

Thanks. Works perfect.

1 Like

On my N2+ running NO I have just tried to implement a momentary press power button using pin 11 (GPIO_NO:479) and its not working. Can anyone confirm whether this works on their box before I go hunting for a solution.

Thanks

I am not sure if this is fully ported to new kernel yet

Thats fine its not important, I expect it will suddenly start working since I put the setting in the config.ini file.
Will keep an eye out for it.

Latest release seems to have cured the stutter on subtitles.

Thank you

The boot problem solved with the new version

But I have a new problem with the new NO RC2 nightly and NG RC2 nightly

All IPTV streams from the TVHeadend server stutter to the client boxes
I tested it with NG nightly and NO nightly

If I downgrade the client box to the RC1 version everything is OK again
I tried it with different boxes (922x,x3,x2) and the behavior is the same everywhere:

CoreELEC-Amlogic-no.aarch64-21.0-Omega_nightly_20240308-Generic works

CoreELEC-Amlogic-no.aarch64-21.0-Omega_nightly_20240322-Generic stutter problem

The same with NG

CoreELEC-Amlogic-ng.arm-21.0-Omega_nightly_20240319 works

CoreELEC-Amlogic-ng.arm-21.0-Omega_nightly_20240322 stuttering problem

Hello,
someone managed N2 rev. a board 2Gb RAM working (booting) just asking, as I posted earlier I’m not experienced enough to provide my logs for help.
thank you.

On my N2+ the powerdown does not work. It always reboots and does not stay in poweroff mode. Also from shell a shutdown -h does not work or any other mode of powering off like halt -p

Not on my N2; subtitles still induce stutter which can be stabilized only with bringing up some overlay. For that case I use “Subtitle offset” adjusting bar, and since it’s on the top above picture I can watch the whole movie without giving me headache.

A completely transparent overlay would probably be a temporary fix, but I don’t know how to make one :slight_smile:

1 Like

vim4 at nightly_20240322, TrueHD and DTS-MA HD and all other bitstreamed codecs are working as expected, great!

LPCM output however exhibits constant clicks/pops, very noticable in less energetic music, not so great. Is this a known issue? Are logs likely to be useful?

1 Like

I have a gt king II, same SoC.
I don’t seem to have that issue.
I only use passthrough of everything as my decoder has support for almost everything. (Does not support thx nor Auro-3d)

If you send me some link to test exactly on my setup and what settings I should use i can test

1 Like

I think the GT King II had working hi-res audio from the start, right? The Vim4 had its audio interface intentionally broken by AML to disable all hi-res output (including formats like TrueHD and DTS-MA HD) until the 5.15 kernels allowed it.

In any case, it seems quite likely to be kernel-related as this didn’t happen under CE 20 NE.

Below are all the relevant settings, but I’ve tried all the combinations of these I can think of and couldn’t produce a change in behaviour, and tweaked a few knobs in alsamixer to no avail. I should note that even the startup sound on the Actic Zephyr skin stutters and crackles, so it seems to be something fundamental.

<settings version="2">
    <setting id="audiooutput.audiodevice">ALSA:surround71:CARD=AMLAUGESOUND,DEV=0|AML-AUGESOUND</setting>
    <setting id="audiooutput.channels">8</setting>
    <setting id="audiooutput.config" default="true">3</setting>
    <setting id="audiooutput.volumesteps" default="true">20</setting>
    <setting id="audiooutput.maintainoriginalvolume" default="true">true</setting>
    <setting id="audiooutput.stereoupmix" default="true">false</setting>
    <setting id="audiooutput.mixlfe" default="true">0</setting>
    <setting id="audiooutput.boostcenter" default="true">0</setting>
    <setting id="audiooutput.processquality">50</setting>
    <setting id="audiooutput.atempothreshold" default="true">2</setting>
    <setting id="audiooutput.samplerate" default="true">48000</setting>
    <setting id="audiooutput.streamsilence">2</setting>
    <setting id="audiooutput.streamnoise" default="true">false</setting>
    <setting id="audiooutput.guisoundmode" default="true">1</setting>
    <setting id="audiooutput.guisoundvolume" default="true">100</setting>
    <setting id="audiooutput.passthrough">true</setting>
    <setting id="audiooutput.passthroughdevice">ALSA:hdmi:CARD=AMLAUGESOUND,DEV=0|AML-AUGESOUND</setting>
    <setting id="audiooutput.ac3passthrough" default="true">true</setting>
    <setting id="audiooutput.ac3transcode" default="true">false</setting>
    <setting id="audiooutput.eac3passthrough">true</setting>
    <setting id="audiooutput.dtspassthrough">true</setting>
    <setting id="audiooutput.truehdpassthrough">true</setting>
    <setting id="audiooutput.dtshdpassthrough">true</setting>
    <setting id="audiooutput.dtshdcorefallback" default="true">true</setting>
    <setting id="musicplayer.replaygaintype">0</setting>
    <setting id="musicplayer.replaygainpreamp" default="true">89</setting>
    <setting id="musicplayer.replaygainnogainpreamp" default="true">89</setting>
    <setting id="musicplayer.replaygainavoidclipping" default="true">false</setting>
</settings>

Appreciate the offer to test, I do suspect this may not be reproducable on your hardware though.

I think it may only affect 2ch LPCM - I was testing with Passthrough disabled, and the problem didn’t seem to occur when multi-ch LPCM was being sent.

I also note that output will sometimes get stuck in DD+, and Kodi seems unable to switch back to stereo LPCM - sometimes after starting an audio stream with a difference codec it will then successfully switch back to LPCM, but sometimes not.

No, high bitrate audio was broken in all a311d2 until recently .
Not sure if the fixes were back ported to kodi 20 as I’ve been using 21 since the fixed nightly dropped .
I’ve misread and thought you were having issues with passthrough.

1 Like

In that case, I wonder if you are able to reproduce with 2ch LPCM output via HDMI (e.g. music)?

Just tested it and had no issue .
Not in interface , not in music output .

I found that shutdown crashes on my N2+.
See log on pastebin

I was mistaken - the popping does appear in all LPCM output, I just tried enabling stereo upmix and it’s still there. Seems like maybe some frequencies either cause dropped samples or get pegged at max gain or something - Kid A by Radiohead for example triggers pops constantly, some other tracks less so. It’s driving me nuts and I’ve tried everything I can think of to tweak at this stage, but I’m out of ideas.

Also seems that it can get stuck in any passthrough mode, happens pretty regularly that it will get stuck in DD+/DTS/etc, and I can’t get LPCM output back without a reboot, though it seems happy to switch into another bitstream mode.

Seems the audio drivers have traded hires for various other deficiencies in this kernel, at least on this hardware.

1 Like