Amlogic-no Discussion

You are correct: something is not going well.

Thanks for backing me up on this. I knew it wasn’t me. I’m sure it won’t take vpeter long to find what’s broken the gui route.

1 Like

In today nightly the timezone selection is fixed.
There is also one new “feature”: on first boot timezone is set automatically based on location (or when file /storage/.cache/timezone doesn’t exist) and then it can be changed manually.

3 Likes

VIM3 Pro: no “inject_bl301” available
common message:

inject_bl301: /usr/lib/libcurl.so.4: version `CURL_OPENSSL_4' not found (required by inject_bl301)

any chance to fix it in near time (for using wakeup remote button)?

Can you tell me how to manually turn on fan of VIM4? I can not find fan.sh and /sys/class/fan/… In NO build there has not setting in the Hardware menu of CoreELEC, where FAN can be configured.

@Portisch I cannot install CE22 NO on my Radxa Zero. It seems that USB ports are not working (I connected keyboard and mouse and neither of them work). Thus, I cannot start the configuration process (select language, network etc. and am stuck at the welcome to CoreElec screen). Could you please have a look at this? For my Radxa 2 it is working as expected. Thank you very much.

https://wiki.coreelec.org/coreelec:ce_support#opening_a_support_request

I wish I could supply more information. However, as I cannot pass the configure screen of CE, I do not have internet access to the board. Moreover, USB ports ore not working. My radxa zero is a 4GB memory 128 GB EMMC model. Due to missing internet connection (which I cannot configure) I cannot provide a kernel log.
Also the sd card driver on Radxa 2 (4GB/16GB EMMC) seems to have a problem. Cards larger than 32 GB are not detected. Kernel log in this case is

Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 5 [0x0], 
TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 5 [0x0], TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 5 [0x0], TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 5 [0x0], TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 55 [0x0], TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 41 [0x0], TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 41 [0x0], TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 8 [0x1aa], CRC[0x2400]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 55 [0x0], TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 41 [0x10200000], TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 55 [0x0], TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 41 [0x10200000], TIMEOUT[0x2800]
Mai 31 09:06:38 Radxa2 kernel: mmc1: error -110 whilst initialising SD card
Mai 31 09:06:38 Radxa2 kernel: meson-gx-mmc ffe05000.sd: 1 [0x0], TIMEOUT[0x2800]
Mai 31 09:06:42 Radxa2 kernel: EXT4-fs error: 61 callbacks suppressed

Is the USB working with Amlogic-ng?
Because on my Radxa Zero it’s not. And I tested with a image from Radxa, Debian I think. But the port was also not working. That was the reason I thought the hardware is broken on my side as it’s a prototype.

Yes, it is working on Radxa Zero with NG without problems. Also, all my SD > 32 GB cards are detected with NG (on both, Radxa and Radxa 2). To my opinion this is a USB driver kernel problem (or overlay)?

CoreELEC-Amlogic-ne.aarch64-22.0-P_nightly_20240529-Generic.img
Trying this for the 1st time on an TOX3 TV Box Amlogic S905X4 (4G 1Gb)
I cannot get past the splash screen . It just sits there rotating the shape.
:frowning:

Try to connect by ssh or provide any other log.

I dont have an 1p addy as it wont open or load.
I have tried both dtb’s with same result.
Should I try one for another box?

All the other versions 21, 20 are OK.

Easiest would be a UART log as you see directly the error. You can also try to add in config.ini: coreelec='debugging loglevel=9 ssh'.
Then it might start the ssh server when you are connected by eth. So find the IP of the device on our router and try to connect by default user and pass.

1 Like

I tried with and without # in the line. Still could not find it on the network, sorry.

Tested NE week or so back on

Kinhank G1
HK1X4

Same result hangs there.

This is NO discussion thread i think

Try latest nightly CoreELEC 22 New Order NO

Success on both !!!

Kinhank
Hk1x4

** Not all functions working wifi/ bluetooth

Boots with Ethernet

Is the ugoos am6b plus supported yet?
I saw it has the am6b.drb in device trees

I tried running no from a usb stick but it wouldn’t boot on my plus (currently ng in dual boot mode)

used the tootpick method but all that happend was constant reboot to the armlogic flashscreen :frowning:

I guess you want DV. If that’s the case there’s no support in -no for it.

1 Like

i ca have dv on ng but i would also have the gui at 4k and runnit on movie mode setting my tv (tcl 50p815) because the inverface fklicers in NG when running the GUI at 4k.and dv

so is there a way to install it on the device if i already runn NG in duakbaoot?

I’m @Vasco

With the latest update from 2024-06-06 kodi won’t connect to my mariadb database:

2024-06-07 13:06:32.435 T:2769     info <general>: Running database version Textures13
2024-06-07 13:06:32.447 T:2769    error <general>: Unable to open database: MyMusic83 [2026](TLS/SSL error: SSL is required, but the server does not support it)
2024-06-07 13:06:32.448 T:2769    error <general>: Unable to open database: MyMusic82 [2026](TLS/SSL error: SSL is required, but the server does not support it)
2024-06-07 13:06:32.449 T:2769    error <general>: Unable to open database: MyMusic81 [2026](TLS/SSL error: SSL is required, but the server does not support it)
2024-06-07 13:06:32.450 T:2769    error <general>: Unable to open database: MyMusic80 [2026](TLS/SSL error: SSL is required, but the server does not support it)
2024-06-07 13:06:32.451 T:2769    error <general>: Unable to open database: MyMusic79 [2026](TLS/SSL error: SSL is required, but the server does not support it)
2024-06-07 13:06:32.452 T:2769    error <general>: Unable to open database: MyMusic78 [2026](TLS/SSL error: SSL is required, but the server does not support it)
...

After rolling back to CoreELEC-Amlogic-no.aarch64-22.0-P_nightly_20240604 the database connection does work again.

2024-06-07 13:22:49.521 T:1252     info <general>: Running database version Textures13
2024-06-07 13:22:49.529 T:1252     info <general>: MYSQL: Connected to version 10.5.8-MariaDB-log
2024-06-07 13:22:49.534 T:1211     info <general>: Loading special://xbmc/system/Lircmap.xml
2024-06-07 13:22:49.534 T:1252     info <general>: Running database version MyMusic83
2024-06-07 13:22:49.536 T:1211     info <general>: * Adding remote mapping for device 'mceusb'
...

Is it an error or do I have to change some settings to make it work again?