Amlogic S905X2

Just tried the latest Nightly release on my Mecool KM9 Pro (2+16G) with 2.4 Ghz WiFi and 100 Mbps Ethernet. Performance is good (I used a USB SSD as boot device). However, the WiFi Chip is not detected.

Which DTB file did you use?
Is your display working?

I also owned MeCOOL KM9 Pro (2+16G) and tested the latest build CoreELEC-Amlogic-ng.arm-9.1-nightly_20190808.tar, using g12a_s905x2_2g.dtb (tried g12a_s905x2_2g_1gbit.dtb but ethernet doesn’t work). Result is the same as @leptdre, there is no WiFi connections listed under ‘Connections’ tag. WiFi chipset of the TV box is AP6236.

@leptdre @wkchick
We don’t have drivers for the AP6236 in our repo just yet.
I see that they are available, so I think it shouldn’t be much of a problem to add them, but @anon88919003 knows about this more than me.

@leptdre @wkchick
Here’s a build that should have AP6236 support. Please give it a shot and report back whether it works or not.
link removed

Bingo, I just tested, WiFi is working. I’m not sure that the AP6236 works with both 2.4 and 5GHz band but at least I can now connected through 2.4GHz band to the router and get two IP address (I kept wire Ethernet active).

Thanks so much.

Edit: I just checked, Bluetooth on the MeCOOL KM9Pro is working as well!

1 Like

At mine KM9 PRO 4GB RAM still no WiFi and BT with that build.


I will test it om my mecool Km9 Pro 2+16G. BRB

Great, thanks.
According to this page, the AP6236 is 2.4GHz only, so it looks like it’s working correctly.

I don’t know. We have an AP6335 firmware already, but I don’t know whether it’s compatible with the “IT6335” chipset you have in your box. It’s likely not. From the limited results I could find on Google, this chipset will not work without the appropriate drivers/firmware. And I can’t find anything about this chip.

Sorry, my bad. I have Mecool KM9 and KM9 PRO, KM9 have a AP6255 chipset and Wifi and BT are working. In KM9 PRO IT6335 chipset not working.

It woorks , bluetooth also works !! please merge these changes !!!

Done. It should be available in tonight’s build.

BTW, I am new to Coreelec and I have a small question. Where are the WiFi settings stored ? (config files path). I am used mostly to Ubuntu, Android and OpenWRT

an “lspci” and “lsusb” would be helpful to fine hardware IDs. The chip would mostly work with a bcm driver. I will do some research.

Team, WiFi now works with 5GHz!, Ethernet is slow, I don’t know how to check if I’m connected at 1Gbps instead of 100 Mbps, can we see this in KODI?
Another thing… How can I turn on my device with the remote control IR? I can turn it off but not on. Thanks!

The wake up will be fixed when I add the g12a CPU support: CoreELEC BL301 Wake-Up feature [inject_bl301]
I guess next week…

1 Like

Check this out:-

1 Like

These are PC commands for scanning PCI and USB bus, TV boxes do not have PCI and WiFi is attached via SDIO and not USB.

The command your looking for is…

udevadm info /sys/bus/sdio/devices/sdio*