Amlogic S905X3, S905Y3, S905D3 thread

Try not to post the same post on different topics…
Such problems should be posted in Hardware section.

Looking to get an android box to run Coreelec for around $40. Currently looking to get the X96 Max Plus 4GB/32GB ROM. Would appreciate any advice or recommendations around that price. Will be running on a 4k HDR TV so would like for that to be supported.

I have the H96 Max X3 4/32GB and I am fully satisfied with it. Coreelec is running fine with the nightlies.Even the original remote is fully functional if you do what is suggested in these forums (very easy indeed).I am using it with a Full HD TV and not a 4K.
According to my information (and some firmware tests I have done) this box is exactly the same as Bqeel Y8 max, HK1 X3, Vontar X3 etc.

My TV Box X96 Air 4/64 GB also works very well with CoreELEC in internal memory. Internal memory space depends on usage. If you think you are going to use Docker containers then choose the largest size available.

Can you confirm the x96 Air has Gigabit Lan working? Also, did you get the remote to work on Coreelec ?

Thank you in advance.

Please look through the forum before asking offtopic questions.

1 Like

Everything works fine for me: ethernet, WiFi, bluetooth, remote, USB 3, USB 2, VFD display, … (I have just tried ethernet now to be sure and I have done a speed test, it seems that it does not exceed 100/100 Mbps, I will study this later).

Note.- I have changed the ethernet cable for another and I can affirm that the X96 Air P2 ethernet connection is gigabit. It can be verified with the command ethtool eth0 | grep -i speed

Nobody can confirm this.
There are a lot of boxes named X96 Air, but there are different chips inside.
Cheap, cheaper, cheapest, chinese box :neutral_face:

Hahaha! I can confirm this.

You can confirm that every box named X96 Air has working GBit ?
Al says: I don’t think so

I can only confirm that my X96 Air 4/64 GB P2 ethernet port is gigabit. Everyone has to know what they are buying.


My X96 Air 4/32GB has working (as in tested using LAN Speed Test / ethtool eth0 | grep -i speed returns Speed: 1000Mb/s) GBit.

As said before, after some thermal mods (see thread), it works great and I am very happy with it.

bought for EUR 35 at banggood.

Hi, does your ethernet work!? I have the same box, the 4/64gb version and wifi does work but I just can’t get the wired internet to work, I’ve tried several builds but no success :frowning:

Yes ethernet works perfectly.I have the 4/32 version but I think it’s the same as yours as far as the required dtb file is concerned.Do you use the nightlies? Have you changed the dtb file you are using?

1 Like

Thanks for replying. I’ve installed an older nightly (CoreELEC-Amlogic-ng.arm-9.2-nightly_20200321) and the ethernet is now working! A new issue I have is with rebooting and powering it on, I must unplug it from the wall socket to get it back to work, have you experienced this!?
Edit: any luck with vfd? I’ve read that for our box, hk1-x3-vfd.conf would work but I’m not having any success. Sorry for all the questions but it doesn’t seem many people have the h96 x3 :worried:!h1d3FYbL!hvjA0uBhtbgJmQ7LcClT0o2JEG1L4TxDRX_R_LC0ukU

  1. Copy the config.ini I uploaded above to the Root of your sd card.
  2. Go to “Coreelec - Hardware - Inject BL301 Blob” and press it to install it.The “IR Remote Power Code” must be “Custom”.
    After that the power button should function perfectly to power ON/OFF your box.
    Also vfd (file for hk1 x3) functions perfectly.In addition to that file you Must install also “Open VFD Service” via the Correlec repository in Kodi.
    I suppose you have already copied the correct files for the Original Remote Control to function properly (all its buttons).
1 Like

Hi, is it possible to set the remote device in addition to turn on and off only sleep mode?

Yes, I had the other buttons working and thanks to you the power on/off is also working now! vfd for some reason I can’t seem to get working, not sure what I could be doing wrong, does one need to edit something on the vdf.conf file?? A newbie question, for me to use the 64gb (or about 58gb that is free) rom of the tvbox to store movies, etc, I’d have to install coreelec internally? No other way, right? Would you recommend that? Is it better to wait for a stable release perhaps? I’d really like to use that free space.
Thanks again, much appreciated!

Did you install the Open vfd Service ? Not only the vfd file for our box.

I prefer to have a dual boot system (Coreelec+Android) so I never thought of using my internal memory for movies etc. Probably I will never do it anyway (with a nightly or even stable).

1 Like

Yes, I’ve installed Open vdf, updated it, I believe I did everything correctly but I must be missing some step. :frowning:
I’ll probably also keep android but alongside coreelec, internally, using this method How to use the Team CoreELEC ceemmc tool Have to read a bit more on it…
Edit: Thanks to @ath156 I now have vdf working!