Amlogic S905X3, S905Y3, S905D3 thread

Ceemmc. is the tool.

Sorry for the cross post…

I’ve got the X96Air S905X3 box - how long should it take for the Coreelec logo to appear after using the toothpick method?

64GB MicroSD card - using sm1_s905x3_4g_1gbit.dtb device tree

Picture of reset button.
For me i find it easy to press the button and then connect the DC power jack release button after 1 second.

1 Like

There is a TV set-top box VONTAR X96Max Android 9.0, X96 Max_Plus 2, (S905X3), and a simple bluetooth remote, “”. the Problem is that in Android the remote works, but in CoreELEC, it seems to be paired, but it does not work. What can be done.
P.S. Board version: Q5X3_141 V3.0 19351, Firmware version 2019.12…

Sorry, wrong link to the remote: “

Hello. I just bought a Tanix TX5 Pro S905X3 box off of amazon. Even though amazon says it is sold by Tanix I can’t find any mention of it on there website so it’s likely a generic S905X3. It’s the 4-64 version with gig lan.
Using the generic dtb and bluetooth wifi and lan all work ok. I bought this as I just bought a 4K TV and my U1 being a 905 box did not support HDR. So i bought this to play my HDR files. Unfortunately when I play a file I know is HDR my TV is not recognising it as being HDR.
If I play the same file using Roku Media Player then my TV sees it as HDR. I have tried whitelisting the resolution and I can’t seem to get it to recognise any of them as HDR. Any thoughts or ideas as to what I might try?

And I figured out what the problem was. I had to force HDMI 2.0 for that input. The TV wasn’t auto switching properly. So all in all pretty happy with this box. :slight_smile:

My IR Remote Config for the Bqeel Y8 Pro…everything’s working:

# table mecool, type: NEC
0x404001 KEY_1
0x404002 KEY_2
0x404003 KEY_3
0x404004 KEY_4
0x404005 KEY_5
0x404006 KEY_6
0x404007 KEY_7
0x404008 KEY_8
0x404009 KEY_9
0x404000 KEY_0
0x404045 KEY_MENU
0x40401a KEY_HOME
0x404011 KEY_RIGHT
0x404010 KEY_LEFT
0x40400b KEY_UP
0x40400e KEY_DOWN
0x40400d KEY_ENTER
0x404043 KEY_MUTE
0x404042 KEY_BACK
0x40404d KEY_POWER
0x4d KEY_EPG
0x40400c KEY_ESC
0x42 KEY_RED
0x01 KEY_LANGUAGE      # audio
0x09 KEY_SUBTITLE      # subtitle
0x404047 KEY_CONTEXT_MENU  # mouse
1 Like

Has anyone seen the S905Y3 in the wild yet?

A post was merged into an existing topic: Nightly builds (NEW)

HDR is working, check your config in box and TV. And since 20200203 nightly, hdr10+ is working too.

You can try another hdmi cable and/or hdmi port in you TV.

Which box for CE in range about 50$, X96 Air or MAGICSEE N5 MAX or something else?

Can somebody explain me how to install the latest Coreelec nightly on the Vontar X96 Max (S905X3).
I think i have to flash the image on my SD-Card correct? And then?
I read something about pressing the reset button that’s hidden inside the audio jack? But when and why do i have to do this?

Also, when something goes wrong, can i just unplug the SD-Card and use the box like before?

plug in card, as you plug in the power cord, press & hold the reset switch,after a few seconds release the reset, it should then boot the device.

If you remove the card,it will boot to android.

nice thanks a lot, i will try it soon

Edit: is it planned to include the s905x3 in the next stable release?
I decided to wait until the next stable release, because using a nightly version, which updates every day, is not an option for a family htpc

What video driver is use in kodi for x3? Why deintherlesing if off for hardware accelerations.

Feedback from my x96air video in latest Coreelec: Video its more clean & best than android but… i can observe micro stairs in iptv or hd video (in full hd its not observe) !

And other problem is boot and pvr iptv adon.

If i reboot tv box not every time kodi booting, 1 or 2 time with 3 its stuck on logo coreelec.

Pvr iptv its not load tv list 1 off 3 time after reboot.

Other problem i m no have for this moment.

Sorry for bad english!

Posted this here but thought I’d provide some feedback to this forum as well.

Using a Droix X3 and the build 9.2-funhouse_2006.7-Generic I have now had a successful boot into CoreELEC using device tree sm1_s905x3_4g.dtb but with the caveats listed below.

Booting both sm1_s905x3_2g_1gbit.dtb abd sm1_s905x3_4g_1gbit.dtb both just present a black screen with no activity on the boot media.

From the bootable build of CoreELEC I was able to test the following using an LG C9 OLED and Onkyo reveiver and media on a USB drive.

Working - 4K60 HDR remux

Working - 4K24 HDR remux

Working -1080p60 remux

Working -1080p24 remux

Working - Dolby Atmos / TrueHD passthrough

Working - DTS-X / DTS-HMA passthrough

Not working - LAN

Not working - WiFi

Not working - Bluetooth

Not working - Playback of content (HDR or SDR) would quite often either start as a black screen or end as black screen. You could still hear the sound so restarting and/or ending the media playback would show the screen again after an attempt or two.

Not working - Dolby Vision passthrough brings up the HDR option on the TV whereas when the content is played back directly from the USB port of the TV it comes up as Dolby Vison.

Not working - Suspend puts the device to sleep but there is no way of bringing it back afterwards as no inputs seem to work.

The performance of the menu interface and playback was excellent though which gives me some hope for the device.

try this

Tried the CoreELEC-Amlogic-ng.arm-9.2-nightly_20200210-Generic.img build and get the same results.

sm1_s905x3_4g.dtb boots the Droix X3 into CoreELEC without working wifi, lan and bluetooth whereas sm1_s905x3_4g_1gbit.dtb sits on a black screen. I see a little flash or two on my USB stick to some some activity after the device boot logo on screen and then nothing.

Solved after the last “nightly” update.