Bl301 injection, problems, help,

A vendor/seller should have contact with the manufacturer, so is in a position to ask them for fixes.

Many boxes are made in the same factories where there is no direct user support/contact for the end user.

Hi, managed to get it working with my BeeLink GT-King but how do I get power off to work?

Power on works fine, I also have a harmony remote (windows media centre) but I can’t seem to get it get power off to work.

I’ve tried putting codes in and have got it to work but then my harmony remote doesn’t work.

Try with one of those

systemctl poweroff
kodi-send -a shutdown

very difficult to contact the vendor/seller as they are clearly in china and whoever u speak to have no clue what you’re talking about.

That’s a normal business model for cheap boxes with no source code disclosed.
There are boxes / sbc’s who’s manufacturers assist the CE devs when issues arrise.
Your’s is obviously not one of them.
Only so much Devs can do on their free time.

Hi!,

Where do I put this command? Sorry if I’m a noob haha

Doubt its ever coming mate, just leave your box on 24/7 problem solved. :slight_smile: :frowning:

@Portisch
If I sent you a copy of my bootloaders on my s912 and s905x is it possible for you to put the BL301 blob into them or does it not work on theses models?

You don’t need to send me your bootloaders. I will get a problematic GXL device soon. When this get fixed maybe bl301 for s905x will come up. But as S912 (GXM) is not supported by Amlogic-ng it’s also not supported by incject_bl301.

Hi,
I tried run inject_bl301 on my A95X F3 Air (S905X3) but without success :frowning_face:

inject_bl301
Starting bootloader blob BL301 injection tool...
This tool can be used to update the bootloader
blob BL301 of the vendor bootloader on the internal
eMMC. This bootloader blob BL301 is customized by
Team CoreELEC to support all wake-up features like
CEC, Wake-On-LAN, IR, and GPIO wake-up from
suspend or power off state!

Device serial number: 2b0c100001011e00000f343043575050
Using CPU type SM1 (2b): S905X3, S905D3
Using binary type because of CoreELEC DT-ID: Generic
Using /dev/bootloader as bootloader partition

Testing bootloader for package version v2...
Did not find Amlogic image v2 header magic!

Searching TOC_HEADER. Please wait...
Can't not find TOC_HEADER! Error - exit! 

Can you check my bootloader bootloader ? (can’t upload to forum, new user)

Thank you.

The bootloader is encrypted, no way to inject bl301.
Maybe you find another vendor Android ROM image where the bootloader is not encrypted then you will be able to inject bl301.

Thank you for quick reply.
For “ON” function I must use original remote which works.

Update

Since Amlogic-ng stable 9.2.4 also GXL devices are supported by inject_bl301!

So wake-up features like CEC and IR should work when BL301 got injected.
The usbpower option is not supported by this platform.

Most IR codes for wake-up need to be defined manually by this guide:

Be aware that this feature and support is still experimental on GXL devices!

It can brick your device from booting and you will need to shorten eMMC to recover the device to unbrick it!

1 Like

Hello, I’ve found this today: https://github.com/CoreELEC/CoreELEC/commit/5397dbdab4aae86cbc84b3df18552bf1dd756cb7
Does this mean that there will be no longer support for injecting gxl devices? Or it’s just a temporary measure?
I’m on 9.2.4.1, patched my x96 mini and (still testing), but using so far without issues.

it will come back but in “manual” mode. there will be no option anymore to inject just from CE settings.
Also there will be a extra warning as it can brick the device and stop booting.

1 Like

I think I identified one remaining issue with GXL injection. It’s about the bl31 blob size does not fit into currently used bootloader on the device. I need to look if this can be fixed.

A bootloader created before 9 June 2017 on GXL devices will get bricked for sure!

1 Like

Hi, I have a Ugoos AM6 Plus and successfully inserted Bl301 through the menu option. I’m using it because I wanted to set the on/off power IR command more accurately since the on/off of my AM6 was triggered by several other IR commands in my TV/receiver setup as well.

Almost all is working well and the on/off triggering by other commands is solved. However, the power button can now only shut down the device. It’s not possible to turn the device on with it. With IR this is no problem.

Does this have anything to do with the gpiopower setting in config.ini? I tried a few settings (under which shutdown didn’t work either so this made the problem worse) but with one setting I got strange messages during boot so I shut off the power and disabled the gpiopower setting again.

Any ideas? Thanks.

Yes, you need to insert the correct gpio number for the power button. I will take a look if I can find it in the Android dtb.

@boot2k3 can you tell me the correct gpio by the dtb from Ugoos?

1 Like

@Portisch, @Huit
Gpio 502

2 Likes

Fantastic! Thanks both :smiley: