Bl301 injection, problems, help,

Only UART can tell what happens. But I guess it’s better to disable GXL injection at all.

I have no idea, maybe something is customized and this is the reason for a boot loop. But without the source it’s almost impossible to say what’s wrong.

1 Like

Because i am living in a rural area powered with just a diy solar system i heavily depend on standby- and/or hibernation-mode. Under Android the display shows actual time in standby, a feature i would like to see with coreelec.

Here is the working UART-log:
https://pastebin.com/eaxzh7sJ

Now i will brick my device again and add the UART-log here :wink:

The beginning of the log is missing.
I remembered something about this N5. And now I see it in your UART log: it have a NAND assembled instead eMMC.
Maybe it never will work, I am not sure about it.

1 Like

I have powered the device throu UART-usb-dongle, but as soon i connect the box the device (/dev/tty.XXXX) reseted itself, so i had to time the start of screen-output after the usb-dongle was connected.

The UART-boot-loop-log after inject_bl301:
https://pastebin.com/u2PuPLtd

Oh no. U mean that little bastard:
https://pasteboard.co/JGRdqph.jpg

Do u think it would work by desolder the nand and replace it with a eMMC? I have a lot laying around.

Or do u think its possible to adapt code to nand? I found: mmc/SD in Linux is /dev/mmcblkx the NAND is /dev/mtdx

I checked the binary blobs and it’s the BL30 blob what is not compatible with your hardware: Wrong chip %x. As this blobs are closed source I think I can not solve this issue.

And no, you can not replace the NAND by eMMC, it wont work.

I upload your picture how to short the eMMC here to have it as backup for other users needing it.
Magicsee N5 short eMMC for debrick:

1 Like

@Portisch I have recovered the box, but the firmware I use (got from 4pda) has an older uboot, the same version of your board, see the bootlog:

And in fact the inject bl301 works now.

So I guess a dump is of no use, but I attach the dump of the “newer” bl301

2b0b0100011d10000006333150525250_bl301.bin (4 MB)

I managed to patch the precompiled bl30 blob from the AML Pie SDK sources available to me. This solves the problem of the serial id (chip id) check for S905L SoC, P211 (also known under fake names P282, P261, etc.).
If you are interested in the future implementation… I can provide this for you

1 Like

Hi, i have a H96 Max x3 box and CEC is not working at all in CE or Droid. i decided to try injecting to see if it may help, but it is failing at the very first step with same error when enabling in the GUI or SSH.

in the inject_bl301.log i see the below - any idea what the issue may be or what to try, or is CEC not possible on this box?

iniparser: syntax error in /flash/config.ini (178):
-> '
iniparser: syntax error in /flash/config.ini (179):
-> '
Starting bootloader blob BL301 injection tool...

This tool can be used to update the bootloader
blob BL301 of the vendor bootloader on the internal
eMMC. This bootloader blob BL301 is customized by
Team CoreELEC to support all wake-up features like
CEC, Wake-On-LAN, IR, and GPIO wake-up from
suspend or power off state!

Device serial number: 2b0c1000012d1100000d333356305250
Using CPU type SM1 (2b): S905X3, S905D3
Using binary type because of CoreELEC DT-ID: Generic
Using /dev/bootloader as bootloader partition

Did not find Amlogic image v2 header magic!
Found a valid Amlogic v3 ToC header (0x10210)
Amlogic magic:			AA640001
Serial Number:			12345678
Flags:				0

TOC ENTRY #0
UUID:				9766FD3D89BEE849AE5D78A140608213
Offset Address:			0x68000 (absolute: 0x78210)
Size:				0xE570
Flags:				0x0
Found BL30 blob image at:	0x00078210
Amlogic magic:			@AML
Old signature bl30:		287A2EBEA00FDD802F347FF9AAEB604C73FAC9EA06AC723D9640FCF610F5D4BF
Using bl301 blob:		Generic_2b_bl301.bin
Failed to read config.ini: /flash/config.ini! Error: 0 - exit!
Failed to set config values from config.ini! Error: -1 - exit!

Thanks!

This issue should be solved in last CE-19 nightly.
There is some “garbage” in the config.ini file what stopped inject_bl301.

thanks, i found an issue with the file while further investigation last night ( line 178 and 179 had only ’ on them) i removed and was able to successfully inject, however, still no CEC :frowning:

is there something else i could look at or does it appear to be a fault / limitation with my box?

Cheers

Injection does not have something to do with CEC, only about wakeup.

You need to try last nightly as there was CEC fixed for 9.2 and CE-19.

thanks, i applied the new nightly from last night, but still no CEC

logs http://ix.io/2Qbr

dsmeg http://ix.io/2Qbu

note i also tried a couple of custom roms to see if maybe something in the bootloader was bad (Slimbox, then a Malay ROM - the Malay rom has CEC settings available in driod where as slimbox and stock did not but still no joy getting it to work) this is the only box of my (many!) boxes that i have CEC issue

Cheers!

CEC is loaded normally. Maybe you enable debug logging in Kodi and also the libCEC component. Then reboot and wait until Kodi is ready to be used.
Open SSH and run:

cat /storage/.kodi/temp/kodi.log | curl -F 'f:1=<-' ix.io

thanks,

is set the logging, rebooted and ran the command once Kodi was fully up, but i didnt get any url to share back in ssh - is this expected?

Then just grep the kodi.log and upload it somehow

i couldn’t work out how to manually post to xi.io so i used the below alternative, hope it is suitable…

not that i completely understand the log, it looks like no response from TV (works fine with same cable on other boxes) suspecting some HW issue - miss soldered pin or something on HDMI port on the box…hope i am wrong tho!

thanks for you help so far!

As I thought, there is no response from your TV:

	Zeile 22246: 2021-02-21 11:53:16.795 T:5383    DEBUG <general>: CecLogMessage - << Broadcast (F) -> TV (0): POLL
	Zeile 22247: 2021-02-21 11:53:16.795 T:5383    DEBUG <general>: CecLogMessage - processor thread started
	Zeile 22248: 2021-02-21 11:53:16.796 T:5383    DEBUG <general>: CecLogMessage - << f0
	Zeile 22260: 2021-02-21 11:53:16.825 T:5383  WARNING <general>: CecLogMessage - Write: write failed
	Zeile 22261: 2021-02-21 11:53:16.827 T:5383    DEBUG <general>: CecLogMessage - << f0
	Zeile 22299: 2021-02-21 11:53:16.864 T:5383  WARNING <general>: CecLogMessage - Write: write failed

Maybe CEC is turned of on the TV or you have a hardware issue.

The message f0 does mean a broadcast “ping” of node 0 what is the TV and there is no answer.

OK Thanks for looking.

i think HW issue on the H96 Max as all my other boxes work on this TV with the same cable, suspect the ‘ping’ is not even getting to the HDMI cable. I also tested the box on another TV where my other boxes also work in case there was something specific between the Max and just that TV, but CEC not working on the second TV with that box also…

What is the status of WOL for the Odroid N2+ on CoreElec?
I tried running the inject_bl301 script but got:

System is not supported by BL301.bin injection: g12b_s922x_odroid_n2plus

About | FAQ | Terms of Service | Privacy Policy | Legal Notice