Blank screen with some video content

I’ve just switched as a long-time Libreelec user and now running 9.0.3 on Odroid C2. Seems to be working quite well but I occasionally I get a blank screen with audio when trying to play some content.

It seems to have been resolved at least partly by adding all of my TV’s supported resolutions into the whitelist. However I read this post last night so I removed them all again. Now 80% of my videos play fine but a few clips like this 4k trailer just show a black screen with audio only. As a side note, the TV does not also switch to 4k when playing that trailer and other 4k content instead showing it in 1080P. I tried connecting the C2 direct to the ARC input on the TV and again, TV only notifies 1080P on 4k playback.

Should we have whitelisted resolutions under 9.0.3? If not, is there another solution for blank screens on some content?

Odroid C2 is connected to a Sony STR-DN1060 amplifier (on the only HDCP 2.2 input) and then to a 2yr old Sony 4k TV on the ARC HDMI input. Adjust display refresh rate – on start/stop activated.

This is what is being reported to CE.

CoreELEC (official): 9.0.3 (Amlogic.arm)
CoreELEC:~ # cat /sys/class/amhdmitx/amhdmitx0/disp_cap

However, the Sony KD-55X8500D supported resolutions are:

4096 × 2160p (50, 60 Hz)*
4096 × 2160p (24 Hz)*
3840 × 2160p (50, 60 Hz)
3840 × 2160p (24, 25, 30 Hz)
1080p (30, 50, 60 Hz)
1080i (50, 60 Hz)

*3840 × 2160p is displayed when 4096 × 2160p is input.

Run dispinfo in SSH while playing the video that gives you black screen and post the URL it returns here for us to check.

Thanks, will do. With or without any whitelist resolutions?

I’ve removed all whitelist items but also upgraded to 20190831 nightly. The upgrade has allowed me to play the aforementioned Elysium 4K Trailer and it is detected as 4096 x 2160P. Under 9.0.3 this was a blank screen.

However, I have the following HDR 4k trailers and only the ‘Life of Pi’ is detected as 3840 x 2160P ( The others all display as 1080P.

FYI, I received my CoreELEC N2 today (awesome) and I spun that up with 9.0.3 on eMMC and the same thing happens with those three HDR files on that platform too along with blank video screen on the Elysium 4K Trailer.

I missed the fact that you mentioned that you have an AVR.
It probably needs a 4:2:2 video signal to work correctly.
Go to CoreELEC tab in Settings -> System and check the 4:2:2 chroma toggle.

Thanks, I’ll try tonight. And the whitelist should be empty?

Yes, it should be left empty.

Thanks. Tried 4:2:2 but this made no difference. Sony Camping, LG Chess and Astra DVB all play at 1080P. Life of Pi still good at 4k. Bypassed Sony AVR and plugged C2 directly into ARC input of TV and still the same; both with 4:2:2 on and off. Here is the output with the AVR removed.

FYI, this SW9 file will not play (TV says video not supported) if I have 4:2:2 on with AVR in play but plays at 4096 x 2160 with 4:2:2 off.

I’ve moved to the N2 today under 9.03 and the Elysium and Interstellar 4k trailers do not play. I have no doubt that if I upgrade to the 0831 nightly, this will fix it. Should I leave it on 9.0.3 so we can figure out what is going on? dispinfo here whilst playing (no sound, picture) the Elysium trailer

P.S The other 4k trailers (Sony, LG Chess and Astra) all still render in 1080P.

I also had problems with black screens and high bitrate 4K trailers in the past.
The solution was to exchange all of my HDMI cables with premium certified ones.

Thanks. All of my cables are the exact same brand and high-quality slimline ones. The trailers that don’t play on my C2 under 9.0.3 will play with the nightly 20190831 suggesting the issue is not cable related?

I’m going to give this a try today, nothing to lose. I’ll grab a HDMI 2.1 certified cable and connect it between the C2/N2 and the TV’s ARC input to see if it makes a difference as the TV displays the video correctly when using the integrated DLNA feature.

The plot thickens. I purchased 1 x 4k cable and 1 x 8k and compared these with my existing high-speed HDMI cables. Sadly, no difference. Here is where I’m at.

N2 via AVR. Both 9.0.3 and 20190831 play all of my 4k HDR test files (Astra, LG Chess, Life of Pi, Sony Camping) in their correct resolution however it will not play the Elysium, Interstellar or SW9 4k trailers producing no picture and sound. If I connect the N2 direct to the TV though, I can see why. The video is playing back (poorly) in a windowed mode that the AVR cannot pass seen below. Tried 20190905 without luck as well.

C2 via AVR. Both 9.0.3 and 20190831 which I’m running now will not play the Astra, LG Chess or Sony camping in 4k instead choosing 1080P. However, Life of Pi 4k HDR as well as the others that the N2 will simply not play at all like Elysium, Interstellar or SW9 4k trailers all play fine in their native resolution. Go figure.

For now and to keep the family happy, I’ll just stay with the C2 on 20190831 until I can find a resolution for the N2 playback issues with some 4k content.

You have overscan configured in Kodi.

Thanks but could you be more specific? A quick search of my guisettings.xml (same one used on working C2) reveals 44 instances of the word ‘overscan’. Which bit am I editing?

Check the entries for 4K resolutions.

Should I remove all references to ‘overscan’ in those sections?

Yes, you need to remove them.

Dang, didn’t work. Can I just delete the gui file and let Kodi create a new one?