Bricked Beelink GT1 standard S912 2/16, can't boot to CE from SD card, have UART log

Have Beelink GT1 standard 2G/16G S912 and it’s bricked. Tried to flash multiple roms but without success.
SD card metod works, got android logo and upgrading progress bar.
After couple of minutes when bar reaches 100% box boots and remain on splash screen forever.
Splash image changes regarding firmware I have flashed.
Then I tried with CE. Prepared SD card with USB-SD Creator (tried with Rufus also), found that box will boot only with gxl_p212 DTB variants.
Tried all of them from device_trees folder but only what I get is splash screen of CE.
UART log ends with (full log in attachment):

CoreELEC:~ # [BL31]: tee size: 0
[BL31]: tee size: 0

What I am doing wrong?
log2.txt (197.4 KB)

I have a couple of boxes that work perfectly with the GT1 firmware and when using CE I use the gxm_q201_2g_1gbit dtb

I don’t know much about TV Boxes but I occasionally have this problem when I flash incompatible android versions (like from pie to oreo) to my phone.
Boot your device into 3e Recovery and do a factory reset.

On new Android phones it’s a different thing, they have two operating systems one that is running and the other that is/can be flushed. If flash is unsuccessful it’s simple to recover the one untouched by flash that is working.

Have you tried with amlogic burning tool and connecting with M-M usb cable?

I just tried with gxm_q201_2g_1gbit.dtb and it won’t boot at all.
Tried to boot in recovery but it won’t, maybe because the box is bricked.
Tried with twrp for S912 (found on XDA), put it on SD card and rename it to recovery.img, insert card to box and push reset button when plugged in, but won’t boot, just Beelink logo.
Pc and amlogic burning tool don’t recognize device.
When plugged in to pc I hear connecting sound but it disconnect after couple of seconds.

It sounds as if your EMMC has been corrupted. Unlike development boards these boxes are not designed to be recoverable easily after a EMMC gets corrupted.
You may need to clear the NAND by grounding the M-register pin on the EMMC. This will then force the box to look to the SD card as a boot option. This may not be a documented procedure and is specific to each individual NAND chip.

A maybe useful Freaktab link:


There are many TWRP image version that boot of the uSD card. You just have to find the right one depending on the Android version and make of your box.
It always takes me some time to find the right one that works with my new boxes. I tried 5 different TWRP versions for my X92 box, until found one that works.

Your log showes a Libreelec image… :crazy_face:
Maybe you are in the wrong forum?

No no, I tried both variants, maybe I mixed up the logs :slight_smile:
Here is log with CE:
log CE.txt (47.1 KB)

EMMC is probably corrupted, but think that shorting NAND pins is not necessary because the box see and boot from SD card, CE splash screen is showing.
The board from link you posted is the same as mine, GT-T_V30_20160831.
I tried to short those pins when connected to PC but without success, get connecting sound but disconnect right away.
Is anyone have the link to working TWRP recovery for my box?

Here are the pictures of the board, if it helps

This thread may also be worth following.

In terms of flashing the original firmware, as well as using the USB burning tools, there is also the option of using a MicroSD card to flash, burning the image using Burn Card Maker.

There are a few guides available on how to use it, such as this one.

Thank you.
I already tried Burn card maker with couple of roms, I do get Android logo and “upgrading” message and it goes to 100% but when restarts box stayed at splash screen forever. Maybe I don’t have right firmware, but I tried 6-7 of them, from Beelink and Freaktab.
Then I tried with CE, thinking it will boot for sure, but it won’t. I’m stuck for 3 days with trials and errors…

This is the firmware for your box, check serial number from back side of the box.

Problem is that the serial number sticker is gone from back of the box.
According the specs I found that serial no. probably is G912.
The firmware you posted the link is for G912 and S912.
I tried it with Burn card maker, the flash proces went fine, I got Android logo and Upgrading bar.
When bar reaches 100% after couple of minutes the box restarts and it stuck on Beelink logo…

The UART log:

GT1_708N0_LTM8830_log.txt (32.1 KB)

When unplug and plug again the log is different:

GT1_708N0_LTM8830_log2.txt (64.4 KB)

So, I tried:
GT1_313MO (Android 6 for G912)
GT1_703NO, GT1_705NOGT1_707NO, GT1_708NO, Nexus stock and Nano, even ATVXperience, no luck.

Start to think it’s a hardware failure, anything could be seen from log?

For some reason I can’t boot to recovery from sd card.
Tried multiple versions, put on sd and rename to recovery.img but wont boot.
Anyone have some version that works with my box?

I have 7 TWRP recovery images that I collected for my X92_S912 box, until I found one that works. I can send them if you want to try them, although I doubt that any will work on your box.

Ok, thanks, nothing cost me to tried them all.