Can't boot CE on Mini M8S II 2/16

Hi all! I’m new at this forum. First of all, thank you so much for all the CE team Work. Thanks everyone!

Now I present you the TV Box where I’m trying to install CE:

  • Device: Mini M8S II with Amlogic S905X, 2GB RAM and 16GB ROM (official buyed on gearbest). It’s upgraded to latest official android firmware: “update_MINIM8SII_rv112_megabox_20170320.img”, and has been working great during past 3 years.
  • Device tree used: gxl_p212_2g.dtb (renamed as dtb.img). This is the DT suggested on the CE downloads page for my device.

Now, I expose my issue in order to check if anyone can help:

I prepare the SD card with “LibreELEC.USB-SD.Creator.Win32.exe”, and using this image: “CoreELEC-Amlogic.arm-9.2.4.2-Generic.img.gz”. After created, I copied the “gxl_p212_2g.dtb” to root folder of SD, and renamed it to “dtb.img”.

With the TV Box off, I insert the SD card, keep the reset button pressed with a toothpick, plug power, and wait until CE logo, then I release the toothpick. I know this is the “toothpick method” and also tried the “remote menu button method”, and the “remote power button method”, with no success.

On all methods, the TV Box starts, it shows the CE logo, then the resizing partition process. After this it reboots and try to boot, but it hangs (screen freezed). It always hangs at the same boot line, sometimes it freeze on “starting unbind framebuffer console coreelec”, others on “Create libMali overlay for specific AML device”, others “Starting Samba configuration”, but always keep freeze. I tried to let it on during 5-6 hours but it doesn’t move.

I’ve tried plug off and on again, to test if it boots several times, but it keeps freezing.

I’ve tried 3 different boot methods: toothpick, menu, and power.

I’ve tried 2 different SD cards from different manufacturers and class. Both works on a RPi3.

I’ve tried to boot with keyboard and mouse connected.

I attatch example screenshot.

PD: I already search the forum, but seems anyone had problems with this device on boot. Only with remote, but not on booting.
Thanks for your help in advance.

Hi

I’ve never had issues with M8S II boxes…I now own only one, running CoreELEC “ng”.
Can you try this release ?

Thank you so much @Fredouye for your fast answer. I have tested and it booted at first attempt!

How can be possible that in Mini M8S II the stable build doesn’t work and the ng build is working? Since 2 years I upgraded the native MiniM8SII firmware to the official version: https://androidpc.es/firmware-tv-box-mini-m8s-ii-con-soc-s905x-20-03-2017/
Could be this firmware be firing the issue?

This is the exact link where I bought the TV Box in 2016, if you can see any point at tech sheet that can be important to consider: https://www.gearbest.com/tv-box-mini-pc/pp_471369.html

I have made working the remote with the attatched file copied along the dtb.img file.
To install to emmc, I’ve used the ceemmc -x option, with no success. See the screenshot. Any way to install to emmc CE?

remote.conf (7,1 KB)

Thanks again.

Please send me the reserved.img.gz of this command:
dd if=/dev/reserved | gzip > /storage/downloads/reserved.img.gz

Hi, thanks for your help!
Yesterday, I solved the problem by re-flashing the TV Box with the same stock 112 android firmware using an USB A-A Cable and USB Flasher.
After this action, I could boot ok CE (non “ng”) on this device. I don’t know what was happening, but this solved the issue.
Thanks again, appreciate your help!

About | FAQ | Terms of Service | Privacy Policy | Legal Notice