CE not booting on updated Firmware Android 10 Mecool KM3 ATV

Hi, i have an Amlogic S905X2 TV-box (namely Mecool KM3 ATV 4/64) which has been recently updated to Android TV 10.0 with fw release 20200515. Well, immediately after the fw update i’ve tried to boot my preexistent CoreELEC (from now on CE) installation, and i noted nothing else if not that with new fw update i cannot boot CE from micro SD as before, its LED shifts from pale blue to light blue before lying on a perpetual black screen. I also tried to flash CE again on the micro SD but nothing. Ultimately i cleverly managed to restore the previous fw (20190320) with Android 9.0 (API level 28), and CE has come back to work. I tried to replicate the same steps once again and i could conclude that with the new fw updated to Android 10.0 (API level 29) CE is unable to boot. I contacted the TV-box support through their email, asking if the fact of not being able to boot alternative OSes from TV-box with new fw could depend from a missing or incomplete implementation of this ability. I was answered by simply saying that they emerged from their analysis that the problem concerns CE directly, and that its developers have to create support for the presence of the new Android version. My question is simple: can you confirm me that this is indeed the case and that CoreELEC must support a newer Android version on some specific SoC in order to work? I hope not to be wrong with my question. I particularly care for the fact that on the previous fw of my TV-box there’s a letter that i’m not able to type with an external input device (like an air mouse), while on the new fw this has been corrected and now i could enjoy the TV-box as i always wanted to do. Thank you and regards

I’m not understanding this part.

Tell them to send a box to CE Developers.

If this is a Google Certified Device , they may have decided to lock the bootloader.

I was quite surprised these Mecool Google Certified ATV boxes were able to boot CE via SD Card.

Yes. In practice on the old fw they had forgotten to correctly interface all the buttons for the external input peripherals, and whatever input peripheral i used (wireless keyboard, wired keyboard, airmouse) i couldn’t type a specific letter, it was impossible in any case and this made writing much slower and cumbersome in some cases (think of using a browser). Mecool support replied to me after a long time: i was told that the problem had been found and solved, and that i could’ve benefited from the correction in a future fw update, and i’d have to wait for June for the new update to pass the test to obtain Google certification. That’s why i care to have CE along with the latest fw, in order not to have to compromise in the use of TV-box: have the OS with the fix but with the inability to start CE, or have the previous OS with that boring typing handicap but being able to start CE. I hope i’ve been clear now.

And listen, regarding the request to send a sample TV-box to CE Developers, do you think they may already know their practice or do you think that the request must be presented to them in such a way that they can show that they have some interest in replying to me on this point? Because it’s not said that they’ll bother to answer me on this point (or at least that’s what i think), they might read and completely ignore my question, so i wonder if they may actually have any interest in forwarding a sample to CE Developers or if it can be translated into a simple courtesy that the company does towards those who want to work on it for development purposes (i know of some companies who do it spontaneously). Thank you and sorry for being long-winded in exposing my doubt, but you know, in some cases we must neglect as little as possible to have a good chance of success.

ok, i forwarded the request to Mecool support and this was their answer:

   If CoreELEC developers need box debugging, the fastest way is that he can get it on AliExpress.

what do you think?

It looks like they’re not interested in supplying the hardware.
They’re only interested in selling with no support.
Nothing new.
Chinese business model.
Cheap Cheap Cheap. :wink:

I totally agree with you. I therefore limited myself to giving them a lecture about not having thoroughly tested the software before putting their product on the market. Certainly cheap, but incomplete at the same time. I think that in the absence of interest in this TV-box i’ll just stay on the old fw and live with the fact of having to navigate with the virtual keyboard to letter “Q” whenever i need it. It was my desire to have the power of Kodi together the ability to properly watch streaming platforms on my 4K monitor, but not being currently interested in the latter i think that i will continue to use it mainly with CoreELEC until obsolescence. Next time i’ll consider dividing the two: a development board for CoreELEC and a secondary device - that doesn’t have to be expensive - for watching streaming platforms in high definition, which is more expensive but certainly a much less demanding solution.

Can you check which kernel version the Android 10 is using?

@TheCoolest Good catch. Strange not to have thought of it sooner. I actually had to re-upgrade the fw in order to bring this answer. My answer is in these attachments and as follows: Android TV 10 kernel version is 4.9.180.

EDIT: Why on this forum can’t we quote a whole post? I just don’t understand this choice.

@n34s wants something in life and it’s always the solution to ask others to do it or pay for it. I guess it makes sense to ask others who by the way do that without any pay and on personal time and costs, to just spend money to buy this box. A little bit repect please!

Dear Ray, i’m sorry that, for reasons unknown to me, my discussion has aroused you a certain indignation and disappointed your expectations whatever they may ever be. I cannot feel guilty simply for asking for something, and furthermore as far as i know i haven’t placed any compulsion on anyone. I can only leave the interpretation of your words to common sense, and kindly invite you to a civil and respectful conversation for the sake of the discussion that is being faced. Thank you

Reading through the thread it seems that @kostaman suggested that the vendor supply the CE team with a box to help with providing CE compatibility.

@n34s then made a request to the vendor and the vendor’s response showed that they were not interested in doing so, to which @n34s asked for comment from the team.

Somehow I think that this last element may have potentially given rise to a possible though that @n34s may have expected the team to go and purchase a unit (which was not how I saw it myself) and so came the response @Ray along these possible lines.

Probably just a case of misinterpretation that sometimes just happens, especially when the tone of a voice that is easy to read and understand doesn’t always come across in the same way with text on a screen, which increases the chances of misinterpretation.

1 Like

I don’t know what to think about this but this sentence tripped me off:
If CoreELEC developers need box debugging, the fastest way is that he can get it on AliExpress.

Not sure who made that comment, but it is disrespectful.

Sorry if i go a little OT, but i’d like to congratulate with @Compent cos he’s the right man at the right time. I suppose the nickname is an abbreviation of the word “competent” because i must say that it fits you perfectly :smile: with respect for others of course.

@Ray i fully understand your disappointment and indeed, if it can make you smile, my reaction was even worse than yours.

I actually replied to their answer, and i must say that i haven’t been very light with’em: i’ve been through a lot for the fact that they put on the market a product that hasn’t been properly tested and that, due to requirements required for obtaining the Google certification (Widevine L1), it’s impossible to fix bugs in a short time because any modification made to the system would entail the need to regain this certification, and i believe that the process lasts approximately 3 months (at least that’s the time i had to wait, from the news of the bug resolution to obtaining the fw with the correction).
Not surprisingly, in the new release they solved the problem in typing the “Q” letter, but they forgot to implement the Storage Access Framework (SAF) and, because of this, it’s not possible to grant write permission on external storage devices, and with a 64Gb ROM this thing in my opinion makes no sense.

Anyway @Ray if you’d paid a little more attention you’d have also mentioned the line before that sentence:

I also want to clarify that i’ve not invented absolutely anything. Those were their words and not mine, kindly a bit of attention :wink:.

Now, if you don’t mind, i’d like to keep the thread tidy so that i can easily get a feedback regarding the Android kernel version. Thanks for your understanding

1 Like

Ok I misunderstood. I thought it was your sentence. I apologise.

2 Likes

About | FAQ | Terms of Service | Privacy Policy | Legal Notice