CEC not working on LG Smart TV

Hi everyone, I have a problem with the remote control from HDMI. On my old Samsung it worked correctly, that is, with the remote control of my TV I could manage the kodi interface. With the new TV a LG 49SM8200PLA does not work and consequently with the remote control of the new TV I cannot manage the kodi interface. I think it’s the CEC function. When I connect the device with coreelec, a function called magic remote control is activated. Simplink is activated. Any ideas?

HDMI Cable maybe ?
Try the the steps on the LG Link

I don’t think it’s the cable because it works on the old samsung tv. It doesn’t even go with the instructions in the link you said. I think the problem is compatibility with the new TV because it worked before.


You where running Libreelec on the device before?
Reset your device environment by long press and hold the reset button while power on.
Insert your CoreELEC uSD and it should setup the correct environment.

Hi Portisch, I don’t think I’ve ever used libreelec on this device but always used coreelec starting from 8. How come this question? That is, have you seen something libreelec? Thanks.

@rawrow I looked earlier on at your log and saw a remote file from wrxtasy LE Leia Krypton.

@kostaman but having a remote leia file doesn’t mean using libreele. Instead I inserted a remote.cfg to use the original remote control with CE. I attach the file.

remote.conf (2.9 KB)

It is your tv’s setting. Turn on CEC and turn off simplink.

Ragazzi works with cec activated both on TV and on CE but it is not very reactive. It has a minimum of lag. On CE the CEC was already active but I think that somewhere that is either TV or Ce needs to be improved.

I don’t know if this is related but LG pushed a firmware update the other day and CEC has become very flaky since then.

@mobamoba actually work regular but slightly with a lag. This because WebOs is a ShitOS.