CoreELEC 19.1-Matrix_rc3 Discussion

Please use this thread for general 19.1-Matrix_rc3 discussion

Khadas VIM3l users

Please be sure you have a file /flash/dtb.img on your current eMMC installation before upgrade to CoreELEC-19-Matrix! Otherwise the device will stop booting and a recovery will be needed!

Open a SSH connection and check it by:

CoreELEC:~ # ls /flash/dtb.img
/flash/dtb.img

If the output look like this the system is compatible and can be upgraded to CoreELEC-19-Matrix. If you get a “file not found” please restore your system like with a Android image or a compatible krescue image before upgrade! Please keep in mind the VIM3L HTPC kit is including a not official image by Team CoreELEC so maybe it does not support the upgrade as well.

I just updated from 19.1_rc2 and after the reboot now I’m stuck at a boot screen (X96 Max logo), which is usually just visible if i try to boot to android. Coreelc was installed on eMMC.

Make a clean install on uSD and try again.

Same problem here.

This was my first thought as well. Im rather stuck right now, as nothing is booting. I can still access the android recovery and tried executing “wipe data/factory reset” to reset my android and get it to boot again. Did not work though.

Are you able to boot/install into coreelec from the android recovery? Or reinstall android or something? I don’t have an android image for the box though.

When you install to internal eMMC you should be able to recover the device…

Create a new clean uSD from rc3 and insert it into the device. Maybe you need to push and hold the reset button till CE logo shows up.

I removed the rc3 release from today until the reason is found of this issue.
All affected devices are S905X2?

What DTB is used?
Anyone able to make any log? Like by opening the device and attach UART?

Successful update on Odroid C4, no issues so far.

Upgrading to RC3 on N2 went smoothly.

Also reporting boot stuck on my 905x3 (x88pro x3 device) boot from sd card.
It was automatic update via system.

I tried to do a clean install from uSD with the reset button, but I either land in android recovery or am stuck in the x96 max boot logo.
currently trying to unbrick with this How To Recover a Bricked X96 Max using Linux

As you are mentioned in that post, can you assist and confirm that the mentioned dd command in the linked post is correct?
The instructions mention flashing the UBOOT and .ini file, but dd flashes UBOOT twice.

edit maybe @JohnBoyz can confirm this?

I failed to update my X96 max from nightly to rc3.
I did a fresh install on SD card of rc3 and it booted without incident.

I had not done an internal install on this device.

its probably the other way around, otherwise flashed uboot size is way off?

still I’m not able to reach the android logo screen. always back to the x96 max boot logo.

You just brick your device when flashing a ini to the bootloader!
No idea from where you got this information.

Create a recovery uSD by Burncardmaker by using a vendor Android image. Insert the uSD and press and hold the reset button and recovery should be started.

VIM3 installed to internal rc2 updated to rc3 yesterday, everything works fine

By confirming the request to update CoreElec I just updated from 19.1_rc2 and after the reboot and now I’m stuck at a boot screen (“A95X-F3 Slim” logo).

INFO: Release is currently on hold and update paused!
If the system request a update to rc3 do not update!!

Those who already updated need to take any action?
It seems to be working fine on my GT King (SD card install).

About | FAQ | Terms of Service | Privacy Policy | Legal Notice