CoreELEC 19.2-Matrix_rc2 Discussion

Unable to replicate with 9.2.7 Legacy and 19.2 RC2

I suggest re-adding Netflix credentials using authentication key.

OK, I’ve downloaded tar’s 20210513-20210526 but I have only tested 13-19 so far (as well as the latest nightly when prompted to update) with the same results: audio dropouts every 5-10 seconds during music playback only.
I’ve also tried disabling music addons & adjusting/resetting player settings with no luck.
I cannot replicate the issue with stereo video files, only music files (mp3, m4a & flac).
Happy to post more logs if necessary.

I have no idea what could be the reason. Maybe some unsupported frequency @TheCoolest @boot2k3 ?

@Terry_Fyde
Not sure, we have not made any changes to the audio system in the past few months.
We would need to find the specific build where this problem has started, but I would look at trying better HDMI cables before looking into our code.
Also, make sure that you have the correct audio device and number of channels selected. (2.0 for “HDMI” or 2.0/7.1 for “LPCM HDMI”)

1 Like

Well, I’ve been able to rule out CoreELEC & the AV receiver. Through a painful & time-consuming process of elimination, it seems the Odroid itself is at fault. Looks like I’ll need to get on their support forums.

Thanks.

I’m getting problems with TubeCast addon. After update, YouTube app is unable to connect. Device (Coreelec) is visible, but connection attempt fails (after long time hang).

I just don’t see how can N2 be at foult if it plays video files with mp3 sound OK, and has dropuots with audio only (music) mp3 files?
Did you try to install Odroid’s official Android OS to see how it behaves then? If N2 is at fault it should have similar behaviour…

Yeah, it’s weird.
None of my video files have mp3 audio, so I can’t test that. It’s just occurred to me that I haven’t tested videos with stereo tracks to see if there’s drop-outs but the kids have claimed the TV for the night so can’t try this until tomorrow.

Edit: have tried several different video files with different stereo codecs and audio does not drop out. This behaviours seems to be exclusive to stereo music files only.

When the N2/CoreELEC is idle, or playing music, the connection to the receiver cuts in and out (receiver speaker lights turn on/off). As soon as I play anything with a multi channel track, the connection to the receiver stays solid.

Switching the N2 to a different input on the receiver, or using a different HDMI cable results in the same behaviour.
The N2 is the only device connected to the receiver that triggers this behavior and it has only started in the last week or two.
Other than updating CoreELEC, no other changes have been made to my system configuration.
I was wrong to say that rolling back to v 19.1 fixed the problem because it actually didn’t.

Not to sound lazy but trying an Android install seems like more hassle than it’s worth.

Did you specify on what you installed? microsd or emmc… and try another if you can…

If you update your petitboot you can even instal on a usb stick… https://forum.odroid.com/viewtopic.php?f=182&t=33873

Doesn’t sound related to CoreELEC.

Try to set Keep audio device alive to Always in the audio settings.
And/Or try to enable the Send low volume noise

OK, I’ll give that a go when I get a chance.

Thanks for the suggestion but I’ve already tried both those settings to no avail.

Well, it’s time you get the “debug log” so that we can see what’s going on with your specific problem. Without logs it’s impossible to give you any further meaningful advice.

I did look at the log you posted earlier, but I couldn’t see where you were playing any particular track. I, too, have an N2+ and my audio collection is all FLAC and is either 2.0, 5.0 or 5.1 at varying bit rates from 44.1kHz - 192kHz. These are rips of my CD/DVD-A/SACD collection and are audio only. I don’t experience dropouts. The only issue I have had with audio was a couple of months back where bit rates either below 32kHz or above 192kHz were being used on the HDMI interface which my Sony AVR couldn’t handle. That was sorted by restricting the range in the HDMI multichannel settings.
You mention that these are video recordings with associated 2.0 or multichannel audio. I wonder if it is a video setting which is trying to adapt framerates to the TV setting or something similar?

DRM? content too fast, and out of sync

I experience rather specific combination issue only on 19.2 rc2 CoreELEC (but not, for example, on x86_64 gentoo Kodi 19.1). I only experience it for VRT-Nu video addon (I also filed github issue Some (DRM?) content plays way too fast and audio out of sync. But only so on CoreELEC. · Issue #890 · add-ons/plugin.video.vrt.nu · GitHub), and only for foreign (I guess more protected) content, but, since not experienced on x86_64 gentoo Kodi 19.1, there seems to be something in the combination of CoreELEC and VRT-Nu and foreign series (e.g. ‘The Investogation’). I can provide credentials to test. Not sure if location matters, but I do not use VPN. So if x86_64 gentoo Kodi works, 19.2 rc2 CoreELEC should also work, In fact 19.x CoreELEC also once worked but it must at some moment in time have been broken. Note that I hardly watch foreign series on VRT-Nu so I may not have noticed exactly when it broke. Thanks for attention. Qua log I do notice plenty
2021-06-13 18:07:57.228 T:4054 WARNING : ActiveAE - large audio sync error: -4680.151250

here is a debug log
https://drive.google.com/drive/folders/1A60r5mmb_QRDnGhbmR67luBeDXaO1Cxi?usp=sharing

It turns out the addon has a separete flag to configure DRM to be played using Widevine. Issue spotted by mediaminister on github.

Okey-dokey.
Debug logs fail to upload but I was able to retrieve the zip file from the N2s storage & upload here (hope that’s OK).
log-2021-06-13-22.06.15.zip (571.5 KB)

However, crash log had no trouble uploading: http://ix.io/3pSp

PS, while it seems unlikely that CoreELEC is behind this & is therefore of no concern to developers, I appreciate everyone’s help.

I see you are using NFS for networking. There was a regression in the kernel about a month ago (I noticed while using a raspberry pi as a file server) which made NFS do what you describe on Kodi machines.
If that is your situation then update the kernel on your file server.

Thanks for the suggestion but I doubt it’s network related as music files played directly from a locally mounted USB drive are affected as well.

Looking at your logs with lots of errors, my suggestion is to do a fresh, a completely new, installation of latest version and before adding any addons try how it works. If it works OK start installing addons to find out which one is the cause for your audio problems.
If a fresh installation does not work OK (which I doubt), enable debug logging (audio), start logging and play your mp3 file; after a few drops-outs stop logging and send new log…

About | FAQ | Terms of Service | Privacy Policy | Legal Notice