CoreELEC 19.3-Matrix Discussion

Hi @vpeter
Can confirm the file from mega:
457f5bf2b61dfc2ccce22bd9032c23cec402210179ad79ba1766a2a8d4934721 gxl_p231_1g_m8s_dvb.dtb

Works ok.



1 Like

There is dmesg from CE 9.2.8
Could be a issue with Nand PHY device driver or device tree.

[    3.145854@1] nandphy: Nand PHY Ver: (c) 2013 Amlogic Inc.
[    3.152549@1] nandphy: ######STS IRQ mode for nand driver
[    3.157799@1] nandphy: NAND device id: 2c 64 44 32 a5 0 0 0
[    3.163266@1] nandphy: detect NAND device: A revision 3D L04A NAND 8GiB MT29F64G08CBCGBSX
[    3.171973@1] nandphy: param data[32~43]: 4d, 49, 43, 52,4f, 4e
[    3.177239@1] nandphy: nand Manufacturer: micron
[    3.177239@1]
[    3.234327@1] nandphy: micron_check_rand_mode()
[    3.234544@1] nandphy: clk_reg = 81000244
[    3.237196@1] nandphy: bus_c=6,bus_t=7,sys=4.0ns,T_REA=16,T_RHOH=15
[    3.243399@1] nandphy: new oob mode
[    3.248008@1] nandphy: NAND CKECK:arg nbbt:arg_valid=1,blk_addr=2,page_addr=0
[    3.256696@1] nandphy: nand blk 16 is shipped bad block
[    3.259185@1] nandphy: nand blk 32 is shipped bad block
[    3.264443@1] nandphy: nand blk 34 is shipped bad block
[    3.272358@1] nandphy: NAND CKECK:arg ncnf:arg_valid=1,blk_addr=5,page_addr=0
[    3.284702@1] nandphy: nand block at blk 16 is bad
[    3.292572@1] nandphy: nand block at blk 32 is bad
[    3.293117@1] nandphy: nand block at blk 34 is bad
[    3.307650@1] nandphy: NAND CKECK:arg phyp:arg_valid=1,blk_addr=6,page_addr=2
[    3.317273@1] nandphy: nand block at blk 16 is bad
[    3.325145@1] nandphy: nand block at blk 32 is bad
[    3.325690@1] nandphy: nand block at blk 34 is bad
[    3.343406@1] nandphy: NAND CKECK:arg nkey:arg_valid=1,blk_addr=4,page_addr=126
[    3.361354@1] nandphy: nand block at blk 16 is bad
[    3.369232@1] nandphy: nand block at blk 32 is bad
[    3.369777@1] nandphy: nand block at blk 34 is bad
[    3.398116@1] nandphy: NAND CKECK:arg ndtb:arg_valid=1,blk_addr=8,page_addr=486
[    3.416372@1] nandphy: nand block at blk 16 is bad
[    3.424260@1] nandphy: nand block at blk 32 is bad
[    3.424806@1] nandphy: nand block at blk 34 is bad
[    3.456878@1] nandphy: NAND CKECK:arg nenv:arg_valid=1,blk_addr=9,page_addr=204
[    3.461146@1] nandphy: nand blk 16 is shipped bad block
[    3.463806@1] nandphy: nand blk 32 is shipped bad block
[    3.469073@1] nandphy: nand blk 34 is shipped bad block
[    3.474345@1] nandphy: nfboot    :
[    3.477781@1] nandphy: off:0x000000000000-0x000001000000 :partn=0:single_chip single_plane
[    3.485971@1] nandphy: nfcache   :
[    3.489418@1] nandphy: off:0x00001a800000-0x000026000000 :partn=1:single_chip single_plane
[    3.497615@1] nandphy: nfcode    :
[    3.501062@1] nandphy: off:0x000040800000-0x00009b800000 :partn=8:single_chip single_plane
[    3.509258@1] nandphy: nfdata    :
[    3.512705@1] nandphy: off:0x0000dc000000-0x000124000000 :partn=1:single_chip single_plane

Hi, new here but I have been using LibreElec for a while. I have a Zen 11 Pro (very similar to TX5 Pro) and I have just installed CoreELEC 19.3 on a new SD as interested in the new kernel 4.9 and nfs4.
Everything seems to work just fine except for the wi-fi, where I can’t see any 5Ghz networks.
Reading previous posts about qca9377 I have attached the following files (I couldn’t post last one, to follow): - dmesg - udevadm

Thank you in advance. - journalctl

I have a X96 box (s905x (opened and checked the chip), 1gb, 8gb) that I am having some trouble getting to boot 19.3.
I had previously been using 9.2.8 without any issues.

I downloaded the latest image, flashed to to my sd card, copied over gxl_p212_1g and renamed it.
The unit boots up, shows it’s device logo, shows the coreelec logo, resizes the sd card, reboots as expected, and then enters a boot loop where it shows the coreelect logo, goes blank, and then reboots.

I have tried different TVs, different sd cards, and different hdmi cables. I have re-flashed the image to the sd card too.

I just can’t seem to nail down why this is not working with 19.3.
I was hoping that someone might be able to make a suggestion, and/or see something I am doing obviously wrong.

Thanks in advance.

You probably need to flash a newer android version. If you search the forum you’ll find some saves similar to yours.

1 Like

You are right. I figured it out while waiting. I bumped it up to 7.1.2 and it started posting correctly. Unfortunately the firmware I found was in (I think) Russian. So I have to go find something in English.


I am currently running 9.2.8 on a Venz V10 device (not pro) and are having issues with the video freezing, but the timer keeps running like the video is running.

I see there is this 19.3-Matrix version available. Can I updated the 9.2.8 to 19.3 whithout loosing the video database?

Use the V10 in the car with a USB stick with videos for the kids to watch on long road trips.

Currently the 9.2.8 is installer on an SD card, mainly because I wanted to test it to make sure it worked, and it has worked good for some time, but now I have these issues with video playback freezing.
I would however prefer to move the installation to the V10 internal memory. So the next question is if that also can be done one way or another, without loosing the video database?

I assume that the firmware should be able to switch the language.

While that may be true, I would have to be able to read the language it is in to be able find the setting to change it.

I was wondering if there are any known issues with 19.3 and the wifi connections for the nexbox a95x player. I have two. Both connect to the network, but the connection fails when I try to move any data across it.
Also I only see the 2.4ghz network with CoreElec booted. If I boot to android 7.1.2 on the device, I see both the 5 and 2.4ghz networks and am able to connect and transmit data without issue.

Another minor issue is that if I try to reboot by using the Coreelec menu, it hangs every time and I have to power cycle the unit.

I tried the latest nightly and it has the same result. Wifi connects, but is unusable.

Update 2:
I rolled back to 9.2.8 and both the 2.4 and 5ghz wireless works fine.

Can anyone else confirm that they are seeing this issue?

Hello Folks!
I bought a TV box S905X3 (T95 Max Plus), installed the CE 19.3 Matrix to build a TV server using two Microsoft TV tuners Xbox. Checking the dmesg I find that these tuners are not supported:

[ 173.324805@2] usb 1-1: USB disconnect, device number 3
[ 178.687918@2] usb 1-1: new high-speed USB device number 4 using xhci-hcd
[ 178.828544@2] usb 1-1: New USB device found, idVendor=045e, idProduct=02d5
[ 178.828558@2] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 178.828566@2] usb 1-1: Product: Xbox USB Tuner
[ 178.828572@2] usb 1-1: Manufacturer: Microsoft Corp.
[ 178.828581@2] usb 1-1: SerialNumber: 008097260915
[ 178.832303@2] usb 1-1: Unsupported device

With an old TV box and an old LibreElec 9.80 the peripheral is recognized. Am I doing something wrong or missing to install other drivers, or what?
Thanks for your help

try to install DVB drivers from CE addons

I got it!! Thanks!

No other place to post this without needlessly creating a single day thread so,

Merry Christmas to the Tireless Devs and stalwart CE community members.

I hope 2022 will be better for all of us.

Also, kudos on the Christmas Boot screen. That was a fun surprise this morning! :grin:


Coreelec 19.3 does not work search in any adon ( filmix , YouTube , elementum ) is there a solution ?

First post and using banned addons.
Good luck


No ,addon autocomplection ! :+1:

Hi guys,
I just bought a Mecool KM7 (2 Go ram, 16 Go flash emmc) and as the provided kodi (original) do not support passthrough for DTDS-HD and Dolby true HD (and do not support frequency adaptation), I would like to install Coreelec on a SD card.

First question,as the box is not rooted , is it a problem ?

Segond question, I do not find any DTB file for this box (S905Y4 proc), any solution ?
Thank for your answer.

1 Like