CoreELEC 19.5-Matrix Discussion

Please use this thread for general 19.5-Matrix discussion

Before posting an error please follow these troubleshooting steps.

Does this version stop supporting m3u playlists?
All links in the playlist are reported 0B, RC3 played those same playlists with no problem.

Same problem here with .m3u lists (X96 Max+; X905X3; with RC3 the lists worked well).

What are the steps to reproduce this issue?

In my case, the .m3u files that are NOT working (CoreELEC 19.5) have links with tvheadend structure, like:


Same .m3u file (tvheadend links) is working using Windows, and works with other CoreELEC devices (same: X96 Max+; S905X3, but with RC3).

When I see tvheadend logs, it seems that CoreELEC (19.5) does NOT try to connect with tvheadend using the .m3u list.

With CoreELEC 19.5 other “normal” links in .m3u files are working. Links like:

(without user:pass)

Perhaps any problem with “special letters” like “:” or “@” in the links ?

Videos > Browse to .m3u (tvheadend structure; user:pass@host:9981 etc.) file > .m3u file opens and I can see the channel list into .m3u file > Click on any channel has NO effect at all. No error information, no CoreELEC log information.

Same process, same hardware, but with RC3: all channels working without any problem.

Confirmed: it doesn’t work. Will check in details tomorrow.

19:31:05.287    DEBUG <general>: HandleKey: return (0xf00d) pressed, action is Select
19:31:05.294    DEBUG <general>: OnPlayMedia http://some-server/some-channel
19:31:05.295  WARNING <general>: Playlist Player: ListItem type must be audio or video, use ListItem::setInfo to specify!

Workaround is to add on every channel correct mimetype (mp4 in my example):


I think the issue is with this PR: [Backport][PlayListPlayer] Fixed wrong player playlist with playlist files by CastagnaIT · Pull Request #21712 · xbmc/xbmc · GitHub
Some videos play, some doesn’t. Depends if the link returns correct mime I think.
And no: it doesn’t work either in Windows. So I think it is not CoreELEC issue.

Would be possible to get some public link with doesn’t work with 19.5?

Sorry. Perhaps my post was misleading. When I wrote “Same .m3u file (tvheadend links) is working using Windows” I was NOT playing the .m3u file with KODI. I was using VLC with Windows.

I can confirm that the same .m3u list does NOT work with KODI 19.5 in Windows (with previous versions it worked).

I can’t provide a public example, but I guess that all tvheadend lists (user:pass@host:port/etc) will have the same problem.

And yes… your workaround is working.



(using Notepad++)

all the channels seems working.

A bit laborious, but it works.

Anyway, a fix would be good :grinning: .

As an example of what is not working:

  1. I take any m3u list and put into playlist folder (/storage/.kodi/userdata/playlists). Here is a sample list:
    sample_list.m3u (266 Bytes)
  2. And here is what I get with CoreELEC 19.5RC3 (any playlist working no problem):
  3. And here is what I get with CoreELEC 19.5 and above (20.0RC2)(no playlist working):
  4. As you can see, all tracks in the playlist are reported 0.00B
  5. The same applies to any other playlist.

These are mp3 files shouldn’t you be playing them from Music folders?

Doesn’t matter. That was only an example. Video playlist are behaving the same way.
BTW the fix doesn’t work for me.

Ok, but your sample was from Windows too not CE so if the issue is Kodi maybe you need to open a Kodi issue.

Indeed. Might be a good idea. Will have to find a public video playlist as for the example.

Sample list:
shop.m3u (12.8 KB)
Result (CoreELEC 19.5 and 20.0_rc2):

Posted in Kodi forum.
You can add your comments there:

Kind regards

1 Like

I resolved my problem on my side:

  1. All playlists must be imported/configured/added in .m3u8 format (“playlist file that contains a path to a media file or directory of media files and meta information about the playlist”).
  2. Playlists in .ts format (“video stream file”) won’t play in Kodi 19.5 and above.

Happy New Year!
Thanks the developers and the community for their effort buliding CoreELEC!

How did you resolve it exactly?

I converted my .m3u file (tvheadend source) to .m3u8 using VLC, and I can’t play that file using CoreELEC 19.5.

I have already checked it. The conversion of the playlist is not working - conversion doesn’t add extensions to the links inside the playlist.

Say, I can import m3u8 list in the following format which plays well in Kodi:
won’t work.

The first example works with no problem, the 2nd fails.