CoreELEC 19.5-Matrix_rc2 Discussion

Go for nightlies, it was fixed meanwhile and should work.

Does the X3 have the dtb changes for the JL2101?

I’ve tried to lookup some ways to force 5.1 without luck. It is simply not able to recognise the audio as default values are unchanged. And the issue persist from 15.1 - 15.3 - 15.5 - latest nightly. Meaning that the most optimal solution here is to downgrade to 9.2.8 for S905X if I want to have working LPCM. Seems that I have another good reason for starting to replace my devices for the “New Era” train :slight_smile:

I updated the system and I can set the LAN and it seems it is working but unfortunately I got only a 169.254… ip address. Should I install from scratch or something else could be the problem?

Similar issue as Report about Amlogic S905X4 HK1 RBOX X4 - #508 by Portisch
Try with add. entry in Config.ini

I reinstalled the Vontar firmware and after that installed from scratch the CE nightly and it seems everything is working fine. Thank you fro your help.

Hi there,

I’m considering to buy a Odroid N2+ and wonder if CoreELEC 19.5-Matrix_rc2 does support both, HDMI-CEC as well as HW deinterlacing for H.264/H.265? These are k.o. criteria for me.

Many thanks in advance.

What is the question ?
All features of Odroid N2+ are public and well documented

to be honest, I couldn’t find an info about it.
before asking I was searching across the CE wiki incl. the one related to Hardkernel devices.
Also I checked the CE release notes of several releases under Github to see if something was added/changed.
just from a HW point of view I suppose that N2+ would support HDMI-CEC as well as hardware deinterlacing but it’s also dependent on the Kodi OS distribution, right.
For example, most recent LibreElec supports HW deinterlacing for H.264 on a RPi3 quite nicely and I’m considering to change from this RPi3 to N2+ with CE 19.5-Matrix.


HK ON2 Kodi forum
AML S922X includes the 9th Generation Advanced AMLogic TruLife Image Engine that can (depends on OS & Firmware):

• Support Dolby Vision (Optional), HDR10, HDR10+, HLG HDR and Prime HDR processing
• Motion compensated noise reduction and 3D digital noise reduction for random noise
• Block noise, mosquito noise, spatial noise, contour noise reduction
• Motion compensated and motion adaptive de-interlacer
• Edge interpolation with low angle protection and processing
• 3:2/2:2 pulldown and Video on Film (VOF) detection and processing
• Smart sharpness with SuperScaler technology including de-contouring, de-ring, LTI, CTI, de-jaggy, peaking
• Dynamic non-Linear contrast enhancement
• 3D LUTs with 17x17x17 nodes, provide 4913 different control points, which is competent for matching calibrated displays to a target colorspace
• High precision HSL color space-based color management with low saturation protection, independent luma/hue/saturation adjustment to achieve blue/green extension, fresh tone correction, and wider gamut for video
• 2 video planes and 3 graphics planes
• Independent HDR re-mapping of video and graphic layer

deinterlace is always on on aml
it is even forced on progressive on some formats

ok, cool! thanks for the info. this helps.

1 Like

I have a problem that if the bluetooth headphones are paired, they connect to me automatically, even if I disable it in the CoreElec settings.

Odroid N2
CoreELEC 19.5rc2 new install
Previously used the last legacy build.

Issue movies scrapped in with either database are not showing all the tags like audio info video info 4k , 3d etc in movies view some are displayed but many are not.

I have tried deleting library and scanning in again same thing happens.

No issues if scanned in on older version.

Extract video information from files is enabled

If anyone has any suggestions please let me know thanks.

Tried a fresh install again same issue with python scrapper but non python works perfectly

Try with nightly, try with CE-20.
Kodi 19 Matrix become near end of live cycle.

Thanks I will I did not have much luck with this version it crashed on me a few times stopped responding I even tried a brand new SanDisk sdcard never had that with the 9.2.8 so not meant to be. I’ll try latest and keep the 9.2.8 as a safe backup on other card. Thanks

Closed, please continue here: