CoreELEC 19.5-Matrix_rc2 Discussion

Try first do remove resolution.ini from COREELEC partition. If this does not help limit colour depth to 10 or 8 bit in kodi display expert settings.

I have found a bug an my minix u22-xj max. After playing 3D movies, the switch to the normal image mode in Kodi menu dos not work. The screen is splitted an the resolution is to big. “Disable stereoscopic 3D mode when playback ended” does not work correctly. It is in Settings / Player → Videos

Apologies if this is a known issue, but on my ODroid N2 (not plus), after the HardKernel logo splash screen shows up, I just get a blank screen on this version.

I thought it might be an issue with my hardware but I tried Armbian and everything looks OK.

Not sure how to debug this because I don’t see anything. Tried Ctrl-Alt-F1, etc. but couldn’t get anything to show up either.

Maybe start here and see if that solves it.

1 Like

Remove resolution.ini and try if it solves your issue. If not SSH to your booted box and run dmesg | paste

1 Like

Hello ,

i have installed latest coreelec on my vontar x3 (905x3) and there is no working LAN. Wifi is ok
LAN is working under stock android. And im using sm1_s905x3_4g_1gbit.dtb from device tree.
Because it is my device configuration

thank you for help

Did it work on rc1 or did you just start to use CE from rc2?
If none of the existing images work, can you SSH into the box and run the following command to check if your ethernet PHY is JL2101?

dmesg | grep 'eth%d: PHY ID'

If it says something like this (PHY ID 937c4032), then your box has a JL2101 PHY:

[    0.742444@3]- eth%d: PHY ID 937c4032 at 0 IRQ POLL (stmmac-0:00) active
[    0.742611@3]- eth%d: PHY ID 937c4032 at 1 IRQ POLL (stmmac-0:01)

If it says something like this, then your box does not have a JL2101 PHY:

[    0.598830@2]- eth%d: PHY ID 001cc916 at 0 IRQ POLL (stmmac-0:00) active
[    0.598834@2]- eth%d: PHY ID 001cc916 at 1 IRQ POLL (stmmac-0:01)

You can also run the following command and paste the link to us so we can check the full kernel log:

dmesg | paste

And if your PHY is JL2101, then can you try either one of the following images to check if the ethernet works? (or if you don’t know how to SSH, then you can simply try these images anyway)

(This one uses the generic PHY driver for JL2101)

(This one uses the official driver from JLsemi I ported for JL2101)

I developed the JL2101 patches for my S905X3 box (HK1 Box), and verified it work nicely, but testers with S905X4 and JL2101 reported it did not work, and since I don’t have a S905X4 box with JL2101 I can’t further fix the problems. Since you are using basically the same model as mine (vontar x3 is basically hk1 box rebranded), the patched image should work for you, could you give it a try?

1 Like

8 posts were merged into an existing topic: Report about Amlogic S905X4 HK1 RBOX X4

Thanks for the help. Reflashed and it seems to be working. Not sure what happened. Tried armbian and CoreElec 20 in between and those worked. Anyways, thank you!

Hello,

at first, i would like to thank you for your superquick and extreme detailed support !

I have used patched image from link and now its working flawlessly ! Thank you!!

One last question - is it ok, to let it on automatical updates at this situation, or should I stay at this patch ?

Unless/Until the patch is merged, you need to turn off auto-update and stick with the image with this patch or build your own image based on newer CE source and manually add the patch

and is it possible to let auto update on, let it update - that will caused that LAN will stop working and than patch it manualy again with same patch ?

Hello!

It seems that since the last update the “Use 4:2:2 colour subsampling” option has disappeared from the “Settings > System > CoreELEC” menu.
Was it moved elsewhere? I searched through the Settings but I couldn’t find it. I absolutely need it…

Thanks in advance.

it’s written in release notes
the options are reworked and moved to expert display settings

Ok thanks.

Hey folks,

Recently updated my N2 to the latest 19.5_rc2 and the update went well. However now every time I try to start a movie or tv show from my server I only hear the sound but the TV get black. Also the Sony TV notifications pop up that no more device would be connected to the HDMI port.
As soon as I stop the playback the usual Kodi interface is being displayed and I can see and navigate it all fine.

I haven’t changed a setting and wondering if you guys have an idea what I can do to have playback working again?

Thanks!

Check your white list and resolutions. This normal happen if Kodi do switch to an unsupported resolution. Also you can try to limit colour depth to like 10 or 8 bit in display expert settings

Thanks for your input. It actually helped to force 8 bits color depth. Still strange though because it worked flawlessly the last years.

Anyway it’s fixed and I appreciate your help!

I developed the JL2101 patches for my S905X3 box (HK1 Box), and verified it work nicely

Hi,

I recently ordered couple of X96, S905X3 boxes, and I am actually a bit worried they could have JL2101 ethernet chip. I compiling own CE images (Leia based - 9.2 ng), would you be so kind to share your modifications related to JL2101 (maybe github?), so I could use them in my image, if I would be that unlucky and standard CE wouldnt work with ethernet? I dont mind wifi, or ethernet speed, really, but I need reliable and stable lan for sure.