CoreELEC 19.5-Matrix_rc2 Discussion

I had rc1 working fine with everything, but as I didn’t read serious issues reported with rc2 I decided to give it a try.
At first sight everything seemed to work as expected, but now I’m experiencing some strange things regarding video resolution, be it in movies or live TV: sometimes I need to change video resolution to normal during playback or else subtitles are off screen, and then the movie doesn’t fill the full screen.

Is this a known diff between rc1 and rc2? is there a way to put it to work like rc1?

Hello everyone, I’d like to point out this bug Bug: Playback Volume setting reset after restart

Would be greatly appreciated if that’s taken care of.

Reinstalling the inputstream ffmpeg direct plugin helped for mi.

S905X - LPCM (AAC) 5.1 issue (LPCM 7.1 works fine)
I recently upgraded three S905X boxes and all of them have a strange issue where LPCM 5.1 is not working, but LPCM 7.1 is. This has worked fine until I upgraded to 19 Matrix. It might be related to an earlier reported issue: 19.0-Matrix Discussion - #97 by raytestrak

Samples from at Samples - Official Kodi Wiki

LPCM 5.1 (no sound)

LPCM 7.1 (sound)

Output from /sys/devices/virtual/amhdmitx/amhdmitx0/config shows that for LPCM 5.1, the audio config is not changing from default. Meaning that it’s not able to recognise 5.1, but 7.1 A strange case indeed.

LPCM 5.1

audio source: SPDIF
audio type: L-PCM
audio channel num: 2 channels
audio sample rate: 48kHz
audio sample size: 16bit

LPCM 7.1

audio source: I2S
audio type: L-PCM
audio channel num: 8 channels
audio sample rate: 48kHz
audio sample size: MAX

Cheers and thanks for the incredible work you guys have done! Looking forward to Amlogic-ne when I switch to S905X4 in some months

19.5 rc2 crashing when trying to play 4k videos using a Beelink GT1 mini 2 (Amlogic S905X3).

Been awhile since I used this device, but wanted to do some testing on it. Every time I try to play a 4k video, (have not tried any Blueray or DVD videos), the box crashes and I have to power cycle it.

As far as I remember, I did not have that issue, but been awhile since I used this box. I was trying to see if this box was using the HDR video codec, I had forgotten, but thought it did.

Here are the logs.

Upload a short sample what do crash somewhere

How do I create a clip of a 4k movie?

You can try to dump your disp_cap so the CE device use this dumped data on boot.

In case anyone is running into the same issue:

cat /sys/class/amhdmitx/amhdmitx0/disp_cap > /storage/.kodi/userdata/disp_cap

This worked for me. Thank you @Portisch.

1 Like

When the CoreELEC device is powered on after the TV, it activates the HDMI input it is connected to on the TV, but it doesn’t switch CEC to the CoreELEC device automatically. On a Samsung TV, I can manually select the CoreELEC device in the Anynet+ menu, but this is tedious.

Normally I could run

/usr/bin/cec-ctl --to 0 --active-source phys-addr=

but that command is missing on CoreELEC. Is there another way to achieve the same? echo "as" | cec-client -s -d 1 seems not to do the job for me.

This option should do this job already:

Hello everyone.

I am trying to update and it is impossible.

I’ve done everything you tell me, and nothing.
I put everything in the USB drive, and turned on my device and at the same time, pressing the power button.
The first thing I get is a black screen and at the top, some text that I cannot read, it is outside the frame of my TV, I press any button on the remote control and coreelec com opens for me the first time it was installed.
It is executing the coreelec in the USB. I have it installed in the root of my tv box k1 pro.
I turn off my tv box, and turn it back on and I still have the old coreelec.

I do not know what I do badly.

I write the message.

I followed a tutorial, connecting through SSH. And I get this.

There is no working ¨installtointernal¨.
On CoreELEC -ng releases ´installtointernal´ has been replaced by ´ceemmc´

Please refer to the following link for more information.


If you use an USB or SD card to boot into CE, you don’t need to install to internal or use SSH. Also, the instructions about the device tree file need to be followed for CE to know what device to cater for.

Read this and find a method that works for you.


By SSH, I tried it, because by the first option, which you told me, it doesn’t do anything. Coreelec only opens, through the usb, it’s as if I used Coreelec on the usb and took it wherever I wanted.

It doesn’t update, I get a large black screen, I can’t see anything, I get the text, outside the TV frame.

Tonight I will try to try again, if I can. I’ll tell you.


Hold on there, you sound confused. What exactly are you trying to accomplish?

In one single post I read:

Update/upgrade an existing CoreELEC installation:

Boot from USB with a new CoreELEC installation:

Move a CoreELEC installation from USB to eMMC:

So can you please be clear and tell us what exactly it is you are trying to do?

Sorry beta tester.
I explain…? I have a TVBox Mecool K1 Pro, it had Libreelec installed in the root memory, (it does not have android).
Libreelec could not update and be able to go with the news of the multimedia content, and update Coreelec, with a tar file, which I put in the Updata folder, to be able to continue updating.
Right now, I have Coreelec version 9.2.8 Amlogic.arm installed in the root and I want to upgrade to 19.5-Matrix_rc2.

Libreelec is not compatible with CoreELEC.
Flash Vendor Android image on device and start again with a fresh install.

I suggest first try to see if CoreELEC 19.x works properly on the Mecool K1 Pro by only booting from USB Flash Drive.

If CoreELEC boots from USB or SD, then to install it to the TVBox, you’ll have to:

  1. reinstall the Android firmware
  2. follow the CoreELEC installation instructions for Generic Devices to create a CoreELEC 19.5 RC2 boot medium (SD, USB) for your device (S905D)
  3. use the ceemmc tool to migrate CoreELEC from USB or SD to eMMC. This is done via SSH

Those 3 steps you have to do because LibreELEC is incompatible with CoreELEC, meaning you can’t upgrade from Libre to Core.

I hope this takes the confusion away.

Everything you need to succeed is on those pages. Good luck.

Good morning.

Well, I had Libreelec, but I downloaded the ´TAR´ file and put it in the ¨update¨. And restart and Coreelec was installed.

When I load the image on the usb and connect it to my tvbox, I restart it, connecting the power cable and at the same time I press the power button, I get a black screen and because of the green of the tv and I can not see anything , as explained above. And I get CoreELEC 19.x, without any application.

I’m going to try from scratch, insert android and then install coreelc. I hope to do everything well and not make mistakes.

Thanks for the contributions, I thought that by inserting the tar file, coreelec was installed.

Thank you all. I’ll tell if I do the process well, I hope I don’t throw the box.