Bug: Playback Volume setting reset after restart

Reopening this issue: Playback Volume setting reset after reboot

I want to save the volume level across Kodi restarts and system reboots. This is not possible, even when using the Audio Profiles add-on and configuring it to save the volume level. After restarts, it will always default back to 0.0 db. I’d say this is a bug, since this is no problem using Kodi under Windows for example (even without any add-ons).

I’m using 19.5-Matrix_rc2 running after a clean install on an ODroid N2+.

Any help is appreciated.

Works here for me. I changed volume, marked as default, pressed closed, went back to main kodi window, rebooted. After reboot setting was still there.

Thank you for your reply. That’s very odd, as for me it is definitely not working.

To reconstruct:

  • did a completely clean install on an SD card with 19.5-Matrix_rc2
  • after boot and going through the welcome messages, started a movie (some random x264 DTS movie)
  • go to audio settings, change the volume level to “- 7.2 dB”
  • click “set as default for all media”
  • exit dialog boxes
  • stop movie playback
  • return to Kodi main window and reboot system
  • start the same movie again
    → volume level is reset to 0.0 dB
1 Like

Try the nightly version too: https://relkai.coreelec.org/

Just tried it with the nightly for the ODroid_N2 following the link you posted. Same result. After reboot and going back into the movie and the audio settings, the volume is reset.

Unable to replicate on Hardkernel Odroid N2+ with CoreELEC 19.5 RC2 booting from 32 Gb Sandisk μSD Card. Tested with Crackle and Disney+ addon.

Maybe try a different boot medium or clean the boot medium currently used.


:rofl: :rofl: :rofl: Change the settings you want and restart CE from the restart option in the menu, you will see that the changes are now saved :rofl: :rofl: :rofl:

Thanks for your reply.

It is really very confusing as to why this is not reproducible for you, since for me it is so easily and reliably reproducible. Therefore I have recorded a video to show exactly what I’m doing. I started, as you suggested, to wipe the SD card entirely and flash it again with 19.5-Matrix_rc2. On my main SD card it is the same issue so I don’t think the card itself is responsible for this.

Video recording: CoreElec Volume level not saved - YouTube

You can see that after the reboot the volume level is reset again.

Am I missing something obvious here?

Hey guys,
did you get a chance to look at the video recording which shows how to reproduce that issue quite easily?

Since I’m not the only one running into this issue (see link in OP) I still feel like this is a valid bug report.

Thank you in advance and keep up the good work.

I follow exactly same steps but can’t replicate the issue. Which doesn’t mean there is one.

After set the value and reboot check if you have any crash kodi log. This would explain why setting is not saved. But on clean install this is not very likely.

I’m not sure what to say, how can the issue not be reproducible for others on a completely clean install if for me that is apparently reliably possible? What can I do to try and find the cause of this issue?

So far can’t find any kodi crash logs. Where would they be? In the ./kodi/temp directory there’s just the kodi.log.

Could the sound device be relevant here? I have the ODroid connected via HDMI to an LG TV and the LG TV is outputting audio via HDMI ARC to a Yamaha soundbar. Passthrough is disabled.

Setting a fvolumelevel e.g. 0.0.880000 in the guisettings.xml seems to be ignored in the video player.

This is a really annoying issue for me, any help is really appreciated!

I’m not sure what to say.

Can you enable Kodi debug logging, change again the setting and then go back to Kodi home window. After that restart Kodi and post complete kodi.log to see if Kodi was shutdown correctly.

Btw: I think you need to stop Kodi before editing guisettings.xml like

systemctl stop kodi
# edit file guisettings.xml
systemctl start kodi

From your video
Looks like you are dragging mouse across volume.
You need to click once
So tab changes from grey to solid white

Then adjust and save

Happy Testing

When you change the setting is the value in /storage/.kodi/userdata/guisettings.xml changed?

Thanks for the swift replies.

Can you enable Kodi debug logging, change again the setting and then go back to Kodi home window. After that restart Kodi and post complete kodi.log to see if Kodi was shutdown correctly.

Did that, find the logs attached.
First log: starting up the system, launching a movie, changing the volume, set as default for all media, back to Kodi home, restart Kodi.
Second log: Kodi restarts, launch movie again, go to Audio settings and see that volume is reset (also audible even before going into the settings), close player and go back to home.
kodi1.log (406.7 KB)
kodi2.log (285.3 KB)

Thanks about the reminder to stop Kodi before making changes to the guisettings but I’m already aware of that.

When you change the setting is the value in /storage/.kodi/userdata/guisettings.xml changed?

Yes the value changes in the guisettings after changing it in the ui. After restarting Kodi, it is still saved in the guisettings but apparently ignored. Once you launch and quit the video player again the setting is reset to 1 in the guisettings.
Just to note again, everything is fine as long as I don’t restart Kodi. The setting is saved and I can watch multiple movies etc. without issue,

@freddy unfortunately I already did it this way, else I wouldn’t be able to close the dialog properly.

Have reset audio, to see what method of madness I have been using.

I used remote control to perform all functions

Change to Expert
Audio / enable passthrough

Start Playback
Enter Settings
Audio Settings
Volume/circle is solid white
Hit OK button
Circle is transparent
Adjust with d pad to -27.0 db
Hit OK button
Circle is solid white again
Move to Volume amplification
Repeat procedure…
Adjust with d pad to 27.0 db
Hit OK
Circle is solid white again
Move to
Set as default for all media
Close Settings
Stop Playback
Reboot CoreELEC to apply changes

*** Note Volume level can be affected/changed by keys on remote,or keys on keyboard. Possibly adjustment on TV remote/with Cec enabled.

Maybe will help

Happy Testing

In your case Kodi is not stopped correctly and maybe that’s the reason something doesn’t work as it should.
When I stop it last line in log file is

2022-11-08 08:49:23.364 T:3759     INFO <general>: XBApplicationEx: application stopped!

Run this two commands when Kodi is on main window and post the url you get.

systemctl stop kodi
systemctl status kodi -l --no-pager | paste

Interesting, for me it was also a bit unclear when to copy the log as I assume it will be overwritten after Kodi restarts.

Here’s the output: http://ix.io/4fj5

You know what: maybe I was thinking wrong. Restart Kodi and post kodi.old.log or whatever is called. This one should has everything inside. Because service status looks ok.

Here’s the full kodi.old.log
kodi.old.log (370.8 KB)

Flow is the same as before. In order to figure out what’s happening after the restart, kodi2.log from the previous post should still be valid.

Thank you again for looking into this, appreciate it.