CoreELEC 19 Matrix Discussion (Kodi RC)

thanks…good to hear its not just me!

Just tried on a N2 and C4 with latest nightly (16-01) and it resolves and connects fine by hostname.
Not saying you dont have an issue; i just cannot reproduce.

i am using the generic image, as i am running on an old s905x Mini M8s II. maybe the issue is just with the generic image. for me it was the 16/01 release that introduced the issue, all was fine before that. doing a clean install on a spare SD i had rather than update with tar didn’t help either…

Some minor feedback on CE Settings with CoreELEC-Amlogic-ng.arm-19.0-Matrix_nightly_20210116-Odroid_N2. I am unable to change the “Wait for network before starting Kodi” value. It starts with and continues to display 10 after changing it to any other value. This isn’t an issue for me as 10 seconds works fine, but just noticed it while messing around.

Can you see if you have any hosts blocks in your advancedsettings? changed smb dns lookups just before RC1 which it looks like CoreELEC rebased to before the Jan 16th nightly.

Will be fixed in next nightly.


thanks…i checked and dont think so, contents of my advanced settings below (with some > removed so you can see what is in!) - is there an entry i can add that will have kodi resolve correct IP in place of address it currently tries to connect it - note i have already tried adding ip and hostname (hostname 1 only) to my hosts.conf to no avail

               exportautothumbs>false/exportautothumbs>      <!-- Export auto-generated thumbs. Default = false. Change to true to allow export -->
               importwatchedstate>true/importwatchedstate>  <!-- Import Last Played and Play Counts. Default = false. Change to true to allow import -->
               importresumepoint>true/importresumepoint>    <!-- Import Resume Points. Default = false. Change to true to allow import -->

Hey! I have possibly a working solution for the CEC bug on Odroid C4 / N2 / N2+. Portisch helped me with this. After that I will try to enable bluetooth again, pair it and try to see this Kodi Settings addon not ready error again.

Thanks, currently i just use the backup addon to write to my PC for Kodi back up, will have a play with the corelec version. i use mysql on my PC as central DB for all my Kodi installs around the house tho, so don’t think this will back up any of the manual fixes i did on my music lib if i need to start from scratch with IP instead of host name on my sources. exporting the music lib in kodi doesn’t give me the .nfo in relevant media folders like it does when i export video lib, although not tried in 19 to see if any change there

1 Like

thank you sooo much! i checked the wiki for advanced settings and added a hosts entry…it fixed the issue. now kodi connects to correct ip when using host name in place of the spurious address it was using before, and i can play back library items again

thank you thank you thank you!!!

1 Like

Are there videos showing what’s new in Matrix ?

not seen any videos, only notable change i can see is that simple iptv client now has time shift, pause and rewind functionality…for me that was a big upgrade and allowed me to ditch NextPVR that was good, but took too much maintenance. now i don’t have to worry about updating each week to keep channels in sync, it happens automatically without the need to even restart kodi…

Thanks !
It seemed to me that the part dedicated to music had been improved as well?

anyone running other skin than estuary? if so, what’s your experience?

anyone running other skin than estuary? if so, what’s your experience?

Aeon Silvio, Amber, Unity all run smoothly with no surprising glitches at all.

Lyra bird mostly works fine.


Aeon Nox Silvo with lots of customization and artwork running well for me

Skin Aeon Nox Glass and Estuay MOD work on this CoreELEC version. For me they are better than the default ones.

I’m running Arctic Zephyr 2 Mod (pkscout) and it works great.